1. Caiben

    OP Caiben Newbie
    Newcomer

    Joined:
    Jun 26, 2017
    Messages:
    1
    Country:
    Sweden
    So i as so many got my hands on a SP (AGS-001) and a classic gba, mated their parts and got myself a working AGB with a lit screen, there is one issue i cant put my finger on tho.

    When i try to power on the unit it works, and sometimes it wont power on at all, i change batteries, nothing, change back and now the old batteries work... i turn of the unit and guess what... it wont start again, i then leave it as is to do other stuff, come back flip the switch and hey presto it works.

    I am at a loss... if anyone has any idea whats going on please share your thoughts.
     
    Last edited by Caiben, Jun 27, 2017
  2. malheur

    malheur Advanced Member
    Newcomer

    Joined:
    Oct 11, 2016
    Messages:
    58
    Country:
    i believe it's switch issue.

    GBA must be switched off correctly for next time turn on.

    for ie, it doesn't automatically turn on GBA with just remove batteries and put again while switch on. it must be turn off and on with switch. intended behavior. also that switch design is imperfect. many GBAs with these year has dust in it, need to cleaning. i think your problem came from aged switch.

    for cleaning power switch, http://blog.naver.com/PostView.nhn?blogId=xsnake&logNo=220765554565 it's korean but pictures will show the process.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - advice, Weird,