[TUTORIAL] My first CFW 3DS

Discussion in '3DS - Flashcards & Custom Firmwares' started by joex11, Aug 10, 2015.

  1. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    Hello all,

    Since I wasted some long hours getting to know how to, where to and all the details on how to install cfw on my n3ds and 2ds and everything else, I'll start this thread trying to help out who just got their 3ds and wants to install cfw.
    This tutorial will be update as the cfw scene develops. Any incorrect info or updated needed, please let me know. This is the last time I try to post something helpful here.

    FIRST OF ALL: IF YOUR 3DS IS IN ANY FIRMWARE OVER 9.2 (9.3 to 9.9) YOU CAN'T RUN ANY CFW ON IT YET!

    IF YOU HAVE AN O3DS 1.X TO 3.X:

    Your best option is to update your system through any game that has any firmware between 4.1 to 4.5 installed.
    Here you can find a list of which games have the update on cart, so you can buy/rent/lend or whatever and upgrade your firmware:
    http://www.3dsdb.com/

    IF YOU HAVE AN O3DS OR 2DS 4.X TO 9.2:

    Your best option is use RxTools. Open rxtools.net and follow the instructions. This exploit uses browser only.
    You can also use Reinand, PastaCFW, CakesFW. For more information read their threads.

    IF YOU HAVE A N3DS ON 9.0 TO 9.2:

    Your best option is Reinand or Pasta CFW. Currently, to be able to run CFW on n3ds you NEED a copy of cubic ninja or zelda: oot. For more information read their threads.
    Currently, Gateway and Reinand have mset support, which lets you use cubic ninja only once. After the mset is installed, the old system > profile > nintendo ds exploit is activated and you can boot the CFW that way.

    HOW TO INSTALL CFW WITH NINJHAX:

    Insert your Cubic Ninja cart (sky3ds works too) on your console. Open www.smea.net/ninjhax and insert your 2ds/3ds firmware info and generate the QR CODE. In cubic ninja, go to create - qr code - read qr code and read your generated code. Ninjhax will install and you can now install your favorite CFW. READ THE INSTRUCTIONS ON HOW YOUR CHOSEN CFW WORKS AND WHAT FILES YOU NEED TO COPY! So, in order:

    1 - Get Ninjhax files
    2 - Get your CFW files
    3 - Put them in your 3ds SD CARD
    4 - Do the stuff I wrote above
    5 - ENJOY™


    CFW'S DIFFERENCES (up until 10/08/2015)
    RXTools - o3ds and 2ds only - has emunand - may support n3ds in the near future - "merged" with pastacfw
    Reinand - all 3ds models - has emunand - supports n3ds mset - open source
    PastaCFW - all 3ds models - no emunand - "merged" with rxtools
    NTR CFW - all 3ds models - no unsigned code - supports out of region cias
    GATEWAY - all 3ds models - requires red gateway cart - has emunand - support n3ds mset
    CakesFW - o3ds an 2ds only - has emunand - mset - .cake format that you won't eat anywhere else

    USEFUL LINKS:
    RXTOOLS Thread - https://gbatemp.net/threads/release-rxtools-roxas75-3ds-toolkit-fw-2-0-9-2.382782/unread
    Reinand - https://gbatemp.net/threads/realease-reinand-cfw.391663/
    PastaCFW - https://gbatemp.net/threads/pasta-c...ld-and-new-3ds-required-ninjhax.388925/unread
    CakesFW - https://gbatemp.net/threads/release-cakesfw.391200/

    Q) I have a 9.3-9.9 3ds, can I-
    A) NOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

    Q) Will CFW ever be able on 9.3+?
    A) My crystal ball says it's right around the corner™.

    Q) How close is right around the corner™?
    A) Soon™.

    Q) I just spent 80$ on my brand new Sky3ds! Now I want to play the new Fire Emblem english patched! How can I do that?
    A)... You can't. Nintendo has a pirate check on new games that sky3ds won't be able to decrypt without hardware revision since the card isn't updatable.

    Q) Damn... But I can still play my SMT 4 Undub, right?
    A)... No... Sky3ds doesn't support edited roms. Only original untoched roms.

    A) Can I at least play eshop games on my 3ds with sky3ds?
    A)......................................................no
     
    Last edited by joex11, Aug 11, 2015
  2. mid-kid

    mid-kid GBAtemp spamBOT

    Member
    879
    962
    Aug 2, 2012
    Where's the delicious cake? ;_;
     
    Ronhero and Vappy like this.
  3. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    i am diabetic, no cake for me :(
    sorry I forgot, I'll edit now
     
  4. Konno Ryo

    Konno Ryo gbatemp's clueless butler?

    Member
    158
    162
    Aug 5, 2015
    Canada
    Somewhere?
    Soon™, Gateway said that to once, so I'll get my cfw in about 2 years. By then we will all have NNNN3DSes. :glare:
     
    mrolive and joex11 like this.
  5. WhoAmI?

    WhoAmI? PASTA's dirty animal

    Member
    1,273
    1,009
    Mar 15, 2015
    Poké Ball
    Bad idea. If they're on 1.x, what are the chances of them having the web browser? Game cards don't update the web browser. What if they update to a firmware that Ninjhax doesn't support, no mset exploit and no browser? They're sorta screwed ._.

    Should change it to this:

    Your best option is to update your system through any game that has any firmware between 4.1 to 4.5 installed.
     
  6. PandaMayFire

    PandaMayFire GBAtemp Regular

    Member
    287
    86
    Jan 24, 2015
    United States
    1.x firmware? I didn't even know consoles like that existed, how do you manage to score a console on 1.x firmware?
     
  7. WhoAmI?

    WhoAmI? PASTA's dirty animal

    Member
    1,273
    1,009
    Mar 15, 2015
    Poké Ball
    With great difficulty. When I got my console ~2-3 years ago, it was on 1.x. At that time, I think 4.x was a thing? I dunno...

    Edit: Someone scored a 1.x system the other day xD
     
  8. LurkerA

    LurkerA ㊣New3DS

    Member
    295
    68
    Apr 8, 2010
    United States

    Your sky3DS can still play - "Fire Emblem if" by PastaCFW on N3DS V9.2 and below anyway. see video here: https://sky3dslatestupdates.wordpre...-support-fire-emblem-if-anya-oukokuawakening/
     
  9. usernametaken

    usernametaken GBAtemp Maniac

    Member
    1,250
    345
    May 13, 2015
    United States
    Xenon Hacks likes this.
  10. Loaffy

    Loaffy GBAtemp Regular

    Member
    136
    47
    Mar 27, 2015
    Canada
    Are you referring to using OOT with a gateway card, or is oot able to launch other cfws already and I've missed something?
     
  11. duwen

    duwen Old Man Yoshi

    Member
    1,165
    649
    Sep 6, 2013
    United States
    Bullet Hell
    Thanks for this Tutorial - it's come just at the right time for me, as (hopefully) today I'll be trading in my o3ds on 9.9 for an o3ds on less than 9.2.
    Some advice though, please: I'm quite happy with my Sky3ds on my 9.9 n3dsxl for playing retail cart stuff, so a cfw on an old model will primarily be for homebrew, eshop titles and custom (translated, undubs, etc) roms... which cfw would suit my purposes best?
    I run Cubic Ninja on my Sky card, so that's an option, but I'd rather have the convenience of mset so my Sky can stay in my n3dsxl.

    Hopefully, I'm not jumping the gun here and getting my hopes up that I'll be able to actually score a <9.2 o3ds that I can trade my 9.9 o3ds for locally... I'm instead taking the timely nature of this thread as a sign that it's meant to be!

    edit

    It's also worth pointing out that I've got an Acekard2i that I'd like to unblock, and (from what I've read) may also aid the installation of cfw's.
    And another question; presuming that I won't be lucky enough to score an o3ds on 4.x or lower fw, is it advisable for a noob to this branch of 3ds hacking (like me) to go through the sysnand downgrade process that I've read about?

    2nd edit

    For the results of my shopping trip see here
     
    Last edited by duwen, Aug 11, 2015
  12. LurkerA

    LurkerA ㊣New3DS

    Member
    295
    68
    Apr 8, 2010
    United States
    It doesn't really matter if it's by PastaCFW and the .cia, just answered "How can I do that?" with sky3DS.
     
  13. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    That kinda beats the concept of sky3ds being the plug and play cart with support to the last firmware. I don't think many people use sky3ds and 9.2, since gateway works on 9.2 and does much more things.
    The card can't plug and play fire emblem and any hacked roms. Only CFW can.

    Your best CFW in my opinion would be RXtools, since it has browser entry point and is being updated frequently. In your case, I'd recommend installing rxtools, getting a big sd card and using it on your o3ds to install cias. A class 10 would be best. And then you can just copy your .cia games, install and have fun without the need of anything. mset is being developed by rxtools (maybe it's done) and that would even end the need of a internet if you power off your console. To unblock your acekard2i, just get the fix someone here released that unblocks all ds cards (cia format).

    Also look for 3ds with 4.x to 9.2 firmware. They are best on hacking terms, since a 1.x to 3.x would need a update from any card with fw installed. If you follow the tutorials here on gbatemp, you should be mostly ok.
     
    Last edited by joex11, Aug 11, 2015
  14. usernametaken

    usernametaken GBAtemp Maniac

    Member
    1,250
    345
    May 13, 2015
    United States
    It does matter, because it's not the Sky3ds playing the game, because it can't. It's how can I play Fire Emblem: IF? - You can play it using cfw; booting into it using cubic ninja. :teach:
     
    joex11 likes this.