Hacking Trouble with certain games on USB Loader GX

elevenism

Member
OP
Newcomer
Joined
Aug 11, 2018
Messages
19
Trophies
0
Age
41
XP
107
Country
United States
This is going to be a painfully noobish post; my apologies in advance.

So i had a homebrewed wii (the black, newer one.)

Everything worked on it (all emulators) EXCEPT USB loader. it froze immediately no matter what.

I was going to order an old wii and try starting over, but then i saw a guy selling HIS hacked wii (with USB Loader GX, plus a 1tb hard drive full of Wii and GC games for pretty damn cheap, so i went for it and bought it from him.

Now. All of the wii games are in wbfs format. There is a LOT of shovelware and kiddie games on the HD, so i decided i would like to delete some of those and add others.

Everything was going fine: i added MadWorld, Kolona, and Wii Sports Resort.

But then i tried adding Red Steel 2. The title screen appears, but when i try to start the game, it sends me back to the wii menu. Same goes for Xenoblade Chronicles.

And Dead Space Extraction just gives me a black screen.

I'm afraid to fuck with this wii TOO much because of how much i paid for it.

Does anyone have any ideas about how to fix this?
 

Maxbeta

Well-Known Member
Member
Joined
Jul 20, 2014
Messages
340
Trophies
0
XP
1,202
Country
United States
I'm not in front of my Wii right now but if you go into USB Loader GX settings and look for something that says Games Loader IOS and set it to 249.
I had the same issues with Xenoblade Chronicles and others and that sure fixed it.

Hope it works for you.
 
  • Like
Reactions: elevenism

elevenism

Member
OP
Newcomer
Joined
Aug 11, 2018
Messages
19
Trophies
0
Age
41
XP
107
Country
United States
Thanks. I will try it.

I managed to get Dead Space- Extraction going; I think that was just a bad print/dump.

I've tried multiple copies of Red Steel 2 with no luck and the same goes for XC.

I'm going to give it a shot here shortly, @Maxbeta .

Meanwhile, if an admin sees this thread, is there any way she might move it to the appropriate part of the forum?

I'm new here but I'm damn sure not new to forums, and this is embarrassing :/
 

elevenism

Member
OP
Newcomer
Joined
Aug 11, 2018
Messages
19
Trophies
0
Age
41
XP
107
Country
United States
Sorry for double post, but ok:

The game and loader's IOS are both set to 249.

Every game I've tried works, and I couldn't be happier except for one thing:

I can't play Red Steel 2 or Xenoblade Chronicles.

I've seen others say that Red Steel 2 was the only game that wouldn't run on USBLGX.

I've tried deleting, redownloading and reinstalling both of these games several times, to no avail. Both games show the title screen, but back out of USBLGX when I hit start.

I know that some people have been able to play these games on this program, so I either keep coming across the same bad files, or I've got some little option wrong
 

kumikochan

Well-Known Member
Member
Joined
Feb 4, 2015
Messages
3,753
Trophies
0
Age
33
Location
Tongeren
XP
3,311
Country
Belgium
Sorry for double post, but ok:

The game and loader's IOS are both set to 249.

Every game I've tried works, and I couldn't be happier except for one thing:

I can't play Red Steel 2 or Xenoblade Chronicles.

I've seen others say that Red Steel 2 was the only game that wouldn't run on USBLGX.

I've tried deleting, redownloading and reinstalling both of these games several times, to no avail. Both games show the title screen, but back out of USBLGX when I hit start.

I know that some people have been able to play these games on this program, so I either keep coming across the same bad files, or I've got some little option wrong
I just checked on my Wii U using usb loader gx and red steel 2 works fine on it. There's is probably something wrong with your installed cios. Maybe not all are installed or not installed correctly. I would look up how to install those to all the latest since i'm pretty sure it has to do with that.
Here's a guide for that https://sites.google.com/site/completesg/backup-launchers/installation. Make sure you use the one for the Wii and not for the Wii U or you'll brick
 
Last edited by kumikochan,
  • Like
Reactions: elevenism

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,422
Trophies
2
Age
43
Location
Engine room, learning
XP
14,524
Country
France
I moved the thread to Wii Loader section.

So, I think your console has an outdated softmod.
old cIOS weren't compatible with some "dol reloading" games, such as SSX, sam&max, metroid prime trilogy, or Red Steel2 !
when launching a game it just returns to the system menu. There is a fix to still use old cIOS with these games, but it's easier to update your softmod.

But, xenoblade shouldn't have that issue. maybe it's a bad dump, like deadspace? You can verify your dump with WiiBackupManager>sha1 option.


So, I think before doing anything we will check what you currently have.
could you follow the syscheck guide in my signature and post the result here, please?

or, re-softmodding is a solution, like following the link posted above.
 
Last edited by Cyan,
  • Like
Reactions: elevenism

elevenism

Member
OP
Newcomer
Joined
Aug 11, 2018
Messages
19
Trophies
0
Age
41
XP
107
Country
United States
I was actually able to get Red Steel 2 to work as well,.by watching the Wii motion plus video on Sports Resort.

The ONLY game I can't seem to run is Xenoblade Chronicles, but it probably IS a bad dump.

I can't see any other reason why it wouldn't work.
 
  • Like
Reactions: Cyan

GreyWolf

Well-Known Member
Member
Joined
Mar 2, 2015
Messages
5,401
Trophies
0
Age
51
XP
1,474
Country
United States
I was actually able to get Red Steel 2 to work as well,.by watching the Wii motion plus video on Sports Resort.

The ONLY game I can't seem to run is Xenoblade Chronicles, but it probably IS a bad dump.

I can't see any other reason why it wouldn't work.

You can test the Xenoblade image using Wii Backup Manager (Tools>SHA-1 Hash) or Wiimm's ISO Tools ("wit verify <filename>").

WBM will show the game title in green on the right window if it's good. WIT tells you "OK" for each partition if it's valid.
 
  • Like
Reactions: elevenism

elevenism

Member
OP
Newcomer
Joined
Aug 11, 2018
Messages
19
Trophies
0
Age
41
XP
107
Country
United States
You can test the Xenoblade image using Wii Backup Manager (Tools>SHA-1 Hash) or Wiimm's ISO Tools ("wit verify <filename>").

WBM will show the game title in green on the right window if it's good. WIT tells you "OK" for each partition if it's valid.
Thanks man. I can't believe how helpful this community is.
 
General chit-chat
Help Users
    SG854 @ SG854: Nintendo Online Expansion sucks