Trouble creating Package Installer bubble

Discussion in 'PS Vita - Hacking & Homebrew' started by sj33, Mar 13, 2016.

  1. sj33
    OP

    sj33 GBAtemp Addict

    Member
    2,714
    1,717
    Oct 22, 2013
    Japan
    I'm following this guide over at HackInformer to create a bubble for the package installer.

    http://hackinformer.com/PlayStationGuide/PSV/tutorials/how_to_create_the_pkg_installer_bubble.html

    It seems very easy, until I get to Step 3: 11. It says I need to set the email subject to the path I want the file to be installed to. I assume this is 'ur0:shell/db/app.db.' so I set it as this. However, I then follow the instructions, restart the console as stated, yet no bubble appears.

    Any idea what I'm doing wrong?
     
  2. Voxel

    Voxel Fable Junkie

    Member
    GBAtemp Patron
    Voxel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,199
    5,925
    Jun 27, 2015
    United Kingdom
    England, UK
    remove the full stop from the end of 'ur0:shell/db/app.db.' so it is just 'ur0:shell/db/app.db' without a full stop. full stops are only used for dumping.

    Unless that was a typo?
     
  3. MDashK

    MDashK GBAtemp Regular

    Member
    219
    58
    Jul 22, 2011
    Internetus Exploratis
    As Voxel said: the full-stop is the issue. Check the screenshot in the tutorial, you'll see there is no full-stop in the e-mail subject.
     
  4. sj33
    OP

    sj33 GBAtemp Addict

    Member
    2,714
    1,717
    Oct 22, 2013
    Japan
    It still doesn't appear when when writing the subject path without the '.'

    I'm not sure what I'm doing wrong.
     
  5. MDashK

    MDashK GBAtemp Regular

    Member
    219
    58
    Jul 22, 2011
    Internetus Exploratis
    Last edited by MDashK, Mar 14, 2016
  6. sj33
    OP

    sj33 GBAtemp Addict

    Member
    2,714
    1,717
    Oct 22, 2013
    Japan
    Do you mind if I send my db your way? I'm very sure I'm doing everything correctly, I've specified the number values (though this appears to be automatic), and the databse is not being rebuilt.
     
    MDashK likes this.
  7. MDashK

    MDashK GBAtemp Regular

    Member
    219
    58
    Jul 22, 2011
    Internetus Exploratis
    Check your PM.
     
  8. MDashK

    MDashK GBAtemp Regular

    Member
    219
    58
    Jul 22, 2011
    Internetus Exploratis
    I believe this thread can be closed, the issue has been resolved.

    I'll leave this info here for future reference, in case someone needs it.


    Following values were fixed in app.db:

    Values on the tbl_appinfo_icon table.
    "pageID" and "pos" values for the entry of package installer we're both 10/10.
    pageID was changed to 6; pos to 9; and added missing values "5" "0" and "0" to the entry of the table.

    Always remember that "pos" value goes from 0 to 9, 10 does not exist.
    "pageID" was change to match with other titles already installed in the system. Of course, this can then be freely moved around in the LiveArea.
     
    Voxel likes this.