This cia is invalid...Dev tool import failed

Discussion in '3DS - Homebrew Development and Emulators' started by Sony98, Jul 11, 2015.

  1. Sony98
    OP

    Sony98 Member

    Newcomer
    14
    1
    Apr 3, 2015
    Gambia, The
    jeah hello guys.
    I have a Old 3ds Xl with Gateway ultra 3.2.2
    Sysnand:4.5 Emunand: 9.8 (Unlinked)

    I can install any game, dlc, homebrew, or modded Devtools like Devmenu 2.x. cias
    But i still can not install any Devtool.

    If i try to install a devtool with Devmenu, i get this error:

    Import failed. File: sdmc:/*****
    Level: LEVEL_PERMANENT( -5 )
    Summary: SUMMARY_INVALID_ARGUMENT( 7 )
    Module: MODULE_ NN_AM( 32 )
    Desc: <unknown> ( 106 )

    If i try to install a one with FBI, this error comes:

    Install failed !
    Could not install app.
    Raw Error: 0xd8e06a
    Module: AM (0x20)
    Level: Permanent (0xib)
    Summary: Invalid argument (0x7)
    Description: Invalid signature (0x6a)

    If i try to install a one with Bigbluemenu, i get this error:

    Install failed !
    Could not install app.
    Raw Error: 0xd8e06a
    Module: AM (0x20)
    Level: Permanent (0xib)
    Summary: Invalid argument (0x7)
    Description: Invalid signature (0x6a)

    nobody on Maxconsole know anything about that or can help me :(
    Is it because i was one time banned for 15 days from Nintendo network ?
    Or is it because the Region ? I have a EU Console.

    I tryed to renew install Sysnand and new formatted Emunand, deleted my complete System, and formatted my sd card new....nothing happens.

    Does anyone know anything about that and how i can solve that Problem ? Because i want to change my ACNL Header with Savedatafiler....
     
  2. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    I cant link you to any CIA's here but search bigbluemenu digiex on google and download the files from the first link. put the 3ds version on your red card and the CIA version on your sd card run bbm from your red card like a game by pressing select while in Emunand and install bigbluemenu cia to your Emunand you can find it in the sdmc tab in whatever folder its in.
     
  3. Sony98
    OP

    Sony98 Member

    Newcomer
    14
    1
    Apr 3, 2015
    Gambia, The
    it looks like you didnt read my post complete.
    I already installed BBM and got an error.
     
  4. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    Ok then what "devtool" are you trying to install that would be a nice start.
     
  5. Dartz150

    Dartz150 GBATemp Official Lolicon Onii-chan™

    Member
    1,406
    845
    May 5, 2010
    Mexico
    On a Strange Journey
    I think he wants to install some SDK devtools like settings.cia or wifisettings.cia, there is a pack with all the .cias contained on a 3DS devkit floating on the web already.

    The file is called 3DSDevKit.rar by the way.
     
  6. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    Im aware of that but if hes using devmenu and converting all the csu's correctly he should not have any issues
     
  7. Dartz150

    Dartz150 GBATemp Official Lolicon Onii-chan™

    Member
    1,406
    845
    May 5, 2010
    Mexico
    On a Strange Journey
    I see, but some of the files contained in that download are already in .cia format, so no need to convert.
     
  8. Sony98
    OP

    Sony98 Member

    Newcomer
    14
    1
    Apr 3, 2015
    Gambia, The
    Bigbluemenu, Govanys Devmenu 2.x and FBI i already installed.
    But i still cant install any Developer unit Software like this: http://3dbrew.org/wiki/3DS_Development_Unit_Software
    Jeah, the files i downloaded are in .cia and .csu inside the pack.
    Always if i try to import a .cia, it stop at 80-95 % and shows the error.
     
  9. TidusWulf

    TidusWulf Real Aloha

    Member
    598
    232
    Jul 27, 2007
    United States
    Hawaii
    Having this problem, too.
     
  10. redunka

    redunka GBAtemp Regular

    Member
    290
    136
    Nov 26, 2014
    Russia
    You can't install dev software in .cia, unless you have Dev Unit.
    If you have regular 3ds, you can install only cia converted from csu.
    There is a tutorial how to do it.
     
    Voxel likes this.
  11. Voxel

    Voxel Clumsy Coder

    Member
    GBAtemp Patron
    Voxel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,181
    5,841
    Jun 27, 2015
    United Kingdom
    England, UK
    lol, that's my tutorial! :P
    It's a pretty useful tutorial for if you don't know what you're actually doing. :)

    OP, All you have to do is just convert the .CSU files into CIA using the 3DS to CIA converter from maxconsole. Then you should be good to go!
    Unfortunately, you will have to mess around with the rsf files (you have to make unique IDs for them to all install.)
     
    Last edited by Voxel, Nov 16, 2015
    redunka likes this.