1. Kokumotsu

    OP Kokumotsu Advanced Member
    Newcomer

    Joined:
    Jan 15, 2013
    Messages:
    54
    Country:
    United States
    So i had an issue with my switch no longer being able to dock and i sent it off to a reputable repair service. Shanefix, a recommended repairman from Tronixfix)
    and before i sent my switch off nothing was wrong other than docking. He gets the switch and tells me that its no longer wanting to charge and will no longer turn on.
    He said he replaced the common chipsets and the P13USB but did not fix the issue.
    I told him to send it back and it indeed charges and turns on. I am able to get it into RCM mode and boot into Hekate but thats all i can do.
    The device will no longer display a battery icon on the top left when off displaying the switch is charging. It will no longer boot into CFW or even stock. It just black screens without any backlighting. it does not even display the nintendo logo or can even get into recovery mode.

    Is there anything on my end that i can do to fix this issue or is it just a motherboard/cpu issue?
    I plan on getting a 12 pin USB C test board to measure the voltages but im stumped on this one.
     
  2. Modificatorul

    Modificatorul GBAtemp Regular
    Member

    Joined:
    Oct 28, 2009
    Messages:
    259
    Country:
    Russia
    "no longer being able to dock" means charghing but no display on tv but working in portable mode?
    Contact @Mena for a second opinion and inspection off the mb.
     
  3. Deleted User

    Deleted User Newbie

    I would try booting Lakka. If you can boot Lakka then you have a software issue.
     
  4. Kokumotsu

    OP Kokumotsu Advanced Member
    Newcomer

    Joined:
    Jan 15, 2013
    Messages:
    54
    Country:
    United States
    Yeah that was pretty much the case before i sent it off for repair.

    I will give that a shot later today, but i tried booting stock OS and i even did a nand backup of the emmc from before i sent it off and restored from that and nothing. i dont think it could be software at that point but ill try. i even verified that the nand chip itself intact and it was listing all the information and benchmarking fine in Hekate.
    though hekate will not let me mount the nand on the computer at all i get a Lzma Decompression error.

    *edit Lakka does not boot either, it will display the lakka/Hekate splash with the logo on the bottom right then go black screen without a backlight too.
     
    Last edited by Kokumotsu, Sep 9, 2020
  5. Modificatorul

    Modificatorul GBAtemp Regular
    Member

    Joined:
    Oct 28, 2009
    Messages:
    259
    Country:
    Russia
    Run Lockpick_RCM obtain bys keys
    https://github.com/shchmue/Lockpick_RCM/releases

    Use this guide only for HacDiskMount
    https://gbatemp.net/threads/how-to-...nofficially-without-burning-any-fuses.507461/

    Mount your nand backup with https://files.sshnuke.net/HacDiskMount1055.zip

    Decrypt and save prodinfo.

    Then open the prodinfo with https://mh-nexus.de/en/downloads.php?product=HxD20

    Look for your serial number.

    prod info.jpg

    Compare the serial number with the one on the tablet.

    P.s
    If you already have biskeys obtianed in the past just compare with the new one obtained after you recived back
    This will not help you repair the hardware problem.
     
    Last edited by Modificatorul, Sep 9, 2020
  6. Kokumotsu

    OP Kokumotsu Advanced Member
    Newcomer

    Joined:
    Jan 15, 2013
    Messages:
    54
    Country:
    United States
    BIS keys and Serial is the same as before i shipped it, so the motherboard has not been maliciously swapped.
     
    Last edited by Kokumotsu, Sep 9, 2020
    Modificatorul likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - booting, Switch, longer