rxTools for dummies

Discussion in '3DS - Flashcards & Custom Firmwares' started by Quantumcat, Jul 22, 2015.

  1. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Does anybody have a link to an rxTools tutorial that is easy to follow? I am so lost. I have followed the pdf that came in the rxTools download and have managed to get to here:

    To clone the repository, run the following command:
    git clone --recursive https://github.com/roxas75/rxTools.git
    Then cd to the rxTools folder:
    cd rxTools
    And build rxTools:
    make
    make theme

    When I try "make", I get:

    [​IMG]

    I have tried downloading and installing and adding to PATH everything under the sun. I am running command prompt as administrator. What else can I do?

    I want to run rxTools with emuNAND on my old 3DS XL with firmware 6.1.12E. And have a downgraded mset if possible.

    Thanks!!
     
  2. Amadren

    Amadren SOMEBODY ONCE

    Member
    287
    127
    Dec 21, 2014
    France
    Paris, France
    You should install make for windows.

    But why do you want to compile it? You can download rxTools from rxtools.net ^^
     
  3. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Where? It looks like only an old version. The newest seems to be on page 363 of the rxTools thread. I was following the pdf that came with it. Should I download the older one off the rxTools site?

    And how do I install make for windows? (Although if I don't have to compile anything that's great)
     
  4. Amadren

    Amadren SOMEBODY ONCE

    Member
    287
    127
    Dec 21, 2014
    France
    Paris, France
    There4s q tut here that guide through the process of compilling rxtools. Also, you downloaded the sources. If you want the latest stable version, download it from rxtools.net. If you want to compile it, use linux, it's the easier way. If you want to compile it in windows, follow the guide on gbatemp. If you want the latest beta version (DON'T DOWNLOAD THE 3.0 ALPHA 0 PLIIIIIIIZ), it's here: https://github.com/roxas75/rxTools/releases #USE BETAS/ ALPHA AT YOUR OWN RISK#.

    The version available in rxtools.net is the latest stable one ;)
     
    Quantumcat likes this.
  5. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Thanks very much, I'll get the one off the rxTools site!
     
  6. Amadren

    Amadren SOMEBODY ONCE

    Member
    287
    127
    Dec 21, 2014
    France
    Paris, France
    You're welcome :)
     
    Quantumcat likes this.
  7. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Still have trouble - how do I make it so I can launch through the DS profile exploit? I only ever used Gateway through the web browser so I don't have experience. I installed mset from the rxTools menu, and launched the .nds file from the download, but when going to DS Profile it didn't work (said software had an error and the system will restart). I also found something about putting a text file called ticket.db in a particular place and I did that, but it didn't work either. What do I need to do?
    Thanks :-)
     
  8. Amadren

    Amadren SOMEBODY ONCE

    Member
    287
    127
    Dec 21, 2014
    France
    Paris, France
    Sorry never did it :c
     
  9. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Bump. Anyone? Link to tutorial on setting up the DS profile exploit would be great or just explain it to me here.... please? :-)
     
  10. Koryushin

    Koryushin GBAtemp Regular

    Member
    176
    46
    Mar 26, 2015
    France
  11. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Thanks for helping, but it didn't work :-( I installed it with my DSTwo, and tried 4.x first, didn't work (DS Profile says there was an error and the system has to restart), then tried 9.x and same thing (I didn't think it would work as the system is 6.2 and I installed the 4.x mset from the rxTools menu). The 4.x mset file disappeared after installing it, so that means it worked, right? I will try installing the mset again.

    Also, I followed this tutorial: https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/ and it said to add ticket and import.db. I had done this before but they were text files, I fixed them to be proper db files. This didn't help.
     
    Last edited by Quantumcat, Jul 24, 2015
  12. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
  13. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Use the 6.x MSET if youre above 5.x
     
  14. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    Thanks! It won't let me install the 6.x mset though as it says I'm already on an exploitable version. I tried formatting the system, and it didn't help.

    — Posts automatically merged - Please don't double post! —

    I tried this, and it got stuck on couldn't find the theme files. I found a reply saying to delete the theme zero folder but that didn't help.
     
  15. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    I found this:
    Is this safe to do if I already installed 4.x mset, to change to 6.x?
     
  16. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    I never used the rxtools tool, because it never worked, I just got the cia of the 6.x MSET and installed it with FBI. Worked like a charm

    And yes, changing from 4.x to 6.x should be safe
     
  17. samiam144

    samiam144 RĂ©gulier

    Member
    2,871
    936
    Aug 19, 2007
    Canada
    If you were already on 6.2, you didn't have to do any of that. Just load the rxCakesROP.nds file with your DS flashcard and select "6.X MSET"
     
  18. Quantumcat
    OP

    Quantumcat Dead and alive

    Member
    11,520
    6,189
    Nov 23, 2014
    Australia
    Canberra, Australia
    So I don't need to get rid of the 4.x mset? Where is rxCakesROP.nds? It isn't in 2.6, 3.0 beta 7, or 3.0 beta 8. Nothing comes up when I Google search, and the only result in this forum is this thread. I found a rxToolsCakesROP.nds but it only has 4.x or 9.x mset options.
     
  19. samiam144

    samiam144 RĂ©gulier

    Member
    2,871
    936
    Aug 19, 2007
    Canada
    Well you don't NEED to get rid of 4.x MSET I think, but what I'm saying is that you didn't have to downgrade mset from 6.x in the first place. The rxCakeROP.nds is in beta 7, I just checked. And it does have 6.X mset options for me so idk what's happening for you. But anyways, since you downgraded to 4.x mset, then just use the 4.x mset option.