RG-300 V1.3 (grey model) & CFW : not working

eldontyrell

Member
OP
Newcomer
Joined
Aug 18, 2017
Messages
21
Trophies
0
Age
50
XP
135
Country
Belgium
Hello,

I just received the new RG-300 v1.3 handlheld and installed the CFW from this page:

https://jutleys.wixsite.com/retrogamers97-90

I installed it on a 32gb samsung card. I even tried on another one, thinking it was dead.
But same result : white screen, RetroFW is not booting.

Has anyone else encountered the same problem ?
Any tip to how to fix it ?
Is it a new hardware revision which still has to be taken into account (new build) ?

Thanks,

Stephane
 

xiao4914

New Member
Newbie
Joined
Aug 15, 2019
Messages
2
Trophies
0
Age
41
XP
39
Country
Japan
The CFW new comic book doesn't work
for my RG-300 (RG_300_V1.3 2019.6.3) gray color.

The microsd I used is toshiba 32gb.

thanks.
 

eldontyrell

Member
OP
Newcomer
Joined
Aug 18, 2017
Messages
21
Trophies
0
Age
50
XP
135
Country
Belgium
At least another member who has the same problem :) I also used a 32gb SD. Not sure it's the reason why it does not work... Pretty sure it needs a new build for this new hardware revision.
 

DeViaNCe_44

New Member
Newbie
Joined
Aug 17, 2019
Messages
4
Trophies
0
Age
34
XP
36
Country
France
Hi Guys,
After flashing the firmware from Droidboxforums I had the same issue : white screen at first boot.
Then I tried the one from jutleys wixsite by clicking on RG300 V2 (mine is the updated console, received today), it works like a charm now. Just had to replace Gpsp by the much better reGba ;)
Hope it helps !
Peace
 

eldontyrell

Member
OP
Newcomer
Joined
Aug 18, 2017
Messages
21
Trophies
0
Age
50
XP
135
Country
Belgium
It's weird. That's the firmware I have used and it gives me a white screen.
Maybe I have a newer hardware revision then?
 

DeViaNCe_44

New Member
Newbie
Joined
Aug 17, 2019
Messages
4
Trophies
0
Age
34
XP
36
Country
France
Indeed, that's weird. Next to the internal Sd I can see V1.3 2019.6.3 written on my motherboard.
I flashed the 16GB Sd and put it in the internal slot if that can help.
 

eldontyrell

Member
OP
Newcomer
Joined
Aug 18, 2017
Messages
21
Trophies
0
Age
50
XP
135
Country
Belgium
Indeed, that's weird. Next to the internal Sd I can see V1.3 2019.6.3 written on my motherboard.
I flashed the 16GB Sd and put it in the internal slot if that can help.

Ok. Difference is that I used a 32gb SD. But I'm not sure it's the reason why it does not work. I have the same v1.3 revision.
 

xiao4914

New Member
Newbie
Joined
Aug 15, 2019
Messages
2
Trophies
0
Age
41
XP
39
Country
Japan
Hello. I'm Sad.
I downloaded and flashed cfw from
a gray RG-300 picture of jutleys wixsite
using a 16gb microsd card.
However, the screen remained white
when the power was turned on.
 

eldontyrell

Member
OP
Newcomer
Joined
Aug 18, 2017
Messages
21
Trophies
0
Age
50
XP
135
Country
Belgium
Hello !
Ok I did something here. I flashed firmware on my 32gb SD card. Then I used minitool to allocate space on the big unallocated partition (fat32). And now RetroFW is running fine on my rg-300 v1.3 !
Hope this helps.
 

geuss79it

New Member
Newbie
Joined
Apr 30, 2020
Messages
1
Trophies
0
Age
43
XP
28
Country
Italy
Hi! I'have the same version of RG300 (v.1.3 2019.6.3). I accidentally erased the original SD card... Can you tell me where I can download it (or share me it)? Thanks so much!!
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    K3N1 @ K3N1: https://youtube.com/shorts/LbCYxWgi9hw?feature=share