Retroarch Wii not saving input settings

Discussion in 'Wii - Emulation and Homebrew' started by DenverNugs, Oct 11, 2014.

  1. DenverNugs
    OP

    DenverNugs Newbie

    Newcomer
    5
    5
    Sep 12, 2014
    United States
    I just have a simple problem. On the occasions where I want to emulate NES on the wii I used to use FCEUltra GX. Recently I've started using Retroarch with the Nestopia core because of better scaling options on my CRT TV. Almost everything is perfect with it, but one main problem is it won't save my custom input options. All I really want to do is use Y=B and B=A on the classic controller to have a more comfortable NES style button layout.

    I can switch it just fine but it just doesn't seem to stick after exiting the emulator or powering off the wii. Having to change it every time I want to load up a game is cumbersome. I've done some searching and can't really find anyone having the same issue. The only thing that comes up is that Retroarch should save the settings once I exit the program.

    I've tried configuring before and after loading the rom and have no luck. I also click the save config button on the main menu after I configure the controls and have the same result.

    I'm sure I'm just making a simple mistake since I'm not used to this type of emulator but I'd really appreciate some insight.
     
  2. SuperrSonic

    SuperrSonic GBAtemp Advanced Fan

    Member
    658
    216
    Dec 9, 2011
    You could try manually editing the config for both the core and retroarch.cfg(depending if the last loaded core was indeed nestopia).

    Warning: Spoilers inside!
     
    DenverNugs likes this.
  3. MaeseJesus

    MaeseJesus GBAtemp Regular

    Member
    220
    38
    Apr 3, 2013
    Don't forget to disable the Autodetect option in the Input Menu, because that was the problem for me. I couldn't save anything until that option was turned off.
     
    DenverNugs likes this.
  4. DenverNugs
    OP

    DenverNugs Newbie

    Newcomer
    5
    5
    Sep 12, 2014
    United States

    This was the issue. Thank you very much.