Region-changed EmuNAND crashes during initial setup after format.

Discussion in '3DS - Flashcards & Custom Firmwares' started by squall14716, Mar 31, 2016.

  1. squall14716
    OP

    squall14716 GBAtemp Maniac

    Member
    1,185
    681
    May 16, 2011
    United States
    I decided to setup a Japanese-region emuNAND for fun on my US N3DS XL. I started on 10.7.0U, downgraded it to 9.1.0J through sysUpdater with the proper files, injected my edited SecureInfo_A as SecureInfo_C, and then updated to 10.7.0J through system options.

    Then, I formatted the system memory to complete the setup. It goes smoothly until the end. Right as the Internet configuration part begins, where it should bring up the Terms of Use, it crashes and restarts the initial setup.

    Has anyone seen this issue before? I'm using AuReiNand 4.0.1 through A9LH, but I've also tried the latest release of Cakes with the same issue.
     
  2. shinji257

    shinji257 61396C68206D61737465722072616365 :3

    Member
    325
    27
    Apr 9, 2007
    United States
    I saw that when I did my first round. I thought it was because I forgot something. As it stands I have not been able to do it again since but I've been deleting stuff from nand as cleanup. I thought it was cleanup that caused it for me but I'm getting the impression that it isn't the case for you at all.
     
  3. squall14716
    OP

    squall14716 GBAtemp Maniac

    Member
    1,185
    681
    May 16, 2011
    United States
    I've been at it for a while, the more it fails the more I decide to try to get it working out of spite. I tried after cleaning the NAND, I've tried without cleaning the NAND, I've used 10.7.0J files through sysUpdater instead of using 9.1.0J files. I was also using my old 9.2.0U emuNAND at the start and had the problem, so I cloned/formatted my 10.7.0U sysNAND and used that as the base and tried it again.

    It's been interesting, but it hasn't changed a thing, in the end.
     
  4. shinji257

    shinji257 61396C68206D61737465722072616365 :3

    Member
    325
    27
    Apr 9, 2007
    United States
    I'm actually suspecting the EULA system title since the id differs between regions.

    USA == 0004009B00013302
    JPN == 0004009B00013202

    However I do not know since I have not been able to get it working yet.

    For your modified SecureInfo_C are you just modifying byte 0x100 and setting the 01 to 00?

    (P.S. - I actually have a Japanese O3DS on its way but I'm doing this as kind of a project to see if it can be done proper)
     
  5. squall14716
    OP

    squall14716 GBAtemp Maniac

    Member
    1,185
    681
    May 16, 2011
    United States
    Oh, thanks for this. 0004009B00013202 was not in the update pack or grabbed by 3DNUS when I was getting the update files from it. I was able to get v0 (but no other version) from 3DNUS and installed it and the crash is resolved.

    Yep.