Question about current available exploits

Discussion in '3DS - Console, Accessories and Hardware' started by Garro, Jun 1, 2016.

  1. Garro
    OP

    Garro Pendulum of souls!

    Member
    624
    312
    Aug 15, 2009
    Cote d'Ivoire
    Somewhere
    I remember back when there weren't many exploits for >=9.0 consoles, whenever somebody had a console under 4.0.0, they were advised to not go above 4.5 using game cart updates since the exploits for the newer versions required an exploitable browser (And game carts doesn't update the browser), and they should use MSET and manually upgrade from there.

    My question is if this still applies? I remember Ninjhax needs the browser for the exploit, but what about Oot3dhax and others? If somebody from a 1.0.0-0U console would update to a 9.2.0-0U would that person be able to install a CFW?
     
  2. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    984
    330
    Apr 28, 2013
    If that somebody has 1.0 console, the best step he could do is get the OTP first and probably a sysnand dump(it's good to have a 1.0 sysnand backup just incase), update to 4.x (I'm not really sure if it's safe to directly jump to 9.2) to have an access to MSET Exploit. And from there, update to 9.2 then do a9lh.

    Edit:
    And to answer your question about 9.2.0-0 having access to CFW, yes, but you need either cubic ninja or OOT with the payload in it to access the HBL since your browser won't work.
     
    Last edited by Akira, Jun 1, 2016
  3. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,669
    732
    Aug 22, 2015
    United States
    Hell
    cart updates lack browser updates, if someone were to have 1.0.0, one of the stupidest things to do honestly would be to update immediately. You need some entrypoint or powersaves to setup OoThax, and ninjhax just requires you to be able to connect to the internet afaik.
     
  4. Garro
    OP

    Garro Pendulum of souls!

    Member
    624
    312
    Aug 15, 2009
    Cote d'Ivoire
    Somewhere
    If I remember correctly, 1.0.0 version doesn't even have a browser, that was added in 2.0.0 so 1.0.0 is pretty much hackless AFAIK.

    Yeah, that was my question, Browserhax and Ninjhax need the Internet Browser to work, which 1.0.0 does not have (and hence, a 9.2.0 wouldn't either), but is it still exploitable with oot3dhax/smashhax/mysterychunkhax/etc.? (Since they do not appear to use the browser to execute the exploit).
     
    Last edited by Garro, Jun 1, 2016
  5. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    984
    330
    Apr 28, 2013
    Well, another good information that I need to know then, sorry about that hehe. I guess the only option a 1.0 console user have is either update via a cart on 4.x, which requires a flashcart in order to use MSET or updating to 9.2.0-0, but he should have access to a hacked 3ds in order to use the secondary exploits.
     
  6. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,669
    732
    Aug 22, 2015
    United States
    Hell
    There is a difference between needing a browser and needing an internet connection. Ninjhax just requires you to scan the qr code, and have an internet connection setup (which was available in 1.0). Everything else you listed is either a secondary entrypoint, or n3ds only, so you will need a hacked 3ds to use those anyways, or powersaves for OoThax.
     
  7. Garro
    OP

    Garro Pendulum of souls!

    Member
    624
    312
    Aug 15, 2009
    Cote d'Ivoire
    Somewhere
    But according to ninjhax writeup (http://smealum.net/?p=517) the step number 3 of the ninjhax exploit mentions it needs to take over the browser applet to execute some stuff. And after some quick search I found this https://gbatemp.net/threads/ninjhax-on-8-1-n3ds-without-browser.382462/#post-5361924

    So yeah, ninjhax needs a hackable browser to work. That's why I'm asking about Oot3dhax and the others.
     
  8. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,669
    732
    Aug 22, 2015
    United States
    Hell
    I just installed ninjhax using my n3ds (which obviously does not have an exploitable browser). Also, that is for ninjhax 1.x, which is irrelevant for anything except updating to 9.x
     
  9. Garro
    OP

    Garro Pendulum of souls!

    Member
    624
    312
    Aug 15, 2009
    Cote d'Ivoire
    Somewhere
    The writeup also mentions Skater (which is the n3DS browser) but yeah, both posts are very old and the scene has grown a lot since, after checking https://smealum.github.io/ninjhax2/ it mentions that the browser version (number next to the region letter) can be anything (implying that ver 0/browserless works), but the place to input your firmware version to download the payload doesn't support a browser version under 7, that makes me think ninjhax still doesn't support browserless 3DS.
     
  10. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,669
    732
    Aug 22, 2015
    United States
    Hell
    I deleted by browser on my emunand, and did a factory reset on my cn cart, still was able to setup ninjhax on it normally and get into hb
     
  11. Garro
    OP

    Garro Pendulum of souls!

    Member
    624
    312
    Aug 15, 2009
    Cote d'Ivoire
    Somewhere
    Well that sounds convincing enough haha.
     
  12. Timburpton

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    Does anyone know if the OOThax payload is the same as the gateway OOT payload?