problem with devkitpro after linux distro upgrade (13.10)

Discussion in 'Wii - Emulation and Homebrew' started by naxil, Oct 23, 2013.

  1. naxil
    OP

    naxil GBAtemp Advanced Fan

    Member
    740
    96
    Oct 26, 2011
    Italy
    hello, i have upgrade my ubuntu from 10.04 to 13.10, i have a copy of devkitPRO to other hd, i have copy again it to /home/naxil/devkitPRO
    after i have write 3 line are in the bottom of my ~/.bashrc

    #devkitpro
    export DEVKITPRO=/home/naxil/devkitPRO
    export DEVKITPCC=/home/naxil/devkitPRO/devkitPPC
    PATH=$PATH:$DEVKITPPC/bin

    after i have do source ~/.bashrc

    i try to do make.. and i get this error

    powerpc-eabi-g++: error trying to exec 'cc1plus': execvp: No such file or directory
    make[2]: *** [ChannelHandler.o] Errore 1
    make[1]: *** [build] Errore 2
    make: *** [all] Errore 2

    i have found the cc1plus file on my system (i have install build-essential and gcc and g++ packets)

    naxil@naxil-old:/usr/lib/gcc/i686-linux-gnu/4.8$ ll
    totale 46360
    drwxr-xr-x 4 root root 4096 ott 23 01:49 ./
    drwxr-xr-x 3 root root 4096 ott 12 06:49 ../
    -rwxr-xr-x 1 root root 12905652 ott 12 06:52 cc1*
    -rwxr-xr-x 1 root root 13946068 ott 12 06:57 cc1plus*

    what i can do? i not sure what cc1 and cc1plus are.. but the powerpc-eabi-g++ not found it?

    before (with 10,04) the same svn works good... (only with root, but work goods)...

    any help?
    iam going in crazy!
     
  2. naxil
    OP

    naxil GBAtemp Advanced Fan

    Member
    740
    96
    Oct 26, 2011
    Italy
    no way?
     
  3. naxil
    OP

    naxil GBAtemp Advanced Fan

    Member
    740
    96
    Oct 26, 2011
    Italy
    I have solve the problem!
    with this step:

    Delete the folder on home/naxil/devkitPRO
    download the automated installer (perl installer).
    Start the installer
    wait the downloading/extract

    Now devkitpro WORKS!!!!
    Iam happy!