OoT3dhax help

Discussion in '3DS - Flashcards & Custom Firmwares' started by mashiro21, Dec 2, 2016.

  1. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    I don't have a cartridge of OoT, but I can buy the eshop one right now. Will that work for homebrew? Kind of confused as yellows8's repo says it's ok, but someone somewhere said it wasn't.

    And also, I can see the dsiware downgrade can use the 4 swords game. Can I use the anniversary edition one for that?
     
    Last edited by mashiro21, Dec 2, 2016
  2. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    If you have another CFW on 3DS you will be able to install the exploit for OOT3Dhax, othwerwise you need a cart + powersaves to use it as primary.

    For DSiWare and 4 swords, I believe this will work.
     
  3. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    ok cool. thanks. i'll give it a go. just to be clear, though, the 4 swords i have was the free one (the one they gave away as a promotion a couple years ago)
     
  4. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Yes, this is the exact game "The Legend of Zelda: Four Swords Anniversary Edition" for yellows 8 hax installer:

    https://github.com/yellows8/3ds_dsiwarehax_installer

    This will install those same public.sav when slowhax is released, so yes it is for the same game.
     
    mashiro21 likes this.
  5. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    i see. thanks. i thought there were some other 4 swords (a not free one, lol). I'll get to it then! Thanks!
     
  6. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Good luck, post any questions if unsure with guide. It's always best to ask before trying anything.
     
  7. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    thanks! it's a long guide so this is going to take a while. i wish there was an easier way of downgrading my 11.0 3dsxl without having to get a physical thing (powersaves, cubic ninja which is impossible to get). too bad browserhax stopped working. so basically, i have to update both 3ds's since system transfer requires updates, right?
     
  8. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Took me 30 mins total.

    You can use CTR-HTTPWN if you prefer not to update, it's part of the guide. Otherwise you can update if you want.
     
  9. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    30 mins? wow. that's fast then. it's just the reading that will really take time for me i guess. thanks! I'm downloading the stuff i need as well as the game from eshop. i'll be back if i need more of them answers. :D
     
    el_gonz87 likes this.
  10. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    ok i'm having trouble. i've been sitting here for more than an hour now thinking what i'm doing wrong, but i can't find it. i'm using 4 swords. i'm still at the start. i copy the public.sav, run 4 swords, and it runs normally. i do it again, nothing. i try the 3dsx file for the dsiware installer, it doesn't even detect my copy of 4 swords. i'm using an 11.2 emunand
     
  11. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,185
    681
    May 16, 2011
    United States
    I assume you haven't transferred yet? DSiWare always runs from SysNAND, not EmuNAND, which would be why your copied save in EmuNAND isn't triggering the exploit. Copy the save in SysNAND, then copy the save in EmuNAND again the exact same way, then try it.
     
  12. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    oohhh. alright. that makes sense. thanks! i'll try that!

    EDIT: wait, that's going to be a problem. my sysnand is at 9.2. how do i download a legit copy of 4 swords there if i didn't have it before? :(
     
    Last edited by mashiro21, Dec 3, 2016
  13. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Look at last 3 posts of this thread:
    http://gbatemp.net/threads/question-about-nfirm-downgrade.451103/page-3

    Basically install on SysNAND using freeshop and install save on both SysNAND and EmuNAND TWL NAND
     
  14. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    worked! now, is this the same with steelhax? like, i also have to do it on sysnand? i do steelhax on emunand alone and it keeps corrupting my savefile

    EDIT: ok, never mind. i kept deleting the corrupted one, but when i didn't it worked when i reinstalled steelhax.
     
    Last edited by mashiro21, Dec 3, 2016
  15. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Hmmm no, this is for DSiWare. For steelhax what version is source 3DS? Maybe your target 3DS is on 11.0 and you are installing an exploit for 11.0 but testing on 11.2 (install should be target)
     
  16. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    i'm at the part where i need to use ctr httpwn. i need homebew on my 11.0? if i do, maybe it's better to just update it to 11.2?
     
  17. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Well if you need homebrew on 11.0 you won't be able to test on 11.2 source system. If you upgrade to 11.2 then don't forget to redo the steelhax section and select the 11.2 firmware for install.
     
  18. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    yup. did just that. thanks! i now finished the system transfer and about to go to the dsiware. quick question, i did the whole steelhax thing, but it's never mentioned again. i thought i was going to use it for homebrew, but turns out i use the browserhax. was steelhax really necessary?

    EDIT: ignore this. i'm pretty sure at this point that i'm stupid. used steelhax to access brew. everything went well. took a few hours (thanks, work!) but i'm all good now. i now have kernel 2.50-11 and firm 2.50-11. now, what next? am i free to downgrade my firmware now?
     
    Last edited by mashiro21, Dec 3, 2016
  19. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,185
    681
    May 16, 2011
    United States
  20. mashiro21
    OP

    mashiro21 Member

    Newcomer
    48
    5
    Mar 19, 2014
    thanks for all your help, guys. i finally now have a working o3dxl with luma3ds and a9lh. one last thing. trying to update the 3dsxl and having an error. i'm at 75% of the updte, and everytime i try it again, it just throws the "an error has occurred unable to update" screen. it doesn't even increase the progress bar by a bit before it happens. can i just install homoebrew and use safesys updater?