Question Nsp files and. Xci files

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by shanefromoz, Sep 29, 2018.

  1. shanefromoz
    OP

    shanefromoz GBAtemp Maniac

    Member
    7
    Jun 18, 2007
    Australia
    Hello
    If i have a .Nsp version of a game and install an update which is .Xci will it work with no issue's

    Thanks
     
  2. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Yes because .NSP files are installed into the system and not the games.
     
    shanefromoz likes this.
  3. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    Is there a second alternative on updating .NSP Games other than having to use CDNSP?

    I keep reading on forums that CDNSP is basically done due to the new eShop changes...
     
  4. Blue_Mew

    Blue_Mew GBAtemp Addict

    Member
    8
    Oct 2, 2015
    United Kingdom
    Only option is to hunt down the update NSPs on piracy sites.
     
  5. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    Yeah! I sort of figured that would be the case. I was able to find a few sites but nothing solid. I'll keep looking until I come across something that offers a solid selection of NSP updates.

    I have tons of NSP Files but not very many updates...
     
  6. Meepers55

    Meepers55 Flintstones Regular

    Member
    4
    Aug 7, 2018
    United States
    It's odd to see people actually struggling to find them.
     
    ModderFokker619 likes this.
  7. kkcheong

    kkcheong GBAtemp Regular

    Member
    3
    May 15, 2018
    Malaysia
    It is also odd that people want to find update when the game works just fine.
     
  8. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    I'm not struggling to find them. I just need to find a site that has a large selection of NSP updates...
     
  9. Clydefrosch

    Clydefrosch GBAtemp Psycho!

    Member
    11
    Jan 2, 2009
    Germany
    every other link has reached capacity or was removed or whatever. since cdn is gone, new updates are also hard to come by.


    new updates often come with bugfixes, performance fixes and most of all, people want them for the dlc I guess.
     
  10. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    I'm not going to name the game titles specifically! But on some of the NSP Games that I have, an update is required for them to run...
     
  11. chippy

    chippy GBAtemp Regular

    Member
    4
    Dec 21, 2017
    Australia
    doesn't that mean you need a higher OS to run it? What version is your switch on atm? 5.1+ or lower?

    Some games do have a day 1 patch and is loaded to trigger to ask for it like kirby
     
    Last edited by chippy, Sep 30, 2018
  12. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    I'm not sure what your referring to by atm? But if your referring to OFW. I had it on 5.1 now it's on 6.0...
     
  13. chippy

    chippy GBAtemp Regular

    Member
    4
    Dec 21, 2017
    Australia
    sorry atm means "at the moment"
    So the games say it needs an update, does it give you the option to play it anyway?
    Might be helpful for the name of one. L.a.nowa has a big part in it's first patch that's not in the cart.
    Are you using xci converted to nsps for the issue games?
     
  14. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    I got you. Lol
    On certain games I was able to play them without having to update. But others wouldn't open unless I did an update first...

    Since it's been a while since I played with my Switch and did a factory reset before I updated to OFW 6.0 I can't remember at the top of my head on what games weren't playing unless I did an update...

    I'm using nsps I downloaded of the net. According to the private site I got them from! They claim that they are true eShop nsps. So I couldn't tell you if they are xci converted to nsp...
     
  15. chippy

    chippy GBAtemp Regular

    Member
    4
    Dec 21, 2017
    Australia
    you shouldn't need updates then if they are eshop downloads as I know of none that won't load without it but I could be wrong

    So seeing it's been awhile since you had the issue do you know if you wore on the latest ofw? Only time I know of a game requiring an update to play and won't let you play anyway is when your on a lower ofw then what the game needs
     
  16. Meepers55

    Meepers55 Flintstones Regular

    Member
    4
    Aug 7, 2018
    United States
    I don't know what sites you use, but I can easily find working links. I could understand not getting newer updates though.
     
  17. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    Before I was on OFW 5.1. I haven't installed anything since restoring my Switch back to factory and updating to OFW 6.0. Now that I did a full nand backup of my Switch I will once again start to install NSP Games.

    Hopefully I won't get any more NSP update messages now that I'm on OFW 6.0...
     
  18. chippy

    chippy GBAtemp Regular

    Member
    4
    Dec 21, 2017
    Australia
    You shouldn't have got the messages on 5.1 as no game requires 6 yet
     
  19. SoCALCat

    SoCALCat Advanced Member

    Newcomer
    2
    Jun 24, 2018
    United States
    So I installed some NSP Games on my switch and so far I got the "New Update" message on
    1. Celeste
    2. Hollow Knight
    3. Namco Museum
    4. NBA 2k19
    5. Owlboy
    6. Pac-Man Championship
    7. SNK Heroines

    I installed updates on 4 out of 7 NSP Games

    Hollow Knight 1.4.1.4 v131072
    NBA 2k19 1.01 v65536
    Owlboy 1.0.5 v327680
    SNK Heroines 1.01 v65536

    After installing the updates I still got the "New Update" message. Maybe there are newer updates that have been replaced? I also wasn't able to find any updates for

    Celeste
    Namco Museum
    Pac-Man Championship

    I'm still able to play all the NSP Games that require the updates with no issues so far.

    My Switch is on OFW 6.0 & running on TX Pro CFW SXOS v1.9
    I stayed away from SXOS v2.0 because I keep reading that it's very unstable...
     
    Last edited by SoCALCat, Oct 1, 2018
  20. chippy

    chippy GBAtemp Regular

    Member
    4
    Dec 21, 2017
    Australia
    Haven't tried thoes games so can't comment about them sorry but it's odd.
     
Loading...