MSVCP110.DLL Missing Error

Discussion in 'Wii U - Emulation & CEMU' started by Halps, Jun 12, 2017.

  1. Halps
    OP

    Halps Newbie

    Newcomer
    4
    0
    Jun 12, 2017
    United States
    Hey all,

    Had everything working fine a few days ago and suffered a hard drive failure. Had a hard time booting to the right OS and with installing things in general, lots of errors.

    Trying to run Cemu 1.7.5 and 1.8.0b on Windows 7 Pro and Windows 10 Pro causes "The code execution cannot proceed because MSVCP110.dll was not found. Reinstalling the program may fix this problem."

    I've been working non stop to get this fixed so through my research I know that you can go into wowsys64 and grab it (or system32) if it isnt there, but that's the odd part - it is there. I do have the MSVCP110.dll.

    Anyone have any ideas of whats going on and how to fix it?
     
  2. Xalphenos

    Xalphenos GBAtemp Regular

    Member
    234
    78
    Jan 21, 2017
    United States
    You need to install the visual c++ 2012 redistributable. MS are douche bags and removed the page that had it. You can still get it though.
     
  3. Halps
    OP

    Halps Newbie

    Newcomer
    4
    0
    Jun 12, 2017
    United States
    Thanks - I had a newer (if not many) installed, but 2012 said it installed successfully after downloading it for kicks - gave it a run and I am now getting "The Application was unable to start correctly (0xc000007b) which I tried a bunch of solutions for (this error has happened before in my troubleshooting).

    Any thoughts?
     
  4. Xalphenos

    Xalphenos GBAtemp Regular

    Member
    234
    78
    Jan 21, 2017
    United States
    0xc000007b occurs when you are on a 64bit system trying to run 64bit code with 32bit .dlls. Possibly the reverse too. Did you at any point download .dll files and manually place them on your system? If so delete them.
     
  5. Halps
    OP

    Halps Newbie

    Newcomer
    4
    0
    Jun 12, 2017
    United States
    I did grab my old MSVCP110.dll from windows.old and dragged it into syswow64 2 installs ago. I will try to delete that now (in use by another program currently).

    I ran into the 64bit 32 bit issue and ran a fresh install of a 64 bit system just to be sure. Will remove that .dll and see if I can find out where it comes from.
     
  6. Halps
    OP

    Halps Newbie

    Newcomer
    4
    0
    Jun 12, 2017
    United States
    Ok, deleted the file and installed it again using ccleaner - rebooted, still says "the code execution cannot proceed because MSVCP110.dll was not found." So I deleted CEMU and reinstalled and I still get the same error.
     
  7. Xalphenos

    Xalphenos GBAtemp Regular

    Member
    234
    78
    Jan 21, 2017
    United States