MSET 4.5 Exploit on N3DS 9.0?

Discussion in '3DS - Flashcards & Custom Firmwares' started by DJPlayer, Jun 4, 2015.

  1. DJPlayer
    OP

    DJPlayer Banned

    Banned
    542
    186
    May 21, 2015
    Netherlands
    Hey Guys,

    I have a N3DS and want to use the MSET-Exploit to use the Launcher.dat of Gateway (or other Launcher.dat's) on my N3DS FW:9.0.0-20E.
    I'm using PastaCFW right now via Cubic Ninja and I'm able to install cias.
    Now I want to know: Can I install the MSET_EUR.cia of Gateways 3.2.2 on my N3DS SysNand without brick?
     
  2. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Yeah, but there's no point right now if you don't have a Gateway.
     
  3. DJPlayer
    OP

    DJPlayer Banned

    Banned
    542
    186
    May 21, 2015
    Netherlands
    So I can't use the Decrypt9-Launcher dat with it? :/ (was updated in nightly build on June 01st)
     
  4. KingOfHell

    KingOfHell Advanced Member

    Newcomer
    74
    20
    Mar 15, 2015
    United States
    This is just my limited view of what actually happened, if I'm wrong, or missing something, someone please correct me.

    MSET is just an entrypoint in a chain of exploits that was used back on firmwares 4.0-4.5 or somewhere around there. The Later firmwares patched out other stages of the exploit chain, and eventually the entrypoint itself was patched out.

    When gateway released their browser(spider) based launcher, in, what I'm assuming was an effort to keep things simple, they re-did their launcher.dat to work through old mset AND spider. Of course, this left n3ds users boned because the the n3ds was incomaptible with both(too new for old-mset, and different browser (skater)), so eventually, they exploited Ocarina of Time and Cubic Ninja so that n3ds users could launch gateway.

    Once gateway team found out how to downgrade system titles, gateway updated the mset portion of their launcher.dat to use newer exploits, since cartridge swapping makes flashcard use a pain, and the two main exploitable games (Cubic Ninja and Ocarina Of Time) have skyrocketed in price. Either that, or they just felt like being nice for some reason.

    The problem is, spider and cubic ninja's stuff has pretty much been laid out for everyone to easily use, while nobody apparently has or cares about OoT, and even fewer people care about new-mset.

    Sadly, the end result is that, a launcher.dat style program isn't usable with every exploit, only the ones it was designed to work with. Unless the developer of said program explicitly states that it's compatible with new-mset, it's more than likely not going to work.

    EDIT: Added standard disclaimer to the top, I can't/don't-care-to be everywhere and know everything about the scene and what's happened.
     
  5. Nollog

    Nollog GBAtemp Addict

    Member
    2,703
    472
    Oct 10, 2008
    Yes you can install it, all it is is an older version of the system settings application.

    I wouldn't advise it though, as you'd lose some options which were added after 4.5
    For example, micro sd management.

    Also, it's worthless in and of itself, you need gateway's nvram majiggy.
     
  6. DJPlayer
    OP

    DJPlayer Banned

    Banned
    542
    186
    May 21, 2015
    Netherlands
    hmm.. okay that sucks :/
    WOn't install it then.
    But is there a way to get the newest version of Decrypt9 to run on the N3DS?
    There'S one for Ninjhax but it's not updated to the latest version.
     
  7. Shadowtrance

    Shadowtrance GBAtemp Addict

    Member
    2,488
    1,517
    May 9, 2014
    Hervey Bay, Queensland
    It's not updated to the latest version because the "official" ninjhax version isn't updated yet (i assume you mean the 9.6 seed crypto stuff).
     
  8. Nollog

    Nollog GBAtemp Addict

    Member
    2,703
    472
    Oct 10, 2008
    Yeah of course.

    Someone willing to update it just has to find the right memory addresses, like gateway did.

    but honestly, it's kind of a catch9001. You have to have exploited the n3ds in order to get the old title installed, so there's probably not as much interest in it.
    Folk like me prefer it since it means I don't have to carry a cart with me, that's a convenience thing though, everything i've seen done on the 3ds has been against making things easy, for whatever reason.
    Might take a while for someone with the balls to do it.