Making .bin Images?

Discussion in '3DS - Homebrew Development and Emulators' started by legofan623, Oct 9, 2015.

  1. legofan623
    OP

    legofan623 GBAtemp Fan

    Member
    418
    196
    Oct 3, 2011
    United States
    Puyallup, WA
    I'm messing around with the .bin image format that the hbmenu uses, but I can't seem to get it to load correctly. All I did was invert the image in gimp. Every time I convert this image to bin:

    [​IMG]

    It comes out compiled like this:

    [​IMG]

    I have no idea what I'm doing wrong. I used this tool to convert the .png to .bin.
     
  2. Garcia98

    Garcia98 Hey! Listen!

    Member
    361
    188
    Sep 8, 2015
    Salamanca
  3. legofan623
    OP

    legofan623 GBAtemp Fan

    Member
    418
    196
    Oct 3, 2011
    United States
    Puyallup, WA
    How exactly do I do step 2 with a single Logo.png file?

    EDIT: I think I need to fix the path
    EDIT2: Nope, I get "Invalid Parameter - -channel"
     
    Last edited by legofan623, Oct 9, 2015
  4. Garcia98

    Garcia98 Hey! Listen!

    Member
    361
    188
    Sep 8, 2015
    Salamanca
    That command works fine for me
     
  5. legofan623
    OP

    legofan623 GBAtemp Fan

    Member
    418
    196
    Oct 3, 2011
    United States
    Puyallup, WA
    Are you on windows?
     
  6. Garcia98

    Garcia98 Hey! Listen!

    Member
    361
    188
    Sep 8, 2015
    Salamanca
    Last edited by Garcia98, Oct 9, 2015
  7. suloku

    suloku GBAtemp Advanced Fan

    Member
    866
    491
    Apr 28, 2008
  8. legofan623
    OP

    legofan623 GBAtemp Fan

    Member
    418
    196
    Oct 3, 2011
    United States
    Puyallup, WA
    Will check these out in a bit, thanks!
     
  9. legofan623
    OP

    legofan623 GBAtemp Fan

    Member
    418
    196
    Oct 3, 2011
    United States
    Puyallup, WA
    Last edited by legofan623, Oct 9, 2015
  10. suloku

    suloku GBAtemp Advanced Fan

    Member
    866
    491
    Apr 28, 2008
    No, wait long enough and it will work. Patience is the key, logo.png is quite big for that javascript.
     
  11. legofan623
    OP

    legofan623 GBAtemp Fan

    Member
    418
    196
    Oct 3, 2011
    United States
    Puyallup, WA
    45 minutes in and it's still frozen on FireFox

    EDIT: Only took 3 minutes in Chrome (TY based Google)
     
    Last edited by legofan623, Oct 10, 2015
  12. esmith13

    esmith13 GBAtemp Regular

    Member
    151
    41
    Aug 19, 2006
    United States
    South Jersey
    I'm having this issue as well. Tried both IE and Chrome. Waited about 30min. Chrome doesn't show anything to click or download at all and IE shows 3) Download your BIN file as a clickable link (that is dead) from the moment I start with no change even after 30min.

    Any ideas?