[Luma3ds] reboot DS games

Discussion in '3DS - Flashcards & Custom Firmwares' started by Cortexfou, Oct 29, 2016.

  1. Cortexfou
    OP

    Cortexfou GBAtemp Regular

    Member
    204
    17
    Apr 14, 2016
    Belgium
    Hi,
    I'm on luma3ds and when I try to use a DS game, the 3ds reboot. Can you help me ?
    Thanks.
     
  2. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    This is normal. It has to reboot to the DSi firmware to play a DS game. If it reboots but doesn't launch the DS game, then I suspect something is wrong with your Luma payload, the DSi firmware on your 3DS or your cart. (Edit - or your A9LH payload).
     
    Last edited by mashers, Oct 29, 2016
  3. Cortexfou
    OP

    Cortexfou GBAtemp Regular

    Member
    204
    17
    Apr 14, 2016
    Belgium
    It didn't launch the game. What should I do ?
     
  4. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    I would suggest updating your Luma payload to the latest version. Also, what A9LH payload are you using? (the one installed with SafeA9LHInstaller).
     
  5. Cortexfou
    OP

    Cortexfou GBAtemp Regular

    Member
    204
    17
    Apr 14, 2016
    Belgium
    I don't know. I such a noob for these things. Sorry for that.
    In fact, I use a tuto to install CTRboot and RXtools. after that, I upgraded my RX with luma (with the tuto on the forum) to play ds games. It worked but the region free didn't work so I upgraded again my luma to the last version and now starting a DS game reboot my console and dont load the game.
    That's the all story.
     
    Last edited by Cortexfou, Oct 29, 2016
  6. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    So did the problem start immediately after you updated Luma? And what version of Luma are you using now? You can find that out by holding select while powering on your 3ds to get into the Luma setup menu.
     
  7. Temarile

    Temarile (ノ◕ヮ◕)ノ*:・゚✧ A9LH ✧゚・: *ヽ(◕ヮ◕ヽ)

    Member
    1,132
    422
    Jan 7, 2016
    Netherlands
    IIRC Dsiware games need to be installed on both sysnand and Emunand for it to work on Emunand. Sounds like you have an Emunand.
     
  8. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    It's a DS game, not dsiware. Therefore on cart, not installed to NAND.
     
  9. Cortexfou
    OP

    Cortexfou GBAtemp Regular

    Member
    204
    17
    Apr 14, 2016
    Belgium
    Yes, it's a card not a digital game.
    Ans yes, it's when I updated luma. My version right now is 6.2.3
     
  10. RyDog

    RyDog Lazy Animal Crossing hacker

    Member
    1,609
    1,192
    Apr 26, 2015
    United States
  11. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Thanks @itsRyan - I didn't know about that part of the guide.

    @Cortexfou
    If that doesn't work, try reverting to a previous version of Luma in case this is a bug or incompatibility in 6.2.3.
     
    RyDog likes this.
  12. Cortexfou
    OP

    Cortexfou GBAtemp Regular

    Member
    204
    17
    Apr 14, 2016
    Belgium
    I tried the @itsRyan thing but it doesn't work, I tried to use my old luma files (I made a backup), doesn't work. I downloaded the version 6.3 of luma and now it work. Strange, I don't know what was the problem but now it work. Thanks you so much for your help.
     
    Quantumcat likes this.
  13. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Perhaps an incompatibility with a config file between versions or something? If you want to be sure, you could rename your luma folder and install the latest stable release. Then re-test. If it works the probably something in the old luma folder was causing the problem. You always have the option to go back to the previous luma folder if it's no different.
     
  14. goncalodoom

    goncalodoom GBAtemp Fan

    Member
    353
    9
    Sep 12, 2009
    portugal
    Latest commit broke DS cards compatibility, i went back to Luma3DS v6.3.1 and it is working fine again.
     
  15. Dracari

    Dracari GBAtemp Maniac

    Member
    1,487
    407
    Apr 5, 2009
    United States
    i can run DS Games just fine on teh latest commit. retail and flashcart even the DsiHB Menu, Make sure you keep your paths set properly in /luma/path.txt if your using a bootloader to load luma.