IOS9 V512 cannot be installed (ret -1022)

Discussion in 'Wii - Hacking' started by nash79, May 30, 2009.

  1. nash79
    OP

    nash79 GBAtemp Regular

    Member
    172
    0
    Sep 27, 2008
    United States
    Hi guys,
    I cannot seem to be able to install IOS9 in my WII. I can install all the wads, move from Menu 3.2 to 3.1 using WAD Manager. The only problem rises when trying to install IOS9 v512. Even updating using Zelda, freezes when the bar reaches the end.
    This is the message it gives when installing with WAD MANAGER 1.4:
    when I go to anytitle deleter, I find the IOS9 is installed. and even though, the zelda disk keeps asking for update (and freezes upon updating).
    I even get to uninstall it with Wad manager.
    Do you know what could the problem be?
    thanks in advance
     
  2. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    Why did you uninstall IOS9 in the first place?`
     
  3. nash79
    OP

    nash79 GBAtemp Regular

    Member
    172
    0
    Sep 27, 2008
    United States
    because I had Zelda disk asking me to update while I was already on 4.0. I read somewhere around the forums that IOS9 might get corrupted. As I couldnt overwrite it, I said maybe if I uninstall it I can reinstall it. So it was already messed up (dont ask me why cause I aint got no clue).
     
  4. nash79
    OP

    nash79 GBAtemp Regular

    Member
    172
    0
    Sep 27, 2008
    United States
    Anyone? (for a solution)

    Update: I installed V521 and it worked. I guess v516 had sthg that didnt allow it to install.
    Thanks anyways.
     
  5. dinayv

    dinayv Newbie

    Newcomer
    5
    0
    May 31, 2009
    Iceland
    IOS9 ? thats old
    since it is not a commonly used ios ( I guess )
    why not to try a different approach :
    make yourself a backup disk of the game and then use WiiBrickBlocker ?
    the game should work.
     
  6. techboy

    techboy GBAtemp Advanced Maniac

    Member
    1,720
    21
    Mar 15, 2009
    United States
    Pennsylvania
    IOS9 is commonly used. Its not for newer games, but things like Wii Sports, Zelda, and I think red steel still use it.

    Games were designed for IOS9, and will always use IOS9. Just because we have IOS36,60, 61, etc. doesn't mean that the game will use them. Each game's header (TMD) specifies the IOS it needs to run. Since things like Wii Sports have headers that indicate IOS9 is needed, it has to be there when the time comes for it to be loaded. Otherwise the games do not work.

    A new REVISION of IOS9 may come out, but its still just a version of IOS9, typically released to fix security holes.

    Using brick blocker wouldn't help. All that does is remove the update from the ISO image. His IOS9 was missing. Since Zelda's header specifies that it needs IOS9, the wii tries to load IOS9 when Zelda starts. Since IOS9 is missing, it fails to load, and the game hangs with a blank screen.

    EDIT: fixed typo (TMF changed to TMD) and reworded second paragraph.
     
  7. dinayv

    dinayv Newbie

    Newcomer
    5
    0
    May 31, 2009
    Iceland
    OK ,
    thaks for the detailed response,
    didn't know that.