How do I fix this?

Discussion in 'Wii - Hacking' started by Killer Phantom, Dec 21, 2008.

  1. Killer Phantom
    OP

    Killer Phantom GBAtemp Regular

    Member
    273
    1
    Oct 1, 2007
    United States
    It happened to me when I try to play some Japanese games on my Wiikey chipped NTSC-U Wii. (Captain Rainbow, Bomberman Wii, Yatterman, etc.)

    In-game Japanese text will show up as "ç(§à((èç(§)" or something like this, it makes the game down right unplayable as I can read Japanese.

    How do I fix it? Thanks.
     
  2. Wiisel

    Wiisel GBAtemp Maniac

    Member
    1,310
    97
    Dec 4, 2008
    use GeckoOS or another loader and change the language to Japanese
     
  3. Killer Phantom
    OP

    Killer Phantom GBAtemp Regular

    Member
    273
    1
    Oct 1, 2007
    United States
    Thanks, but...isn't there anyway to use it without GeckoOS? Like patching the ISO or something.
     
  4. kimikal27

    kimikal27 GBAtemp Maniac

    Member
    1,381
    0
    Oct 28, 2008
    Galway
    try SoftChip
     
  5. Killer Phantom
    OP

    Killer Phantom GBAtemp Regular

    Member
    273
    1
    Oct 1, 2007
    United States
    What do I do with SoftChip? I checked their site and couldn't find download link.
     
  6. Knocks

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    He doesn't want to use GeckoOS, so what makes you think he wants to use SoftChip?

    Killer Phantom: you can patch the ISO with WiiFrii and force language to Japanese. The only problem is that it uses Trucha and the discs will not work with 3.3U or higher.
     
  7. Heran Bago

    Heran Bago Where do puyo come from?

    Member
    2,993
    389
    Nov 6, 2005
    United States
    Foggy California
    Change your system to Japanese? GeckoOS is going to be the easiest method, sorry if you are opposed to homebrew. You could install and use a backup loader too.
     
  8. Killer Phantom
    OP

    Killer Phantom GBAtemp Regular

    Member
    273
    1
    Oct 1, 2007
    United States
    I suppose this is it, then.

    Thanks a lot.

    GeckoOS is easy but I hate having to open HBC every time I want to play it, since I always use Starfall recovery mode boot up my game, so yeah.
     
  9. Wiisel

    Wiisel GBAtemp Maniac

    Member
    1,310
    97
    Dec 4, 2008
    if you use the softchip dol forwarder and have language set as jap and auto boot you only need to load the channel you can find the dol and channel in the 002 thread [​IMG] probably the least click solution [​IMG]
     
  10. Wiisel

    Wiisel GBAtemp Maniac

    Member
    1,310
    97
    Dec 4, 2008
    --------------------------------
     
  11. Killer Phantom
    OP

    Killer Phantom GBAtemp Regular

    Member
    273
    1
    Oct 1, 2007
    United States
    Sorry to bump this again.

    I tried GeckoOS and forced the game to use Japanese language, but it still shows gibberish.

    The game is Bomberman Wii (J), I guess I am screwed?
     
  12. 20clarky08

    20clarky08 Official Wii Freak

    Member
    844
    1
    Oct 29, 2008
    ScouseLand
    have you tried any of the other loaders i.e gamma/softchip??
     
  13. nerubii

    nerubii Advanced Member

    Newcomer
    51
    1
    Jul 22, 2007
    Taiwan
    wiikey 2, gecko 1.07b, gamma, softchip.. all with the same problem. gibberish text. it seems the wii didnt choose a proper encoding even after setting the Language as Japanese.

    maybe someone can try patching the ISO with WGLP to 0. see if it works.
     
  14. nerubii

    nerubii Advanced Member

    Newcomer
    51
    1
    Jul 22, 2007
    Taiwan
    solved.

    use waninkoko's region changer and change to japanese region.

    i hvnt try patching the game with WGLP.
     
  15. swf3

    swf3 Banned

    Banned
    197
    0
    Jan 30, 2008
    dont try softmii , its not atall safe
     
  16. afif95

    afif95 I own a bungalow on Mars, and booked 4 corner lots

    Member
    1,805
    1
    Nov 24, 2008
    Malaysia
    Malaysia!
    swf3, nobody in here mentioned softmii.

    IT'S SOFTCHIP.

    Learn to read.

    Stop flaming Softmii.

    You did wrong, not Softmii did.

    You follow the instructions loosely, and you got bricked.

    It's your fault, not Softmii's
     
  17. nerubii

    nerubii Advanced Member

    Newcomer
    51
    1
    Jul 22, 2007
    Taiwan
    A better solution:
    (1) Get "Any Region Changer" and change only the "Game Region" to Japanese. Language may remain as per norm.
    (2) Load up Gecko/Gamma/Softchip and change language to Japanese. (This step is required to connect online, ie wifi battle)