1. LinusRG

    OP LinusRG GBAtemp Regular
    Member

    Joined:
    Jun 7, 2017
    Messages:
    153
    Country:
    Canada
    I am trying to use the original R4 revolution for cfw is there any way to do this?
     
  2. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)
    Member

    Joined:
    Jul 23, 2018
    Messages:
    1,912
    Country:
    Germany
    Picture from your card pls. Btw is here a list with all compatible flashcards.
     
    Last edited: Nov 17, 2019
    alexander1970 likes this.
  3. LinusRG

    OP LinusRG GBAtemp Regular
    Member

    Joined:
    Jun 7, 2017
    Messages:
    153
    Country:
    Canada
  4. LinusRG

    OP LinusRG GBAtemp Regular
    Member

    Joined:
    Jun 7, 2017
    Messages:
    153
    Country:
    Canada
    The link is only to a google image because I do not feel like taking a picture of my own cart when there is on already online. Can anybody please help me with this issue?
     
  5. You have been linked to a list of compatible flashcarts, if yours is not on that list then it is not compatible.
     
  6. LinusRG

    OP LinusRG GBAtemp Regular
    Member

    Joined:
    Jun 7, 2017
    Messages:
    153
    Country:
    Canada
    Why is the original R4 supported it is one of the oldest flashcarts, so what prevents it from having support?
     
  7. KleinesSinchen

    KleinesSinchen The Backup Reminder
    Member

    Joined:
    Mar 28, 2018
    Messages:
    1,333
    Country:
    Germany
    As far as I know the original R4 came out before the DSi. With the DSi (and later the 2|3DS) Nintendo started blocking DS flashcarts by putting all DS games that existed to this point on a whitelist – later DS games are digitally signed.
    If a cartridge neither is on the whitelist nor contains a valid signature the DSi (2|3DS) refuses to load it.

    Later flashcarts contain at least parts of ROMs from the whitelist to get around this check. [background information→ https://hackmii.com/2010/02/lawsuit-coming-in-3-2-1/ ]
    For a while Nintendo played a cat and mouse game with flashcart manufacturers. Each update blocked known flashcarts with better checks. Firmware updates changed the game the flashcart tries to mimic. [For example see: https://wiki.gbatemp.net/wiki/Updating_the_AK2i_Bootloader]

    But as the DS-Lite and DS-Phat did not have such a check… I don’t think the original R4 can get firmware updates at all (the firmware is not the kernel on the micro-SD). Without the possibility to upgrade (rewrite) the firmware, there is no way to replace the firmware with ntrboothax.
     
    LinusRG likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Original, NTRBOOT, Using