GBA On 3DS, weird issue, cannot run, cannot install.

Discussion in '3DS - Homebrew Development and Emulators' started by StarGazerTom, Oct 1, 2015.

  1. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    Ok, so I've been trying to play a converted Lunar Legends gba game that I made into a .cia, but for the life of me I cannot figure out whats going on with it.

    I've installed the game to the EmuNand, and it wouldn't work.

    I've installed the game to both EmuNand and SysNand. It doesn't work.

    I've installed the modded ABG_FIRM file thats floating around, into SysNand.
    Still doesn't work.

    Now whenever I install the game to SysNand, i get a black icon on my EmuNand.... which only goes away if I try running the game from EmuNand... so a real icon and a fake/black icon.

    Each time, I've deleted it fresh from both systems. Any idea's?

    SysNand 4.5-E
    EmuNand 10.1-E
    RXTools 2.6
    O3DSXL
     
  2. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    Bump

    No one?
     
  3. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    255
    Jan 31, 2015
    Please remember that in FBI destination NAND is only for nand files like agb_firm. If you install the game in nand destination you'll get a black icon.
    The game should be installed to sysnand SD, but you're still able to run it while in emunand and it will launch the one in sysnand.
     
  4. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    I still have the problem thought that no matter what, I get "An error occured" after starting a GBA Game
     
  5. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    255
    Jan 31, 2015
    Is the gba game installed in sysNAND destination SD? Is the AGB_FIRM installed in sysNAND destination NAND?
     
  6. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    No, FBI has been installing the AGB_FIRM to EmuNand Destination Nand as that's where i've been running it.

    Funny enough, I've been trying to install _AGB_Firm to the sysNand, but FBI refuses to start on SysNand now for some reason....
     
  7. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    255
    Jan 31, 2015
    Try using rxTools to get the old Health and Safety app back, then install FBI again.
    I recommend that you install Devmenu_2x.cia when you can since it automatically picks destination depending on what kind of cia it is and is a lot easier to use. That way you won't have to deal with black icons anymore.
     
  8. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    Ok will do. I'll try get the whole lot set up again fresh. Got his one black square persistent little fecker. I'll install AGB_Firm to SysNand aswell, guess I misunderstood the guide when it said install to Nand with FBI XD
     
  9. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    Forgive me, but apparently I STILL need help with this, as I CANNOT start FBI on SysNand to install the file. Any idea's? Close to just saying feck it and giving up as it's been a total headache to install AGB_FIrm to the SysNand.
     
  10. StarGazerTom
    OP

    StarGazerTom GBAtemp Advanced Fan

    Member
    774
    492
    Feb 2, 2015
    Bump Update

    I managed to get AGB_Firm working using a secondary SD Card which has Linked Nands. Meaning I'd have to carry around a second SD Card. It's not too much hastle, but I'd honestly prefer to have everything on 1 sdcard.


    Is it, or is it NOT possible to get AGB_Firm working on an Unlinked setup? If so, could someone PLEASE post clear instructions on what to do, as every guide I've found on it (I think 3.....) all are very vague, and just say "install on sysnand and emunand", with no clear indication if it can be done with unlinked setups.

    If it CANNOT be done with an unlinked setup, just say and I'll have to start carrying around a second sd. Heck, I hear that there is a way to have a Multi-Emunand setup.
     
  11. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    255
    Jan 31, 2015
    If it didn't work by restoring Health and Safety app and back to FBI then try to restore your NAND backup with Gateway Launcher.
     
  12. Voxel

    Voxel Clumsy Coder

    Member
    GBAtemp Patron
    Voxel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,155
    5,797
    Jun 27, 2015
    United Kingdom
    England, UK
    @StarGazerTom Try RxTools Dev Mode. My FBI always works using Dev Mode.