Galaxy S3 issues

Discussion in 'Android' started by ShawnTRods, Mar 28, 2013.

Mar 28, 2013

Galaxy S3 issues by ShawnTRods at 10:36 PM (395 Views / 0 Likes) 3 replies

  1. ShawnTRods
    OP

    Member ShawnTRods GBAtemp Psycho!

    Joined:
    Mar 26, 2011
    Messages:
    4,284
    Location:
    London
    Country:
    United Kingdom
    Ok, I finally got fed up of these issues.

    1) Since day one, I get no notification with twitter/facebook. I have formatted the phone couple of times, tried changing settings but nothing helps. Yes, all the notification settings are on, it simply doesnt work.(notfication with other apps/games work fine. Push email and everything else works fine)

    2) Battery.. randomly at some days it literally takes 18+ hours to charge fully and then again the charge runs out pretty quick o.o. That didnt happen too many times in the past, but last 2 weeks, it has happened over five times. I left my phone charging since yesterday night and its at 66% NOW! charging for nearly 19 hours now. *

    3) Touch screen gets out of sync randomly.. only fixes when I format the phone to factory settings. *

    4) Internet issues.. nothing to do with my wifi or 3G network. Randomly disconnects from internet. *


    *2-4
    a work colleague of mine is facing the same issues, but 1 is happening with me only. Anyone else having these issues?
    Should I contact Samsung or my carrier regarding this? Phone is not even 6 months old yet..
     
  2. Bobbyloujo

    Member Bobbyloujo I am a millipede, I am amazing.

    Joined:
    Jul 24, 2010
    Messages:
    609
    Location:
    United States
    Country:
    United States
    That's strange. I've never had these issues with my S3. Sounds like it could just be defective. Take it back to wherever you bought it from and ask for a replacement.
     
  3. Tom Bombadildo

    Contributor Tom Bombadildo Honk!

    pip
    Joined:
    Jul 11, 2009
    Messages:
    8,805
    Location:
    I forgot
    Country:
    United States
    I've experienced #4 a little bit, but turning airplane mode on and off fixes it for a while.

    As for 2 and 3 those sound like defect issues and you should contact whomever you bought it from.

    #1 seems like a software issue, I'll assume you aren't rooted/on a custom ROM? And the apps are up-to-date and everything? Tried reinstalling the apps/clearing data and cache?
     
  4. ShawnTRods
    OP

    Member ShawnTRods GBAtemp Psycho!

    Joined:
    Mar 26, 2011
    Messages:
    4,284
    Location:
    London
    Country:
    United Kingdom
    Its not rooted. Everything is up to date. Notification settings are all on. Its just twitter and FB that doesnt work properly. There might be other apps, but email and the rest of the things work fine.

    I guess I will call Three regarding this on tuesday.
     

Share This Page