EZ Flash V 3 in 1 not saving anymore

Discussion in 'GBA - Hardware, Devices and Utilities' started by Shin-Ra, Mar 10, 2009.

Mar 10, 2009
  1. Shin-Ra

    Newcomer Shin-Ra Member

    Mar 10, 2009
    United States
    I hope this is the right board.
    So, I bought my EZ V 3 in 1 3 months ago and I used it always worked fine with my fake R4 imitation (SDHC) and GBA ExpLoader 0.3.
    I used it 99% of the times in NOR mode with patched GBA ROMs without problems, but last Friday, when i was finally at the tower of Kefka in FF6 Advance, my EZ decides to delete my saved game. (luckily i made a backup of the .sav file to my pc earlier that day, so i can finish the game on an emulator)

    Anyway, the EZ is not saving, nor loading saves anymore (The games load fine). Using Final Fantasy i and II, i just can't save the game (i get a "save failed" on the game when i try to). Using a Mario game (i cant remember which), the games gives me no problem saving, but of course, when i turn the console off and on again the save is deleted. Loading saves from the .sav files to the SRAM using GBA Loader doesn't work either, (i get an error).
    It's as if the battery were just gone, because the games load fine, but i checked it with a voltimeter and it measures 3V or even more.
    Any suggestions? Thanks
  2. ClickCLK

    Newcomer ClickCLK Member

    Oct 21, 2009
    Having the same problem. I used my ez flash 3in1 with TTDS and gba_ExpLoader 0.58b for 1.5 month without any problems, usually in psram mode.One day I opened gba_exploader and there were no saves. After that my ez flash don't save/load games anymore. When I ty to boot super mario advance the rom boots up and says "Save data is corrupt". I tried both in NOR and PSRAM modes, gba_ExpLoader and ysmenu and nothing helps. Saves doesn't work. Please help on this topic.

    P.S: Sorry for my bad English...

    EDIT: and forget to say, I also checked the battery with voltmeter, it's 3v...

Share This Page