EmuNAND9 Fails to create sysNAND backup

Discussion in '3DS - Flashcards & Custom Firmwares' started by szymon170, Jul 8, 2016.

  1. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    I've changed my SD card to 32GB and formatted it with Windows 10 to Fat32 with 32kb cluster size. When I launch EmuNAND9 it sometimes doesn't work (I just got a black screen), and when it does work when I try to create a sysNAND backup it stops working at the beginning of creating this file and throws an error:
    "NAND or SD i/o failure

    Backup sysNAND to file: failed!

    Press B to return, START to reboot."
    Or it does work but it throws the same error around 20-30%. Is it normal? I've tried to do this backup many times and I'm just stopped by this random error. What should I do now? I'm following this guide for installing A9LH:
    https://github.com/Plailect/Guide/wiki/Part-2-(9.2.0-Downgrade)
    And I'm on step 24.
     
  2. OrGoN3

    OrGoN3 GBAtemp Advanced Maniac

    Member
    1,754
    368
    Apr 23, 2007
    United States
  3. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    But it fails at random moments.

    — Posts automatically merged - Please don't double post! —

    Or maybe it's because I've formatted it while it was plugged to USB adapter.
     
  4. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,043
    3,349
    Nov 13, 2014
    United States
    What brand SD and where did you buy it
     
  5. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
  6. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    Wait, I've browsed some other threads and I've formatted this card with EmuNAND9, and now I'm copying backed up files. I'm gonna post if it's working properly or not.

    EDIT:
    It's creating backup now. It's on 7% and it didn't crashed. I don't think it's a problem with brand. It's GoodRam. It's a Polish company and they make pretty decent cards.
     
  7. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    have you first formatted with guiformatter?
     
  8. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    No, I've formatted it with EmuNAND9 now. And right when I'm typing it failed with the same error on about 22%.
     
  9. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    FORMAT FIRST WITH GUIFORMATTER!
     
  10. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    OK, I was on Linux and I've rebooted to Windows (I just hate it, it's really slow and it installs updates at random moments, and the weirdest part is that it doesn't have any viruses at all). I've downloaded the guiformat and it asks me to put the allocation unit size. Is 32768 the proper size? I've set it up, in the beginning it was 16384.

    EDIT:
    I've formatted it with the 32768 allocation unit size. And now I'm creating that sysNAND backup. If it will fail I will use SD formatter (but I don't think that it will help much).

    EDIT 2:
    It failed at 43%. It's probably the first time it backed up this much. I'll try again.
     
    Last edited by szymon170, Jul 8, 2016
  11. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    Now it failed at 27%. I'm going to use SD formatter now.
     
  12. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    I've formatted it with SDFormatter, and at the first time when I tried to back up sysNAND it failed, at the second time too, then I rebooted and at the third time it failed at 20something%. Have you got any other ideas? What if it's not problem with the card, but with NAND (for example problem because I've downgraded it to 9.2)?

    — Posts automatically merged - Please don't double post! —

    Now I've tried formatting it with EmuNAND9 but I didn't copied the backup of my card from the computer. I've just tried to make a backup on an empty card. And guess what! ... It failed again.
     
  13. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    Do you know where is the problem? I really want to get A9LH and I'm just really desperate now. Maybe I should use default 4GB card and after all of the work I should copy everything from this card to the 32GB one? Or maybe I should use my another 16GB card used for my Wii?
     
  14. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    OK, it was problem with the card. When I used the default 4GB one the backup was created successfully at the first time. So I've got another question. Can I use this 32GB card after doing A9LH if my 3DS detects it but it throws errors when creating NAND backup on it? And if no, which card should I use?
     
  15. OrGoN3

    OrGoN3 GBAtemp Advanced Maniac

    Member
    1,754
    368
    Apr 23, 2007
    United States
    You should throw that card away. It is clearly a bad card. You should never trust it. Get a new card or if your card is within warranty, RMA it instead of throwing it away.
     
  16. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    is your 32GB one is micro sd card? are you using micro sd to sd adapter? if yes then replace the micro sd to sd adapter as that could be having loose contact causing errors. if still gives issue and have bought it from online shops (other than amazon) or local shops then probably a fake one and you should avoid using it and replace it if you can
     
    Last edited by Just3DS, Jul 9, 2016
  17. szymon170
    OP

    szymon170 Pr0FessiuNal HelPeR wiTh HaxXX

    Member
    366
    108
    Jan 2, 2016
    Poland
    Where I live
    I'm using New 3DS so I don't need to use SD Adapter. I'm using SD adapter for my PC so I plug my microSD card into my PC.

    — Posts automatically merged - Please don't double post! —

    BTW I have made these backups with the default card and I have used the default card through all of the A9LH installation. And now I've switched the cards and I'm using the 32GB one. And I don't have any problem with it. CIAs install fine, games are running fine, sysNAND is running at normal speed... I don't know why should I throw this card away. It's a nice card.