Doing a "Monkey D. Luffy" on a 2DS

Discussion in '3DS - Flashcards & Custom Firmwares' started by MisterPantsEyes, Jan 14, 2016.

  1. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    I want to buy a 2DS for a kid and because I don't have any money for games, I want to "Straw hat" it. You know what I mean, a full "Captain Jack Sparrow", "Monkey D. Luffy", or, how the simple people might call it, "arrr!".

    I don't know much about doing this and the threads seem a little complicated. Can the 2DS be over 9.2? I don't want to buy any flashcards.
     
    imthe666st and sailor_moon like this.
  2. sarkwalvein

    sarkwalvein Professional asshole at GBATemp

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,885
    4,954
    Jun 29, 2007
    Germany
    Niedersachsen
    AFAIK (and I am not knowledgeable on this topic) if you hurry up you will be sure your new system is below 10.3, and a 10.3 system can be downgraded to 9.2, then a 9.2 system can get a custom firmware installed that I suppose is what you want.
    Also, supposedly most 2DS come with <=9.2 so it may be even easier, but some of them (transparent ones e.g.) come with newer fw, that still can be downgraded.

    PS: Check better, I don't know too much about this.
     
    MisterPantsEyes likes this.
  3. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    Thanks. Change of plans, I want to buy this blue 3DS XL: http://www.amazon.co.uk/gp/product/B018IKLLNS?psc=1

    Does anyone know what FW this could have?
     
  4. Author

    Author ****NEWS**FLASH**** 1 /̵͇̿̿/'̿-̅-̅-̅''

    Member
    458
    419
    Aug 30, 2014
    GBAtemp
    if its 10.3 or below youre good. and as far as i'm aware, no 3ds has been shipped with 10.4 yet, because it's not even out. so go ahead and buy it and then downgrade to 9.2, install CFW and games :^D
     
    MisterPantsEyes likes this.
  5. nero99

    nero99 GBAtemp Advanced Maniac

    Member
    1,907
    867
    Sep 18, 2014
    United States
    that system will come with a minimum fw of 6.3. IF its the legit bundle system and not just a game included with a system. but it will most likely be below 9.0
     
    MisterPantsEyes likes this.
  6. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    It's not the bundle. :/

    I bought it and it will come in 2 days. So the title is inaccurate now, because I'm not doing anything with a 2DS.

    Before I ask further questios, I will elaborate my situation.

    I currently have a red 3DS XL with Gateway, now I bought this blue 3DS XL. I want to give the old red 3DS XL to a little girl and keep the blue 3DS XL for myself. Because I only have one Gateway, one will run with a CFW. I think it's better if I use a Gateway and the kid a CFW.

    So what I will do on the blue 3DS XL is:
    1. Downgrade to 9.2 (if it's above)
    2. Downgrade to 4.5
    3. Install Gateway

    Now, can I just put my SD stick with emuNAND and all the installed CIAs from the red 3DS XL into the blue 3DS XL? Because I don't want to install everything again. Is there maybe a tutorial on this?

    And what I will do on the red 3DS XL:
    1. Wipe everything
    2. Install CFW
    3. Install CIAs

    The problem here is that I really don't know how to install CFW. There are many CFW and I don't know which one is the best.

    HELP PLEASE :D :(
     
  7. pofer

    pofer GBAtemp Fan

    Member
    326
    104
    Jan 4, 2016
    Spain
    Somewhere around the corner
    https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/
     
    MisterPantsEyes and Zidapi like this.
  8. sarkwalvein

    sarkwalvein Professional asshole at GBATemp

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,885
    4,954
    Jun 29, 2007
    Germany
    Niedersachsen
    Regarding the blue 3DS XL, I don't think it is convenient to downgrade it to 4.5, it is better leave it at 9.2, and so you will avoid save incompatibility in actual game cards.
    (also, I have a GW and I don't use it anymore because I find it less convenient than an autobooting rxtools/menuhax based emunand, but that is just my preference)

    Regarding the red 3DS XL, let it stay in FW 9.2 so you can use menuhax for emunand coldboot, it is beautiful, makes you life easier and in general avoids update problems.
    Then install RxTools, and pay special attention to the "Launching rxTools at Boot - Menuhax!" in the tutorial posted above.
    But be aware, you can't use your SD card with the emuNAND from one 3DS into a different 3DS, it will not work. You will have to backup your saves in the old system with sdf, reinstall everything in the new system, and restore your saves with sdf.
     
    Last edited by sarkwalvein, Jan 16, 2016
    MisterPantsEyes likes this.
  9. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    My old red 3DS XL isn't on 9.2, but on 4.5. So if I don't downgrade the blue 3DS XL, I can't use my CIA saves (I think?).

    Isn't it possible to coldboot on 4.5? How difficult is it then? Asking because the kid is 7 and can't read properly, so it shouldn't be too complicated.

    This makes me angry and sad at the same time. I feel the need to convert to Islam everytime I read this. But not even Allah could stop my simultaneous anger and sadness. >:-(
     
  10. sarkwalvein

    sarkwalvein Professional asshole at GBATemp

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,885
    4,954
    Jun 29, 2007
    Germany
    Niedersachsen
    I am not sure but I think you may have problems with the CIA saves, specially if they belong to some game that requires FW > 6.0.
    It is not possible to coldboot on 4.5, the best you can do there is the MSET exploit and go to settings every time to trigger it, you install that using a DS flashcard (you probably have done that already on GW, is quite similar, but you use a different MSET installer for rxtools... I think)
    I think the best you can do for the kid is make it coldboot to rxtools automatically, using menuhax, but that requires system firmware between 9.0 and 9.2.
     
  11. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    I'm still thinking on what to do. I got the 3DS now and it's on 6.2. So if I don't downgrade, I can't use my CIA saves from my old 4.5 3DS. Is that correct?
     
  12. dpad_5678
    This message by dpad_5678 has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  13. MisterPantsEyes
    This message by MisterPantsEyes has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  14. sarkwalvein

    sarkwalvein Professional asshole at GBATemp

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,885
    4,954
    Jun 29, 2007
    Germany
    Niedersachsen
    I would recommend to backup all the savefiles with sdf, upgrade to 9.2 to use menuhax, and restore all the savefiles with sdf.
    I have not tried, so I don't really know if that will work, but perhaps, who knows, try it. (and let us know, be the guinea pig for the sake of the community! :creep:)
    Worst case scenario downgrade and restores the savefiles with sdf again. (or you start playing your games again, but that might be a pita)
     
  15. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    If it wasn't for Pokémon AS, I wouldn't even care about the saves. But that's a bit too risky too for me and it would be too much work. Besides that, I don't even know how to update the ofw to 9.2.

    I will just downgrade the blue 3DS XL now.
     
  16. dpad_5678
    This message by dpad_5678 has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  17. Meteor7
    This message by Meteor7 has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  18. sarkwalvein
    This message by sarkwalvein has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  19. hundshamer
    This message by hundshamer has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  20. MisterPantsEyes
    This message by MisterPantsEyes has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  21. sarkwalvein
    This message by sarkwalvein has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  22. hundshamer
    This message by hundshamer has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  23. dpad_5678
    This message by dpad_5678 has been removed from public view by raulpica, Jan 18, 2016, Reason: Off-topic -rp.
    Jan 18, 2016
  24. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    11,025
    7,344
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    Either help or don't post at all guys. We have no need to turn every CFW thread into a moral discussion. Thanks.
     
  25. subcon959

    subcon959 teh retro

    Member
    736
    430
    Dec 24, 2008
    I'm thinking a 7 yr old might be better off with the GW.
     
  26. Quantumcat

    Quantumcat Dead and alive

    Member
    10,537
    5,565
    Nov 23, 2014
    Australia
    Canberra, Australia
    Me too. You want the kid to use the least complicated method. Especially if you set it to autoboot.
     
  27. Adeka

    Adeka Beta Tester

    Member
    4,102
    1,276
    Mar 19, 2013
    United States
    Having rxtools auto-boot and the adult install the games is pretty kid-proof
     
  28. subcon959

    subcon959 teh retro

    Member
    736
    430
    Dec 24, 2008
    It would be pretty easy for a kid to end up in the rxtools settings menu on boot.
     
  29. MisterPantsEyes
    OP

    MisterPantsEyes GBAtemp Fan

    Member
    344
    223
    Jan 10, 2015
    Laos
    I installed rxTools and emuNAND on the red 3DS XL, it's booting through the DS Settings menu.

    Now I will start working on the newly bought blue 3DS XL. First I will downgrade it to 4.5 with Gateway. This is really intense, I hope nothing goes wrong...

    edit: Everything went fine. :-)
     
    Last edited by MisterPantsEyes, Jan 19, 2016