cifsd command preventing smooth Plex streaming from RPi3

Discussion in 'Computer Software and Operating Systems' started by DiscostewSM, Oct 10, 2018.

  1. DiscostewSM
    OP

    DiscostewSM GBAtemp Guru

    Member
    12
    Feb 10, 2009
    United States
    Sacramento, California
    To note, I am using a Raspberry Pi 3 Model B for retro emulation with RetroPie at the base (though I may move my retro fix to Switch with RetroArch), but also have Plex Media Center and Transmission running on it with ExpressVPN installed. What I've done is connected an ext HDD to my Netgear router (r6700v2), and making it ReadySHARE so that I'd mount specific folders upon RPi3 boot. One for Plex, one for RetroPie, one for Transmission, and one password-protected for general access to the drive. It's been very good to me for a while, but within the past week I've been having a buffering issue now and then when streaming through Plex. It's not an issue with video transcoding as video streamed are Direct Play. Audio streams do have to be transcoded from AAC to AC3, but RPi3 seems very capable of that with room to spare with all these other processes running. So, I went in remotely with PuTTy on my laptop, and ran the "top" command. This is what I've see.

    Warning: Spoilers inside!

    When I took this screenshot, I had already stopped streaming from Plex, so those processes are less. From what I read, "cifsd" is an open-source in-kernal CIFS/SMB server for Linux. Now, when I mounted the ext HDD folders for RPi3 to use, the lines did have CIFS in them (drive is formatted NTFS), so I could imagine those are linked in some manner, but I never had this problem before, not from months of use. It just seems like the ext HDD is being read to its max, preventing my Plex streaming from being usable. On my router even with Plex not actively streaming during this instance, the light for the USB 3.0 port is blinking constantly, whereas the lights for internet and the LAN port that the RPi3 is attached to as blinking together at a lesser rate. Thought perhaps this was some intrusion from the internet, so I disconnected the router from the modem, but that changed nothing. Didn't seem like someone accessed my router wirelessly, else I'd see it listed as an Attached Device.

    So what could be happening, if not an intrusion? I only know enough and reading directions to get my RPi3 to work like this, so I don't know what could cause this issue. I can reboot the RPi3 through PuTTy with "sudo reboot", and the Pi runs well for a bit after that, but then cifsd kicks back up the the top in time, and it all starts over again.
     
    Last edited by DiscostewSM, Oct 10, 2018
  2. DiscostewSM
    OP

    DiscostewSM GBAtemp Guru

    Member
    12
    Feb 10, 2009
    United States
    Sacramento, California
    Nvm, turns out that my RPi3's time/date was assigned to UTC (Universal Time Coordinated) instead of my local time/date, and what was happening at this time was Plex was running its Scheduled Tasks. It was assigned to run them between 2am and 5am, but because of running on UTC, the time was designated between those times, hence, it ran the tasks and held up my system. I guess the time zone was not set, so I fixed it by running "sudo raspi-config" in PuTTy -> Localization Options -> Change time zone, and set it to my time zone. Now the time/date is correct and defaulted to my time zone instead of UTC. Everything seems to be working as it should now. Only found this out because I could still stream directly from my ext HDD on my router to my laptop without Plex when this happened, so it wasn't a bandwidth issue there with the drive, but with the RPi3 itself.
     
    Last edited by DiscostewSM, Oct 10, 2018
Loading...