CFG USB Loader: Partition not found!

Discussion in 'Wii - Backup Loaders' started by Coronach, Dec 1, 2012.

Dec 1, 2012
  1. Coronach
    OP

    Newcomer Coronach Member

    Joined:
    Sep 25, 2012
    Messages:
    10
    Country:
    United States
    So, this problem cropped up ever since I got my new 16gb USB drive to store old games on. Normally with CFG I have a USB HDD plugged in for my Wii games.

    Now that I'm switching between the two, and since only one of the USB ports seems to actually work with any of the apps I use, I've encountered this problem, and I'm not sure how to fix it, even if there is a fix.

    The HDD is formatted as NTFS1.
    The Drive is formatted as FAT1.

    So it comes up whenever I run CFG loader:

    Partition: NTFS1/FAT1 not found!
    Select a different partition

    Press A to select a partition.
    Press B to change device.


    So I press A, and it changes to:

    P# -- Size(GB) -- Type -- Mount -- Used
    P#1 -- 14.45 -- FAT1 -- usb:

    That is for the USB drive. All I have to press is A and it mounts it fine.

    The thing is, in the settings it had the options to select whether to look for a FAT/NTFS partition, to automatically load one, or to ask each time.

    I tried using AUTO...but nothing happens. I honestly thought if I had "partition = auto" in my Config.txt, it would automatically load up the WBFS folder if the HDD was plugged in, or the Games folder if the Drive was. But it still gives the error, this time saying that the "auto" partition doesn't exist.

    I tried switching to Ask, to make it ask me which to load at startup, but that doesn't work either. It just tries to load a partition known as "ask1".

    What am I doing wrong with the settings? I tried setting this via the Configurator, so either something is wrong within that, or I'm expecting too much from this. Any help would really be appreciated. It's not a huge problem, but it gets to be irritating.
     
  2. oggzee

    Member oggzee GBAtemp Addict

    Joined:
    Apr 11, 2009
    Messages:
    2,335
    Country:
    Slovenia
    I think when you save the settings from inside the loader, it will also save the current device and partition selection. This is saved to /usb-loader/settings.cfg, something like:

    # Global Settings:
    device = usb
    partition = FAT1

    Now, this file probably has priority over what is in config.txt, but I don't remember the details anymore. And even if you would remove or change these settings, they would be overwritten next time you save settings from inside the loader... so I don't have a good solution for your case, except pressing A and selecting a partition each time you change the hdd. If you don't change it too often you can save the settings and next time you start the loader it will not complain.
     

Share This Page