Block 3DS updates other method than dns

Discussion in '3DS - Flashcards & Custom Firmwares' started by artur3004, Aug 17, 2015.

  1. artur3004
    OP

    artur3004 GBAtemp Fan

    Member
    486
    124
    Mar 31, 2015
    Gambia, The
    I'm planning to lend my 3DS to my friend and even he understand that the 3ds is not allowed to update from 9.2, I'm still worried if he accidentally updates. Or in general.
    What are the possibilities to block updates for the 3ds besides blocking the update server connection by the router?

    MSET Downgrade sound interesting, I could start RXTools etc. and GW Launcher by Profile exploit and could delete all wifi settings.
    Is that possible
     
  2. Tjessx

    Tjessx GBAtemp Maniac

    Member
    1,157
    508
    Dec 3, 2014
    Belgium
    You could just change the dns in the internet settings of your 3DS to a server which blocks the nintendo update servers.
    (the one smealum provides should do the trick with his tubehax)
     
    artur3004 likes this.
  3. artur3004
    OP

    artur3004 GBAtemp Fan

    Member
    486
    124
    Mar 31, 2015
    Gambia, The
    Oh great, good to know, thx!
    But would Profile exploit work on downgraded mset? I'd would be nice starting homebrew without having internet, you can't have it anywhere, ya know?
     
  4. Inochi.no.Zenmai

    Inochi.no.Zenmai GBAtemp Regular

    Member
    182
    102
    Jun 1, 2013
    United States
    As far as I know, the console won't download the update automatically as long as you don't put it in sleep mode.
     
  5. bjaxx87

    bjaxx87 GBAtemp Fan

    Member
    329
    107
    Jun 17, 2011
    Germany
  6. artur3004
    OP

    artur3004 GBAtemp Fan

    Member
    486
    124
    Mar 31, 2015
    Gambia, The
    So, MSEt 6.x is supported by rxTools and Gateway?
    But DS Profile Exploit starts only one Launcher, so I need to use a DS Flashcard for switching or I use THIS browser "switch" application. I still need Internet connection.
    is there any possibility to use more than one DS profile launcher without Internet or DS-Flashcard? Like a launcher-launcher?
     
  7. bjaxx87

    bjaxx87 GBAtemp Fan

    Member
    329
    107
    Jun 17, 2011
    Germany
    Unfortunately Gateway doesn't support downgraded system settings on O3DS yet (it does on N3DS), so you have to downgrade your whole SysNAND if you want to use MSET for O3DS.

    There's no "launcher-launcher", you'd have to reinstall the exploit everytime you want to switch between Gateway and rxTools.

    Alternatively you could just use 3DS X-Loader to boot either launcher.dat or rxtools.dat offline (you can change the target launcher in the app).
     
  8. artur3004
    OP

    artur3004 GBAtemp Fan

    Member
    486
    124
    Mar 31, 2015
    Gambia, The
    Right, i completely forgot the app, oh boy, that's better
     
  9. loco365

    loco365 GBAtemp Guru

    Member
    5,458
    2,674
    Sep 1, 2010
    You guys do also realize that cartridges can hold updates too which can bump you beyond 9.2? There's basically no way to stop those unless they just don't play those games.
     
  10. Cavioe

    Cavioe GBAtemp Fan

    Member
    308
    72
    May 28, 2015
    United States
    Actually cartridges are easier to stop than that sleep mode download nag. All you have to do is set parental controls for software ratings.
     
  11. loco365

    loco365 GBAtemp Guru

    Member
    5,458
    2,674
    Sep 1, 2010
    I've heard that doing that no longer works, unless I read wrong...?
     
  12. Cavioe

    Cavioe GBAtemp Fan

    Member
    308
    72
    May 28, 2015
    United States
    Well updating with a cartridge can be blocked with parental controls still. If you set the restrictions for software rating you can pick the lowest one called EC for kids. And from what I have searched Nintendo no longer makes EC games. So you pretty much block out all games. This is useful especially when you have someone who picks up your 3ds in your house and put in their game. So with EC games being only allowed it will not let someone play a game like code name steam with a 9.4 update as they need your pin. So when this happens I just boot them to the CFW and they can play the cartridges they want.