Banner Pixely/Weird

Discussion in 'Wii - Hacking' started by Mrkinator, Oct 13, 2008.

  1. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Okay, so I made a custom banner and this is what it looks like (nothing special, just made it in flash)

    [​IMG]

    But when it's on the wii it looks all pixely and weird

    [​IMG]

    Here's a close up

    [​IMG]

    I'm not sure what's wrong. Anybody know
     
  2. HowardC

    HowardC GBAtemp Fan

    Member
    490
    1
    May 4, 2008
    United States
    The current u8tools (mine included) have an error which cause banners of certain sizes to corrupt the image. I am working on a solution as we speak, but in the meantime, if there's any way you can reduce the size of any of the files in the banner by one byte, that should do it.
     
  3. A252

    A252 Member

    Newcomer
    41
    0
    Dec 18, 2006
    edit
     
  4. Deepest

    Deepest Member

    Newcomer
    16
    0
    Sep 17, 2008
    I have a banner similar to the above, that I've downloaded from another thread. Does anyone know of a guide that I can follow which will allow me to install the backup loader in its very own channel. I'm accessing the loader the via the homebrew channel at the minute but it would be more convenient to access the loader directly from the wii dashboard menu.

    Any help, tutorials or guides anyware?
     
  5. SanGor

    SanGor Witchhunter

    Member
    993
    79
    Aug 21, 2008
    United States
  6. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    So you have a wad right? Just download WAD manager for the wii and it will install it [​IMG]
     
  7. SanGor

    SanGor Witchhunter

    Member
    993
    79
    Aug 21, 2008
    United States
    you have to supply an argument ie:

    Code:
    U8.exe somefolder
     
  8. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    I'm gonna try what HowardC said and reduce the size of the image.
     
  9. linkinworm

    linkinworm GBAtemp Maniac

    Member
    1,374
    39
    May 30, 2008
    Birmingham (England)
    any way to get moving banners working yet?
     
  10. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Do you mean animation? I don't think so but that be sweet!!

    Edit: It worked!! I shrank the image a few bytes and it worked! (the quality is still okay too.) If anybody wants me to upload it, just ask.
     
  11. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
  12. SanGor

    SanGor Witchhunter

    Member
    993
    79
    Aug 21, 2008
    United States
    you are pretty insane for using a broken U8 packer, it could easily end up in a brick [​IMG]
     
  13. Deepest

    Deepest Member

    Newcomer
    16
    0
    Sep 17, 2008
    excellent I didn't realise the creation of a banner would be littered with such problems, thanks for the work on this it makes it so much easier.

    So its relatively okay/safe to install this using the the wad manager via homebrew channel then?
     
  14. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Yes, It's fine to install. Were you gonna use mine? (It's okay if you weren't, I don't really care [​IMG] )
     
  15. SanGor

    SanGor Witchhunter

    Member
    993
    79
    Aug 21, 2008
    United States
    yes but that bug could affect other more import files, a borked picture might not be so bad but imagine what a broken config(insert other important filename) file could cause!
     
  16. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Ah yes, point taken. Hopefully HowardC fixes it in his set of tools
     
  17. HowardC

    HowardC GBAtemp Fan

    Member
    490
    1
    May 4, 2008
    United States

    Well, they are ALL broken, so by that logic editing a banner period is pretty insane. I've found various bugs in all of the u8 tools, not just mine.

    Editing banners is pretty safe, it is quite difficult to brick your wii from it unless the 0.app is corrupted. Generally speaking if the banner.bin or icon.bin are corrupted they just show up blank.
     
  18. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Good to know. I have another question for anyone. Whenever I unpack a wad and I install it, I get error 4100 w/ the Wad Manager. I know it's the unpacker because HowardC's U8 tools give me an error and I've had someone else unpack the wad for me and It worked perfect when installed (I've asked this before, but I haven't got a response).
     
  19. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Can I get help with this please?
     
  20. Mrkinator
    OP

    Mrkinator Neil Peart Wannabe

    Member
    890
    0
    Sep 28, 2008
    Canada
    Great White North, Eh!
    Anyone?! I really want to know so I can make more banners