FrameRate Running To High

Discussion in 'Computer Games and General Discussion' started by Dakota Nix, Sep 15, 2016.

  1. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    When I play Dark Souls 3 my FPS stays at 120. Most games that is good if the FPS doesn't effect the mechanics but it kinda breaks this game. I never seen a blacksmith hammer so fast nor a enemy move so fast it freezes.
    I have: ASUS 64bit G11CD series's
    Intel i7-6700 @3.40ghz
    16gb ram
    Nvidia 970

    My monitor is an Acer z35 predator with gsync (max 144hz)
    I have an widescreen .ini that fixes my screen resolution to 2560/1080.
    I have tried to use Nvidia inspector to limit FPS to 60fps but it makes its choppy and noticeable.
    Used without the widescreen ini file. Turning v-sync on. Even setting my screen FPS to 60. All it does is play at 120 FPS. That's even at max graphics and everything. I am open to ideas to try. I use to stay around 60 FPS but that was when I was playing it connected to my 39" lg tv running a 29 or 30hz.
     
  2. Mikemk

    Mikemk GBAtemp Advanced Maniac

    Member
    1,557
    555
    Mar 26, 2015
    United States
    Try setting the monitor framerate to 30 fps.
    Or turn off gsync.
     
  3. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    The lowest my monitor goes to is 60 FPS but I will try turning off gsync and checking. I forgot about having that on.


    Sent from my iPhone using Tapatalk

    So I turned it off and it dropped down to 88-90 frames. Running max settings and full widescreen. That seem to help. I just don't understand. I swore this game had a cap limit that it wouldn't go pass


    Sent from my iPhone using Tapatalk

    Anything really over I notice causes breaks in movement


    Sent from my iPhone using Tapatalk
     
  4. Zanoab

    Zanoab GBAtemp Regular

    Member
    110
    25
    Dec 4, 2009
    United States
    Bad console ports generally tie physics to fps. If you go over 60 (sometimes even 30) fps, the game's physics engine will speed up and get really weird. As for setting a cap, I have no idea.
     
  5. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    Like I have absolutely no clue why it would run wide open like this when I have my monitor FPS set to 60, and set the ini file to run at 60. I turned gsync off now after trying something else it's back up to 120. Heck even saw it go a little higher.


    Sent from my iPhone using Tapatalk

    90 seems like the lowest I can reach. I just marked the ini to limit 60, monitor to 60 and set the .exe launcher to run vsync(1/2 refresh rate)


    Sent from my iPhone using Tapatalk
     
  6. Mikemk

    Mikemk GBAtemp Advanced Maniac

    Member
    1,557
    555
    Mar 26, 2015
    United States
    Well, you can always increase your graphics settings or underclock your GPU.
     
    TotalInsanity4 likes this.
  7. Armadillo

    Armadillo GBAtemp Psycho!

    Member
    3,592
    1,554
    Aug 28, 2003
    United Kingdom
    I thought Dark Souls 3 was capped at 60 to stop issues like this.

    Anyway, it probably felt choppy at 60fps with Nvidia inspector because of shitty framepacing. Try using RTSS to cap instead as that tends to do a proper job and caps with proper frame pacing as well.
     
  8. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    7,217
    7,303
    Dec 1, 2014
    United States
    Under a rock
    That would be the hassle-free way of doing it, I'd think. Lower the resolution and max out the settings and it should settle the framerate down pretty quickly
     
  9. kprovost7314

    kprovost7314 GBAtemp's Official Bara Master

    Member
    1,691
    890
    Dec 24, 2014
    United States
    In that bara manga ( ͡° ͜ʖ ͡°)
    Wait, framerates can go too FAST? I need an upgrade...
     
  10. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    I am playing it at max settings trying to lower it, and I haven't tried lowering the gpu because it played fine on my tv. It just started when I got my new monitor.
    Me too. I swore it had a cap as well. But it doesn't have a great ini file to edit that I could find. Nvidia inspector works great on my fallout 4 but made dark souls 3 choppy and unplayable when I slowed it to 60fps. I will give RTSS a try. Is it the same/similar as Nvidia inspector?
    I tried many different stuff tbh trying to slow it done but nothing has worked. Even the ds3e program I use to set up ultrawidescreen resolution to fit my monitor. Would think max graphics, widescreen mode resolution, and poor optimization would slow it. Even running vsync at 1/4 refresh rate didn't work.
    It's only a problem if everything is tied to the frame rates. Like dark souls 3 mechanics are linked to the frames and fallouts 4 locking picking is virtually impossible at anything above 100. I uncapped fallout 4 and had the dang thing running 500ish frames in the lock pick screen. Made it impossible to do anything. Hence why I have Nvidia inspector limit my frames to 90-100 FPS.


    Sent from my iPhone using Tapatalk
     
  11. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    7,217
    7,303
    Dec 1, 2014
    United States
    Under a rock
    Have you tried increasing resolution past what the monitor can display and maxing settings? At this point I'm asking more because I'm curious as to if it would work lol
     
  12. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    I know you can go higher res but the game doesn't, how do I say ,natively support it. I am running on 2560/1080(2k) which involved me having ds3e and making changes to the xml file to force it into no black bar wide full screen via borderless windowed then allowing it to force itself back into full screen and I think you can increase it further to 3440/1440(4K or triple monitors).


    Sent from my iPhone using Tapatalk
     
    TotalInsanity4 likes this.
  13. Armadillo

    Armadillo GBAtemp Psycho!

    Member
    3,592
    1,554
    Aug 28, 2003
    United Kingdom
    Never used nvidia inspector (on AMD at the moment), but you just add the .exe and set an fps cap. The main difference between rtss and other capping programs, is the framepacing/timing. At 60fps, RTSS makes sure the frames are delivered correctly, spaced at 16.66ms apart.

    Other capping options often deliver inconsistent frametimes, it still averages out at 60/30/whatever cap you have, but the times between frames are not evenly spaced which gives a noticible judder.

    You can see in this article here about it and Witcher 3. http://www.pcgamer.com/durantes-witcher-3-analysis-the-alchemy-of-smoothness/. While capping to 30fps, RTSS delivers near enough constant 33.33ms frametimes, while the other options for capping (in game, in this case), have frequent frametime spikes which result in judder/choppy gameplay :(.
     
  14. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    That is what happened in ds3. It does limit to 60 FPS but you can see the frames being forced to it and it can't fully cap the speed itself. It becomes unbearable. Rather have the enemies warping when they jump and the blacksmith hammer so fast he arms warp up and down lol but I will try RTSS


    Sent from my iPhone using Tapatalk
     
  15. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,632
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    i had issues with old games or bad ports running too fast..
    for example in mafia 1, some missions are impossible to complete if you don't underclock it at less than 25 fps...
    one temporary but ok solution was to use fraps, i don't remember if i actually had to record or use the benchmark thing.. but i know it could lock the framerate...
    you can also use your GPU config tool (like nvidea) to enable V-sync forcing it to run at the monitor rate usually 60fps\hertz
     
  16. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    That basically what the Nvidia inspector is. It gives more customization to the gpu. I tried using the Nvidia control panel and editing the exe for dark souls. I then even tried to vsync (1/4 refresh rate) to reduce my frames by that much. Even turning my gsync off and switching to an normal hdmi cable and using vsync it plays at 120 FPS.


    Sent from my iPhone using Tapatalk
     
  17. Dakota Nix
    OP

    Dakota Nix Advanced Member

    Newcomer
    76
    7
    Jan 26, 2016
    United States
    I couldn't find a link directly for RTSS but it lead me to msi afterburner and I installed that server program as well. I'm running it at 60fps on stealth mode. Ds3 doesn't like anything running along side with it so hopefully no ban. But I am now at 60fps no tearing or derps from limiting it so far.


    Sent from my iPhone using Tapatalk