[Tutorial] Updating from rxTools to Luma3DS

Discussion in '3DS - Tutorials' started by MattKimura, May 23, 2016.

May 23, 2016
  1. Dothackjhe

    Member Dothackjhe GBAtemp Regular

    Joined:
    Dec 29, 2013
    Messages:
    150
    Location:
    Philippines
    Country:
    Philippines
    My O3DS XL had always been on rxTools (bootable via MSET) while its sysnand is on 8.1.0-19U.

    Following this guide, it said about copying "Luma3DS.dat from the mset-spider folder to the root of the SD" which surmises as leaving the "Luma3DS.dat" as is whereas this guide tells about the need to rename it to "launcher.dat."

    Specifically, this guide says: "5. Rename Luma3ds.dat file to launcher.dat"

    Which exactly is the step that I should follow?

    [Update]

    I tried either way, none worked in making Luma3DS boot from my unit after transitioning from a formerly working rxTools setup (via MSET).

    I also even resorted to using Luma3DS NDS launcher via a DS Flash Cart and choosing to patch for "6.X" since there is no option aside from 4.X and 6.X, but to no avail.

    [Update]

    I made this thread at Luma3DS's GitHub page: https://github.com/AuroraWright/Luma3DS/issues/380
     
    Last edited by Dothackjhe, Mar 13, 2017


  2. Byokugen

    Member Byokugen GBAtemp Fan

    Joined:
    May 16, 2016
    Messages:
    487
    Location:
    Just a bit to the right, or was left...
    Country:
    Serbia
    Will there be update for luma? Last one 6.6 on nov. 12. 2016 :-(
     
  3. bololabich

    Newcomer bololabich Member

    Joined:
    Feb 27, 2015
    Messages:
    25
    Country:
    Poland
    Doesn't work at all :(
    I tried both renaming the file as launcher.dat and rxTools.dat but every time is just crashes the same way as if there was no sd inserted :( and after updating the emunand it doesn't boot anymore
     
  4. MattKimura
    OP

    Member MattKimura 3DS & WiiU Enthusiast

    Joined:
    Jun 30, 2014
    Messages:
    1,617
    Country:
    United States
    1. This guide is very old
    2. It's been forever since I used that old setup so I can't really tell you how to fix it anymore
    3. You're better off with Arm9loaderhax, it's super easy to setup these days and it's way better.
     
  5. bololabich

    Newcomer bololabich Member

    Joined:
    Feb 27, 2015
    Messages:
    25
    Country:
    Poland
    well how to do it? the thing is I don't really want to lose all my saves which are on emu nand :(
    BTW does luma work on 6.x? because I read somewhere that I'd need an update to 9.x
     
    Last edited by bololabich, Mar 23, 2017
  6. MattKimura
    OP

    Member MattKimura 3DS & WiiU Enthusiast

    Joined:
    Jun 30, 2014
    Messages:
    1,617
    Country:
    United States
    You won't lose your saves or anything like that. You'll eventually come across a step where you move emunand to sysnand, then delete emunand. If your sysnand is on 6.x, you can start setting up Arm9loaderhax from there, you dont have to be on 9.x
     
  7. Dothackjhe

    Member Dothackjhe GBAtemp Regular

    Joined:
    Dec 29, 2013
    Messages:
    150
    Location:
    Philippines
    Country:
    Philippines
    Did not work with me as well. I assume the latest build of Luma3DS has got to do with this i.e. it was patched for better compatibility with A9LH but render MSET obsolete. I remember someone from GitHub suggesting using an older version of Luma3DS to make MSET work. Sadly, older versions of Luma3DS are no longer being hosted at GitHub.

    In the end, I just went through the A9LH route in trying to make Luma3DS run with my O3DS XL. Luckily, the process was successful.
     
    MattKimura likes this.
  8. bololabich

    Newcomer bololabich Member

    Joined:
    Feb 27, 2015
    Messages:
    25
    Country:
    Poland
    I see. Could you give me a link how to make an update to Arm9loaderhax then. BTW I'm not sure if my emunand is even working anymore since I made an update and then when it restarted it gives a black screen on boot (because of rxtools being banned), the hell i could not even find the emu nand files on my SD :/
     
  9. Dothackjhe

    Member Dothackjhe GBAtemp Regular

    Joined:
    Dec 29, 2013
    Messages:
    150
    Location:
    Philippines
    Country:
    Philippines
    Just follow the guide carefully and make sure not to put your unit to sleep mode or shut it down at any point in the hacking process unless otherwise stated: https://3ds.guide/
     
    bololabich likes this.
  10. Pacheko17

    Member Pacheko17 かっこい男の子

    Joined:
    Jan 31, 2015
    Messages:
    965
    Location:
    Southern Confederation
    Country:
    Brazil
    Kinda. Luma doesn't need that, you can just install everything to sysnand and it will be fine.
     
  11. Dothackjhe

    Member Dothackjhe GBAtemp Regular

    Joined:
    Dec 29, 2013
    Messages:
    150
    Location:
    Philippines
    Country:
    Philippines
    Luma3DS is basically a full custom firmware for the 3DS. As soon as you turn on your unit, it boots directly to CFW without the need for Emunand.
     
  12. Sirence

    Member Sirence GBAtemp Regular

    Joined:
    Feb 22, 2015
    Messages:
    108
    Country:
    Germany
    I just got an an o3ds on 4.5 that boots rxTools with mset. I was asked to update the emunand to 11.4 so I would need to swap rxtools for luma.

    My question is, can you boot luma on 4.5 with mset? I don't want to update the sysnand, just swap the files and launcher.dat on the sdcard.
     
  13. Byokugen

    Member Byokugen GBAtemp Fan

    Joined:
    May 16, 2016
    Messages:
    487
    Location:
    Just a bit to the right, or was left...
    Country:
    Serbia
    Just follow the https://3ds.guide/ :-)
     
  14. Sirence

    Member Sirence GBAtemp Regular

    Joined:
    Feb 22, 2015
    Messages:
    108
    Country:
    Germany
    I am not getting money for it so I can not spend more like 10 minutes on it. Also this is not my console, so I am not going to touch the sysnand or update on something I do not own. My question is, can I swap the launcher.dat files and be done, or does luma not boot from 4.5? In that case, would ReiNand?
     
  15. Sakura1

    Newcomer Sakura1 Member

    Joined:
    Aug 6, 2014
    Messages:
    27
    Location:
    Cincinnati, Ohio
    Country:
    United States
    So I have an o3ds at 6.00 and was wondering if I could install Luma3ds? since I heard rxtools is outdated and pretty much bc Im being left out of fun english patch games.

    SO I have rxtool installed and am at ver 6.0.0 in system firmware? do I have to do an update to 9.0.0? or can I stay at 6.0.0 and still be able to move to luma3ds?
     
  16. MattKimura
    OP

    Member MattKimura 3DS & WiiU Enthusiast

    Joined:
    Jun 30, 2014
    Messages:
    1,617
    Country:
    United States
    I'll help you setup Arm9loaderhax with Luma3DS, which is the best setup to have right now. You can stay on 6.0.0 and still set everything up from there. Meet me on Discord : 3
     
  17. whitesoulbk

    Newcomer whitesoulbk Newbie

    Joined:
    Saturday
    Messages:
    1
    Country:
    Bolivia
    I'm new in this forum, please can you help me to update from rxtool to Arm9loaderhax?
     
  18. MattKimura
    OP

    Member MattKimura 3DS & WiiU Enthusiast

    Joined:
    Jun 30, 2014
    Messages:
    1,617
    Country:
    United States
    This thread is very outdated, Arm9loaderhax is no more. You have to setup Boot9strap now which is even easier. go to 3ds.guide and follow it
     
    whitesoulbk likes this.
  19. SoslanVanWieren

    Member SoslanVanWieren GBAtemp Fan

    Joined:
    Feb 6, 2017
    Messages:
    311
    Country:
    Australia
    How do i install rxtools just installed sighax and it sucks
     
  20. GerbilSoft

    Member GerbilSoft GBAtemp Advanced Maniac

    Joined:
    Mar 8, 2012
    Messages:
    1,673
    Country:
    United States
    Please clarify, how does it "suck"?
     

Share This Page