I can install IOS in vWii! But...

Discussion in 'Wii U - Hacking & Homebrew' started by damysteryman, Dec 8, 2012.

Dec 8, 2012
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,445
    Location:
    Engine room, learning
    Country:
    France
    The mod by Fix94 extract the IOS from the NAND, you don't need to do it manually first.
    But in my opinion, it's a good idea to extract the IOS manually and keep a copy, they are not available on NUS and might still be required in the future. (or keep a NAND Dump)

    Wiiflow works fine as long as your HDD is compatible.
    You might need a Y cable to provide enough power, or use an external powered USB device.

    Most users reported that only IOS with base58 was working, but it could be only that some WiiU doesn't like the other bases for USB (I had this problem once with a Wii, only base58 worked).
    I think some users reported installing base56 and it worked fine.
    So, install all three available bases and test them.


    • Member

    Excelsiior New Member

    Member Since:
    Sep 13, 2009
    Message Count:
    235
    Country:
    Germany
    I'm using r53-alt with base 56 and it works (CFG USB-Loader v70 Mod r49). though you have do use the upper usb-port on the back.
    • Member

    JoostinOnline Certified Crash Test Dummy

    Member Since:
    Apr 2, 2011
    Message Count:
    9,316
    Location:
    The Twilight Zone
    Country:
    United States
    damysteryman, do you plan to release the changes I gave you?
    • Member

    damysteryman I am too busy IRL these days...

    Member Since:
    Oct 4, 2007
    Message Count:
    1,177
    Country:
    Antarctica
    First post updated with new version of my patches, now no more error -1017 when trying to install hidden channels. Thanks to FIX94 for bringing this issue to my attention.

    Enjoy!

    EDIT:
    @JoostinOnline, just did :P
    Been busy IRL so could not do so until now. Thanks for those changes man.

    EDIT2:
    Should I bother updating IOS236 installer to apply these new patches to IOS236?
    Or should I not bother?
    Does anyone even need IOS236 anymore?
    What with more AHBPROT on-the-fly patching apps being available now and all... but then again those apps (mainly wad installers) would need updating with these patches too...
    Last edited by damysteryman, Jan 2, 2013
    JoostinOnline likes this.
    • Member

    Excelsiior New Member

    Member Since:
    Sep 13, 2009
    Message Count:
    235
    Country:
    Germany
    ATD also doesn't support HW_ABHPROT or BlueDump.

    I'm doing some tests and could provide updated versions of FS-T/IOS236 Installer/YAWMM DE, if desired.
    [Truth] likes this.
    • Member

    bezem New Member

    Member Since:
    Dec 15, 2012
    Message Count:
    211
    Country:
    United States
    I was still using IOS236 for MultiModManager WAD installation, for Wii Settings Editor GUI to turn WiiConnect24 on, and for Dop-Mii to install the News Channel, Forecast Channel, etc. I haven't even started playing with, nor did I intend to use, d2X, as USB loading is not a goal of mine (from the Wii U at least). I wouldn't mind an updated IOS 236 installer just to make sure my vWii IOS 236 has the latest patches unless d2x has uses other than USB loading.
    Last edited by bezem, Jan 2, 2013
    JoostinOnline likes this.
    • Member

    Excelsiior New Member

    Member Since:
    Sep 13, 2009
    Message Count:
    235
    Country:
    Germany
    OK, made some updates:

    libruntimeiospatch 1.3: http://downloads.nanolx.org/WHB/libruntimeiospatch-1.3.tar.bz2
    Code:
    1.3: thanks to [U]JoostinOnline/damysteryman[/U]
    * replaced HAVE_ABHPROT by AHBPROT_DISABLED (now public)
    * removed (now) redundant have_ahbprot()
    * store version in #LIB_RUNTIMEIOSPATCH_VERSION
    * removed (now) redundant get_libruntimeiospatch_version()
    * minor code clean-ups
    * changed some unsigned ints to signed
    * added license header to runtimeiospatch.[ch]
    * new vWii patches by damysteryman (fixes installation of hidden channels)
    * updated API
    FS-Toolbox 0.4d: http://downloads.nanolx.org/FS-Toolbox-0.4d.tar.bz2
    Code:
    0.4c: changed several strings, minor fixups
    0.4d: linked against libruntimeiospatch 1.3
    reload into IOS 36 before HW_ABHPROT patching (fixes error -1029 on startup)
    YAWMM DE 0.5e: http://downloads.nanolx.org/YAWMM_DE-rev5e.tar.bz2
    Code:
    linked against libruntimeiospatch 1.3
    JoostinOnline and [Truth] like this.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,445
    Location:
    Engine room, learning
    Country:
    France
    Thank you for these updates.

    I think updating IOS236 installer could be good to use homebrew still using IOS236 and not updated to use AHBPROT (as d2x doesn't have a base36/38, some manager required base36/38. not that there's no alternative, but it's nice to have choice), and just to have the installer with latest patches.


    Could you tell me what was the change log of YAWMM 5c and 5d?
    I didn't find were you posted 5c link (and didn't know there were a 5d. Edit: ok there's no 5d)

    I'm making a list of all vWii related files, to make a post with all of them on the same place.


    Edit:
    Is there a chance to get this manager updated with AHBPROT for Wii/vWii?
    (I like the libWiiGui look)
    Thank you in advance if you can update it too :)

    Edit2 : sources of 1.5v2 in case they are not in the link above
    • Member

    damysteryman I am too busy IRL these days...

    Member Since:
    Oct 4, 2007
    Message Count:
    1,177
    Country:
    Antarctica
    Ok, I went ahead and updated IOS236 installer to v7, with v3 of my patches.

    Also, in its iospatch.c, I have added another on-the-fly IOS patch I made a short while back that actually fixes error -1029 when installing wads (no need to use IOS base 36 or 38 anymore, 58 works fine for pretty much everything now, only downside is that you cannot install wads that use korean common key, but nobody really seems to install any of those anyway).

    Enjoy!

    As for updating that wad manager gui app, I cannot even get it to compile. It seems to be based on and out-of-date devkit, which still uses diropen, dirnext, and dir close, but recent versions of the devkit use opendir, readdir, and closedir. I do not have the knowledge to be able to update these to make it work I am afraid...
    bezem likes this.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,445
    Location:
    Engine room, learning
    Country:
    France
    Too bad, but thanks for taking a look into it :)
    • Member

    madri1 New Member

    Member Since:
    Feb 15, 2006
    Message Count:
    127
    Country:
    France
    why not use pimp my wii 3.00 which can install wad and prevent the installation of vwii ios on wii and vice versa
    • Member

    bezem New Member

    Member Since:
    Dec 15, 2012
    Message Count:
    211
    Country:
    United States
    Does Pimp my Wii support the installation of channels from NUS? I like how Dop-Mii has the option to download channels from the Wii Shop, but it is no longer updated and not all channels are available. For example, I'm a dork who wants my WiiMode menu to look exactly like my former Wii menu (I got the News Channel to work for example). I installed the Nintendo Channel but I am unsure if I have the latest Wad (pretty sure I do but also pretty sure I can't say from where I got it) as it would go through the initial setup but ultimately not connect (Error code points to Nintendo Channel outage even though I know Nintendo Channel works). I also installed the Netflix channel but it was not the latest version, and the Wii Shop Channel on Wii U does not have these channels so I can't just download them as normal. Again, I know it's silly since the Nintendo Channel is just ads and the Netflix Channel is superseded by the Wii U application, but I'm a dork :)
    • Global Moderator

    FIX94 Global Moderator

    Member Since:
    Dec 3, 2009
    Message Count:
    5,329
    Location:
    ???
    Country:
    Germany
    That doesnt work with a normal wii IOS58, there error -1029 still comes up if the ticket byte 0x1f1 is not set to 0x00.
    • Member

    SifJar Not a pirate

    Member Since:
    Apr 4, 2009
    Message Count:
    6,022
    Country:
    United Kingdom
    One reason that springs to mind is that Pimp My Wii is a piece of crap that should never be run on any Wii on account of the vast number of bricks it has caused, plus the fact that people who use it do so without any knowledge of what it actually does, or why they would want such things to happen, meaning much unnecessary invasive system modification.

    Another reason would be that there is no reason to install a patched IOS other than warez.
    JoostinOnline likes this.
    • Member

    madri1 New Member

    Member Since:
    Feb 15, 2006
    Message Count:
    127
    Country:
    France
    no it's not.
    Link me to people who bricked using pimp my wii to see if it's caused by pimp my wii or misuse ?
    but pimp my wii has multiple protections to prevent bricking, while other don't
    Pattonfiend67 likes this.
    • Banned

    Pattonfiend67 You're F'ng Out!

    Member Since:
    Oct 7, 2009
    Message Count:
    235
    Country:
    United States
    for sure. i have modified hundreds of wii's with pimp my wii in the past few years and have never had even one brick... ever...
    madri1 likes this.
    • Member

    JoostinOnline Certified Crash Test Dummy

    Member Since:
    Apr 2, 2011
    Message Count:
    9,316
    Location:
    The Twilight Zone
    Country:
    United States
    I agree with everything except that last statement. I'm sick of people (you included) acting like 202 is for warez. It's for media players only. Most stuff uses IOS58 now instead, but 202 works better with my HDD.

    @madri1 Just do a google search. It's been nicknamed BrickMyWii for a reason.
    • Newcomer

    nitrate New Member

    Member Since:
    Dec 10, 2012
    Message Count:
    24
    Country:
    United States
    @ damysteryman: I STILL get "Could not identify ES module" error followed by "IOS236 installation failed" when trying to install your latest (v7) patched IOS36 into slot 236.

    You didn't even respond to one of my previous posts related to file size differences of dumped IOS36 WAD files.

    Some other people also mentioned that they had the same or similar issues.

    There has to be more investigation on this case IMO.
    • Member

    SifJar Not a pirate

    Member Since:
    Apr 4, 2009
    Message Count:
    6,022
    Country:
    United Kingdom
    I have never said 202 is for warez, all I have to say about it is that it is redundant. You are the only person I have ever heard say it works better that IOS58 with any hard drive. If that is the case for your drive, you are the exception, not the rule.
    Pattonfiend67 likes this.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,445
    Location:
    Engine room, learning
    Country:
    France
    202 (base38/60) is faster than 58.
    That's why there are mod of WiiSX to use 202 instead of the default IOS58.

    But I don't know about HDD compatibility with 202, to my knowledge and my own tests 58 has better compatibility than patched IOS.
    I didn't test a lot of devices, but on a particular Wii, only IOS58 worked with USB HDD.

SPONSORED LINKS
 

Share This Page