SWITCH NOOB PARADISE - Ask questions here

Discussion in 'Switch - Hacking & Homebrew' started by epickid37, Nov 1, 2017.

  1. Uumas

    Uumas GBAtemp Maniac

    Member
    1,233
    414
    Sep 17, 2016
    Finland
    I think reswitched
     
  2. Skeet1983

    Skeet1983 GBAtemp Addict

    Member
    2,770
    188
    Apr 22, 2012
    United States
    Somewhere, out there...
    Hi guys. I have a Switch, but Firmware is already past 3.0. It keeps asking me to update. Question is, should I update? I keep hoping hacks will be released for Firmware past 3.0. Thoughts appreciated :)
     
  3. PossiblyOne

    PossiblyOne the asexual

    Member
    101
    98
    Oct 28, 2017
    United States
    Hell
    Exploits for firmwares past 3.0.0 will take a long time to come out.
    The decision is really up to you.
     
  4. Yanda

    Yanda Advanced Member

    Newcomer
    84
    15
    Aug 26, 2015
    Lower is better. Anytime, anywhere.
    It's hard-and-fast rule.
     
    PossiblyOne likes this.
  5. xdaneo

    xdaneo Newbie

    Newcomer
    1
    0
    Oct 18, 2017
    United States
    Hello guys. I have a switch on 2.3 and another one on 4.0.2 . So I've bought Pokken and put it in the 4.0.2 to play a bunch. It prompted me to update the game on the 4.0.2 console, so I did.
    Is it now safe to put the cartridge into the 2.3 thus wanting to update to 3.0.0? Coz I think I've read here that you can't write anything to the carts... Just wanted to make sure.
     
  6. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,973
    3,256
    Oct 26, 2014
    Vanuatu
    Its fine, you cannot write to the carts.
     
    xdaneo likes this.
  7. Airu_Rivierre

    Airu_Rivierre Newbie

    Newcomer
    6
    1
    Nov 17, 2017
    Malaysia
    I haven't dabbled with anything online yet, do I need to update my firmware if I want to get a digital copy (via code?) of a game?
     
  8. Uumas

    Uumas GBAtemp Maniac

    Member
    1,233
    414
    Sep 17, 2016
    Finland
    Yes.
     
    Airu_Rivierre likes this.
  9. europat

    europat Advanced Member

    Newcomer
    51
    62
    Feb 28, 2015
    Canada
    Do you think the Switch hardware right now is like a pre-version of a future VR edition in HD for when Metroid Prime 4 will goes out , the slide on each side of the screens, the controls in each hand , etc... I feel like they'll want us to buy an updated version in a not so long time, in 3DS ways
     
  10. epickid37
    OP

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    594
    504
    Jan 4, 2017
    United States
    why would i tell you stalkers where i live?
    The current switch has a "VR mode" already. The 3ds took 3 years for an updated version to come out, plus it's Nintendo's portable console. I doubt they would make an updated switch, at least for another 2-3 years
     
  11. RitchieRitchie

    RitchieRitchie GBAtemp Advanced Fan

    Member
    640
    81
    Nov 15, 2013
    I'm aware that this has been asked many times before so apologies if this is a stupid question but is it better to have a 3.00fw or 2.3 for future homebrew?
     
  12. epickid37
    OP

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    594
    504
    Jan 4, 2017
    United States
    why would i tell you stalkers where i live?
    Don't worry! There are no stupid questions here. You definitely want 3.0.0 for homebrew
     
    RitchieRitchie likes this.
  13. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,973
    3,256
    Oct 26, 2014
    Vanuatu
    Lower the better, you can update to a particular firmware later down the line if you need too. You can always go up but not down when it comes to firmware versions.
     
  14. RitchieRitchie

    RitchieRitchie GBAtemp Advanced Fan

    Member
    640
    81
    Nov 15, 2013
    Thanks!

    — Posts automatically merged - Please don't double post! —

    Oh, so you think 2.3 is better?
     
  15. epickid37
    OP

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    594
    504
    Jan 4, 2017
    United States
    why would i tell you stalkers where i live?
    Currently there is homebrew on 3.0.0, but not on lower or higher versions. I would cart update to 3.0.0 if you want homebrew now. (It's only hello world scripts right now though)
     
  16. RitchieRitchie

    RitchieRitchie GBAtemp Advanced Fan

    Member
    640
    81
    Nov 15, 2013
    I've got the option of either a switch on 2.3 or one 3, just trying to work out which one is better to buy.
     
  17. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,973
    3,256
    Oct 26, 2014
    Vanuatu
    If you can afford to buy a game with the 3.0 firmware update on to use IF you need it then go for the 2.3, if you cant afford to buy a game to update later on then play it safe and buy the 3.0.
     
    RitchieRitchie likes this.
  18. FenixElite

    FenixElite Newbie

    Newcomer
    1
    0
    Dec 3, 2017
    Canada
    I'm looking to see if my understanding of the process so far is solid. So a browser exploit was found to be present on the switch, which was worked into a method for homebrew utilities, and those utilities will be used going forward to examine the device for vulnerabilities? Ultimately what we hope for is an unfixable, kernel level exploit which can be used for access, correct? I'm interested to learn more about the process.
     
  19. South Cape

    South Cape Member

    Newcomer
    14
    5
    Jun 27, 2010
    Japan
    Can anyone approximate how long a cart update takes? I don't really want to buy Pokken just to update, and since I live in Japan, clerks are really obliging, so I might legitimately just be able to to walk into a store and ask to "try the game" just for the update as long as it doesn't take over five minutes or something.

    EDIT: I went ahead and did exactly this. Just asked the clerk for the card, put it in, updated to 3.0.0 (which takes like 30 seconds or something) and then gave her the card back. Major success!
     
    Last edited by South Cape, Dec 4, 2017
  20. Repairedbee82

    Repairedbee82 Member

    Newcomer
    11
    0
    Oct 26, 2017
    United States
    Since, I haven't update my switch for awhile, how am I able to view my current version when the switch only shows "Update to latest" instead of firmware numbers.