Hacking Yooka-Laylee and the Impossible Lair - Atmosphere 14.4

mrdude

Well-Known Member
OP
Member
Joined
Dec 11, 2015
Messages
1,229
Trophies
1
Age
53
XP
3,459
Country
Using latest Firmware in emunand (10.2.0), in SXOS - Yooka-Laylee and the Impossible Lair is working fine with no issues, so no data/game corruption. When switching to Atmosphere 14.4 - this game fails to launch and gives an error - (other games and homebrew are working fine). Is anyone else having issues with this game on the latest Atmosphere NX?
 
  • Like
Reactions: peteruk

hippy dave

BBMB
Member
Joined
Apr 30, 2012
Messages
7,228
Trophies
1
XP
8,749
Country
United Kingdom
Using latest Firmware in emunand (10.2.0), in SXOS - Yooka-Laylee and the Impossible Lair is working fine with no issues, so no data/game corruption. When switching to Atmosphere 14.4 - this game fails to launch and gives an error - (other games and homebrew are working fine). Is anyone else having issues with this game on the latest Atmosphere NX?
A lot of the time, games installed with SX OS don't run on atmosphere. I don't remember the details of why, or if it's only when the installer built in to SX OS's album was used (notoriously broken installer). Anyway just reinstall the game (try Awoo installer, it's solid).
 
  • Like
Reactions: mrdude

mrdude

Well-Known Member
OP
Member
Joined
Dec 11, 2015
Messages
1,229
Trophies
1
Age
53
XP
3,459
Country
Ok thanks for letting me know. It's weird though as all my other games work just fine. If I install a NSP with SXOS it works fine in Atmos, however if you install XCI with SXOS it doesn't work in Atmos - maybe I installed a XCI (I can't remember).
 

jajamundo

Well-Known Member
Member
Joined
Aug 28, 2009
Messages
318
Trophies
0
XP
1,638
Country
United States
Ok thanks for letting me know. It's weird though as all my other games work just fine. If I install a NSP with SXOS it works fine in Atmos, however if you install XCI with SXOS it doesn't work in Atmos - maybe I installed a XCI (I can't remember).

The problem is because atmoshphere can't run XCI. If you installed a XCI game it never gonna works on Athmosphere

The installer is not broken, is just because Athmosphere doenst play XCI files

Just install again the game as a NSP and it gonna work fine in both CFW
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
16,637
Trophies
1
Age
27
Location
New York City
XP
11,218
Country
United States
The problem is because atmoshphere can't run XCI. If you installed a XCI game it never gonna works on Athmosphere

The installer is not broken, is just because Athmosphere doenst play XCI files

Just install again the game as a NSP and it gonna work fine in both CFW
That's not entirely true. You can install .XCI files with Atmosphere just fine. I and many members have installed plenty of .XCI files with other title installers without issues. The real issue here is the installer with SX OS applies an additional patch that only SX OS makes use of.
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
21,334
Trophies
3
Location
Space
XP
10,206
Country
Norway
The problem is because atmoshphere can't run XCI. If you installed a XCI game it never gonna works on Athmosphere

The installer is not broken, is just because Athmosphere doenst play XCI files

Just install again the game as a NSP and it gonna work fine in both CFW
Installing a XCI converts it on the fly to NSP. Installing a XCI is completely different from mounting it.
 
General chit-chat
Help Users
    KennieDaMeanie @ KennieDaMeanie: https://youtube.com/shorts/N6ZiG1c80q4?feature=share