Yet Another Noob Question: Wii U USB Helper to Haxchi/Mocha CFW to WUP woes

Discussion in 'Wii U - Hacking & Backup Loaders' started by JustWantsToPlayGames, Oct 15, 2017.

  1. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    OK so I decided to check out the Wii U USB helper app. It's pretty cool. I downloaded a few games and copied them to my SD card using the app.

    Next step I installed Mocha CFW (previously only used emulators so I didn't have a need for it) and WUP Installer. I also formatted an 8GB USB drive with the Wii U. So (after some trial and error), I opened Mocha CFW, and then I reopened Haxchi, and then I opened WUP Installer. After attempting to install Advance Wars, it would get to 100% but then say that there was an error and no USB storage was attached. I dried D&D Chronicles of Mystara and it gave me an "Exception type DSI occurred!" error with a bunch of hex code below it. This also froze my system, forcing me to hard reset it.

    I have a feeling I skipped a step or did something wrong. I was wondering if anyone might be able to help me again? Thank you so much in advance!

    Edit: I forgot to mention that I am trying to install to USB. Someone in a video somewhere said not to install to NAND or else it could jack up my Wii U.
     
    Last edited by JustWantsToPlayGames, Oct 15, 2017
  2. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    you don't need to use mocha if you have haxchi. try that.
     
    JustWantsToPlayGames likes this.
  3. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    I tried without Mocha by accessing WUP through Haxchi and it didn't even give me a progress bar. It said something along the lines of needing a proper signature. Thank you for replying!
     
  4. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    try redownloading. improper signature? never heard of that error before.
     
    JustWantsToPlayGames likes this.
  5. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    OK I'll give it another shot. To be clear, you're saying that having Haxchi installed and accessing WUP thru Haxchi should do the trick? There's no separate 'Haxchi CFW' I need to download and install?
     
  6. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    you are correct. if haxchi is installed, you just need to open that, then use wup installer. are you using sig patches? config.txt - default=sysMenu ?
     
    JustWantsToPlayGames likes this.
  7. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    OK so it doesn't actually say 'improper signature' but it does say Sig Patch is required. No clue what that is. Googling now. Thank you so much!
     
  8. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    sig patches is what haxchi does. I don't know if it does this when loading the homebrew channel though which is the default method with haxchi. you should create a config.txt and use that default=sysMenu for one, then the homebrew channel with say the A button. so have it say: a=location of homebrew launcher.elf . then, try using wup installer by opening haxchi with no button presses, then opening haxchi by holding the b or the a button. I'm not sure if this is necessary, but it's worth a shot.
     
    Last edited by godreborn, Oct 15, 2017
    JustWantsToPlayGames likes this.
  9. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    Thank you again for trying to work with me through this. Does it matter that I'm not using CBHC? I always open Haxchi from the main Wii U menu using the touch screen. Also, in the config.txt (which I'm assuming will go in Haxchi's root folder on the SD card?), I should set the .elf to a or b, and then open Haxchi from touch screen, open wup from haxchi homebrew launcher with touch screen, then re-open haxchi with the assigned button?
     
  10. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    you are correct about placing the config.txt in the haxchi folder, then reinstalling haxchi. you're close. open up haxchi, don't push any buttons, and it should send you back to the home menu with sig patches. then, open up haxchi, hold the a or b button depending on what you put in the config.txt to open the homebrew launcher.elf . I don't know if this will work, but since you're have sig issues, it might.
     
    JustWantsToPlayGames likes this.
  11. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    Bummer so far. So at first I didn't know that I was supposed to reinstall Haxchi after editing the config.txt file. I set b to the .elf, and default to sysMenu. I then ran the Haxchi installer again form the HBL. After the reinstall, Haxchi still defaults to HBL (and WUP still has the sig patch issue). Does this have anything to do with me not re-downloading Brain Age before doing the reinstall?
     
  12. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    not sure why that happened. downloading brain age again shouldn't matter as long as you run haxchi with the config.txt in the haxchi folder.

    what does your conifg.txt look like? maybe that's the problem.
     
    JustWantsToPlayGames likes this.
  13. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    Sorry I took so long. Had to walk the dog. The config.txt looks like this:

    a=fw.img
    b=wiiu/apps/homebrew_launcher/homebrew_launcher.elf
    default=sysMenu

    b & default were originally switched.

    Edit: This config file is in the Haxchi folder which is in the root folder of the SD card. There's another Haxchi folder in /apps/ that does not have the config file.
     
    Last edited by JustWantsToPlayGames, Oct 15, 2017
  14. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    you may need to wait for @Kafluke . he's the one who wrote the main wii u tutorial. you only need the config.txt in the haxchi folder on the root of the sd card. that looks right though.
     
    JustWantsToPlayGames likes this.
  15. JustWantsToPlayGames
    OP

    JustWantsToPlayGames Member

    Newcomer
    1
    Jul 23, 2017
    United States
    Thank you for all of your guidance and help. Good news! It now works. After some more Googling I found that sysmenu is case sensitive, and thus should not have a capital 'M' for 'menu'. I was expecting some form of actual menu to pop up, but instead Haxchi would load and boot me back to the Wii U Menu. I didn't understand that sysmenu is the actual software working in the background, and not an actual menu (aside from being able to press a or b for 'menu' options). So I tried again, held B, and it took me to HBL where I opened WUP and BOOYAKASHA! Advance Wars. Thank you so much! I really do appreciate you taking the time out of your day/night to help me with this.
     
    godreborn and Kafluke like this.
  16. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
    Just saw this. Was gonna tell you you had a capital M. Glad you got it worked out
     
    JustWantsToPlayGames likes this.
  17. godreborn

    godreborn GBAtemp Guru

    Member
    11
    Oct 10, 2009
    United States
    hmm. I was unaware that sysmenu had to written like that. I've always seen it with a capital M. I guess those users were wrong as well.

    edit: I should've prefaced this by saying that I don't use default=sysmenu. I was using the fw.img before switching to cbhc.
     
    Last edited by godreborn, Oct 15, 2017
Loading...