Hacking Question Yellow screen from EmuMMC boot after atmosphere update

Regained

Active Member
OP
Newcomer
Joined
May 21, 2017
Messages
42
Trophies
0
Age
66
XP
133
Country
Armenia
I'm on version 9.2 firmware and wanted to update to 10.2 on emummc so i put on the latest atmosphere. When i get to Hekate and chose emummc, its giving me a yellow screen. I updated my rcmloader then with the latest fusee primary, and it boots all the way without a Hekate menu.

When i chose Reboot to payload, it takes me to Hekate, but when i select emummc, i get the yellow screen again.

Did atmosphere break my emummc partition? how do i fix this? thanks
 
  • Like
Reactions: HollowGrams

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
21,331
Trophies
3
Location
Space
XP
10,191
Country
Norway
I'm on version 9.2 firmware and wanted to update to 10.2 on emummc so i put on the latest atmosphere. When i get to Hekate and chose emummc, its giving me a yellow screen. I updated my rcmloader then with the latest fusee primary, and it boots all the way without a Hekate menu.

When i chose Reboot to payload, it takes me to Hekate, but when i select emummc, i get the yellow screen again.

Did atmosphere break my emummc partition? how do i fix this? thanks
You need to update Hekate. You should always update Hekate at the same time as updating Atmosphere and sig patches.
Also, you probably have Hekate set to replace reboot_payload.bin automatically. Please stick with either Hekate or fusee-primary as your reboot_payload.bin and dongle payload, don't mix and match as that will only lead to confusion.
 
Last edited by The Real Jdbye,

Regained

Active Member
OP
Newcomer
Joined
May 21, 2017
Messages
42
Trophies
0
Age
66
XP
133
Country
Armenia
You need to update Hekate. You should always update Hekate at the same time as updating Atmosphere and sig patches.
Also, you probably have Hekate set to replace reboot_payload.bin automatically. Please stick with either Hekate or fusee-primary as your reboot_payload.bin and dongle payload, don't mix and match as that will only lead to confusion.

I've update to the latest Hekate and it still yellow screens. The update procedure is to copy over a new bootloader folder, and put in the fusee-primary.bin into payloads? The ini file for the old version was in bootloader, and now there's a new INI folder, do I copy the old ini file into INI?

my old config

[config]
autoboot=0
autoboot_list=0
bootwait=0
backlight=100
autohosoff=0
autonogc=1
updater2p=1

[CFW - sysMMC]
fss0=atmosphere/fusee-secondary.bin
kip1patch=nosigchk
atmosphere=1
emummc_force_disable=1
icon=bootloader/res/icon_payload.bmp

[CFW - emuMMC]
fss0=atmosphere/fusee-secondary.bin
kip1patch=nosigchk
emummcforce=1
atmosphere=1
icon=bootloader/res/icon_payload.bmp

[Stock - sysMMC]
fss0=atmosphere/fusee-secondary.bin
emummc_force_disable=1
stock=1
icon=bootloader/res/icon_switch.bmp
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
21,331
Trophies
3
Location
Space
XP
10,191
Country
Norway
I've update to the latest Hekate and it still yellow screens. The update procedure is to copy over a new bootloader folder, and put in the fusee-primary.bin into payloads? The ini file for the old version was in bootloader, and now there's a new INI folder, do I copy the old ini file into INI?

my old config

[config]
autoboot=0
autoboot_list=0
bootwait=0
backlight=100
autohosoff=0
autonogc=1
updater2p=1

[CFW - sysMMC]
fss0=atmosphere/fusee-secondary.bin
kip1patch=nosigchk
atmosphere=1
emummc_force_disable=1
icon=bootloader/res/icon_payload.bmp

[CFW - emuMMC]
fss0=atmosphere/fusee-secondary.bin
kip1patch=nosigchk
emummcforce=1
atmosphere=1
icon=bootloader/res/icon_payload.bmp

[Stock - sysMMC]
fss0=atmosphere/fusee-secondary.bin
emummc_force_disable=1
stock=1
icon=bootloader/res/icon_switch.bmp
You shouldn't replace hekate_ipl.ini as that will wipe your CFW boot entries. But if you want to boot fusee-primary directly with the dongle you should also disable updater2p and if you want to chainload from Hekate, you should replace the payload on your dongle with the Hekate one and leave updater2p enabled.
 

Regained

Active Member
OP
Newcomer
Joined
May 21, 2017
Messages
42
Trophies
0
Age
66
XP
133
Country
Armenia
You shouldn't replace hekate_ipl.ini as that will wipe your CFW boot entries. But if you want to boot fusee-primary directly with the dongle you should also disable updater2p and if you want to chainload from Hekate, you should replace the payload on your dongle with the Hekate one and leave updater2p enabled.
Wow, thats alot of things i dont really know about.
Is updater2p a menu option in Hekate?
I dont know the difference between fusee-primary and secondary.
what is chainloading?
where is the hekate payload for the dongle?

thanks. its alot i know
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
16,613
Trophies
1
Age
27
Location
New York City
XP
11,204
Country
United States
Wow, thats alot of things i dont really know about.
Is updater2p a menu option in Hekate?
I dont know the difference between fusee-primary and secondary.
what is chainloading?
where is the hekate payload for the dongle?

thanks. its alot i know
Updater2p is a line in the hekate_ipl.ini file. The difference between fusee_primary and fusee_secondary is that fusee_primary is, as the name implies, the primary payload. It then automatically chainloads into fusee_secondary if it is on your SD card. Chainloading is the action of using a different payload than the one you originally launched. The hekate payload for your dongle will depend on what type of dongle you are using.
 

thehenryswanson

New Member
Newbie
Joined
Oct 10, 2021
Messages
1
Trophies
0
Age
36
XP
27
Country
United States
I had the same issue. What I did was create a new emuMMC. I was then able to boot without getting the yellow screen. The only thing was that my games were missing so I copied and replaced the Nintendo folder from the original emuMMC into the new and everything is back working correctly.
 
Last edited by thehenryswanson,

HollowGrams

Well-Known Member
Member
Joined
Nov 27, 2020
Messages
628
Trophies
0
Age
41
XP
637
Country
United States
I'm on version 9.2 firmware and wanted to update to 10.2 on emummc so i put on the latest atmosphere. When i get to Hekate and chose emummc, its giving me a yellow screen. I updated my rcmloader then with the latest fusee primary, and it boots all the way without a Hekate menu.

When i chose Reboot to payload, it takes me to Hekate, but when i select emummc, i get the yellow screen again.

Did atmosphere break my emummc partition? how do i fix this? thanks
Notice about Atmosphere 1.0.0 and up: The fss0=atmosphere/fusee-secondary.bin in hekate_ipl.ini must be changed to fss0=atmosphere/package3
 
General chit-chat
Help Users
    Progamertherealone @ Progamertherealone: ask google