Would we need new CycloDS's exclusive for the DSi?

Discussion in 'CycloDS' started by Link5084, Nov 20, 2008.

Nov 20, 2008
  1. Link5084
    OP

    Member Link5084 Sword & Shield at your service

    Joined:
    Aug 6, 2008
    Messages:
    1,367
    Country:
    United States
    With the recent good news that Cyclo working on the DSi is becoming a reality, would we need new CycloDS's that will work with the DSi? If so, will you buy one?
     
  2. unz

    Member unz Chaotic Neutral

    Joined:
    Jul 14, 2008
    Messages:
    283
    Location:
    Curmudgeon's quarters
    Country:
    Australia
    Speculation tiem!! [​IMG]

    Keeping in mind that at this stage, any flashcart running on a DSi is purely experimental, let's think this thing through to its logical conclusion...

    Flashcarts currently available to the public are not compatible with the DSi. This is common knowledge to anyone with the slightest interest in the flashcart/homebrew scene.

    The hardware in the DSi is quite different to the older DS models. Also, there's those new "security measures" Nintendo have added. Obviously, it's going to take more than a flashcart software update to achieve compatibility with the new hardware.

    So yes, I think new improved flashcart versions will be needed to boot homebrew and/or backups on a DSi.
    Perhaps the new models will be compatible with DS Phats and Lites - that would allow flashcart manufacturers to keep production costs down. But cartridge space constraints could make that difficult.

    But (and this is the real question at this point in time), if anyone succeeds in getting the DSi's SD card to boot/run code, the flashcart discussion will be moot.

    Will I be buying a DSi and a new Cyclo DS to go with it? Only if my current Lite implodes - and due to some unforseen apocalyptic circumstances, I can't buy another Lite to replace it in (at least) the next 12 months...
     
  3. hyun

    Member hyun GBAtemp Regular

    Joined:
    Apr 8, 2008
    Messages:
    298
    Country:
    United States
    My opinion,
    I think they will make a kernel that will make Cyclo DS to run games on Dsi.
    I really don't think you have to buy a new one O.o
     
  4. snaai8

    Newcomer snaai8 Advanced Member

    Joined:
    Mar 15, 2008
    Messages:
    54
    Country:
    Netherlands
    yeah they will make a new firmware but even if they sucseed in making the firmware (it looks promosing to me now)
    there will be an update from nintendo that fixes the flashcard problem and they can start over again.
    maybe we need something that cleans the update so it will run with the cyclo even patched !!!!!
     
  5. Mod Chip Monster

    Newcomer Mod Chip Monster Member

    Joined:
    Nov 26, 2008
    Messages:
    13
    Location:
    Adelaide, Australia
    Country:
    Australia
    I have a feeling the DSi's SD slot will cause a custom firmware battle with the Homebrew community and Nintendo to constantly update and patch exploits like we have seen happen to the PSP. However this is purely speculation.
     

Share This Page