Will the DSTWO with 1.4.2 work on a 1.4.3 DSi XL?

Discussion in 'NDS - Flashcarts and Accessories' started by sofakng, Dec 12, 2011.

  1. sofakng
    OP

    Newcomer sofakng Advanced Member

    Joined:
    Jul 3, 2007
    Messages:
    75
    Country:
    United States
    This might seem like a silly question, but I'm using an Acekard 2i with my DSi XL (v1.4.3 firmware).

    However, I'm thinking about "upgrading" to a DSTWO mostly for the real-time save features. (I was also upset with my Acekard 2i constantly freezing but sticking a piece of paper behind the cart seemed to have fixed it; kinda a weird solution though)

    Anyways - RealHotStuff.com is selling DSTWO's pre-upgraded to support DSi 1.4.2, but I'm using 1.4.3. Will I be able to use this cart or am I basically screwed? (I don't have any other DS's in the house...)
     
  2. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Unlike most carts the DSTwo can update itself without having to run as long as it's base firmware is above a certain version (and the 1.4.2 one should be fine, somebody correct me if I'm wrong), since it can read and apply the update on itself due to it's special CPU and all that jazz.
     

Share This Page