Hacking Will Smash Bros update screw up HBC/backup launcher 0.3 gamma?

Yablan

New Member
OP
Newbie
Joined
Aug 4, 2007
Messages
4
Trophies
0
XP
51
Country
Hi there.
I have a question. Sorry if it already has been answered.

I have a softmodded (TP hack) PAL WII, with HBC and Backup launcher 0.3 gamma.
The Wii system menu says my Wi has version 3.3c, but when I installed Backup Launcher, the installer did the CIOS update thing. So I believe the WII actually has some 3.4 stuff in it, am I right?

Anyway, I want to buy Super Smash Bros, but am worried if the update will screw up my Wii.

First of all, will Super Smash Bros even update if the system is on 3.3c at all?

And if it does, will the update screw up any of:
* my HBC channel
* WAD install capabilities (thru HBC/WAD Manager)
* Backup Launcher Gamma?

And will I be able to play Super Smash Bros online? That's not really a high priority for me. But I'd like to know.

Thanks in advance
/Yablan
 

SJ2K9

Member
Newcomer
Joined
Nov 2, 2008
Messages
16
Trophies
0
XP
62
Country
Yablan said:
Hi there.
Anyway, I want to buy Super Smash Bros, but am worried if the update will screw up my Wii.
First of all, will Super Smash Bros even update if the system is on 3.3c at all?

Answer: No

QUOTE said:
And if it does, will the update screw up any of:
* my HBC channel
* WAD install capabilities (thru HBC/WAD Manager)
* Backup Launcher Gamma?

Answer: Doesnt apply as it shouldnt update

QUOTE
And will I be able to play Super Smash Bros online? That's not really a high priority for me. But I'd like to know.

Answer: Yup dont see why not as other games work fine via WFC with BUL/HBC etc installed

HTH
 

WiiPower

Well-Known Member
Member
Joined
Oct 17, 2008
Messages
8,165
Trophies
0
XP
320
Country
Gambia, The
The "cIOS thing" is based on IOS36v1042, that's 1 IOS from 3.2, so it has nothing to do with 3.4 at all. It doesn't even overwrite something.

If you run your games from a loader like Gamma or SoftChip you don't have to worry about updates. If you want to use the rebooter from Gamma, you need some kind of update prevention, but the rebooter is only needed for 2 games now.(Sam & Max Season 1 and Far Cry)
 

Leeuwtje

Well-Known Member
Newcomer
Joined
Nov 16, 2008
Messages
47
Trophies
0
XP
71
Country
Netherlands
downgrade to 3.2, use tone shopinstaller for the 3.3 options and install starfall so you can protect yourself against updates on discs.
 

Yablan

New Member
OP
Newbie
Joined
Aug 4, 2007
Messages
4
Trophies
0
XP
51
Country
Thanks a lot for the quick answers so far. I have a follow-up question though.
QUOTE said:
If you run your games from a loader like Gamma or SoftChip you don't have to worry about updates. If you want to use the rebooter from Gamma, you need some kind of update prevention, but the rebooter is only needed for 2 games now.(Sam & Max Season 1 and Far Cry)
I never use the rebooter thing, I don't know how to use it. I just pop in the backup disk, klick on the backup launcher channel on my Wii menu, and then the Start button.

I however still use the standard disc channel for my originals. Are you saying that I should run my originals from the backup channel instead? Is it even possible? And if I do, won't the backup launcher read the originals at x3 speed, rather than x6 speed?
 

Yablan

New Member
OP
Newbie
Joined
Aug 4, 2007
Messages
4
Trophies
0
XP
51
Country
BTW I am at work, therefore my question. Otherwise I would of course (duh!) have tested if the backup launcher read originals myself.
 

WiiPower

Well-Known Member
Member
Joined
Oct 17, 2008
Messages
8,165
Trophies
0
XP
320
Country
Gambia, The
Oh sorry, i forgot about the originals. If you don't want updates from originals, you need starfall with the update block option enabled. Starfall requires 3.2 firmware, so you need to downgrade for this first. Updates are not installed automatically, you are always prompted to do it, so if you don't have the "push the 'do not push button' syndrome" you could just use Gecko OS to launch your originals and you would be safe without messing around with your firmware.
 

Yablan

New Member
OP
Newbie
Joined
Aug 4, 2007
Messages
4
Trophies
0
XP
51
Country
Ok. My summary/deduction from the above inputs.

* My Wii has system version 3.3c, so Super Smash Bros Brawl will NOT ask to update my Wii, as said update is for a previous version.
* I WILL be able to play online with Super Smash Bros Brawl without updating my Wii to 3.4, at least until Nintendo does something that forces this.
* If I try to play original games that require updates from the regular disc channel, the updates will not run automatically. They will ask politely.
I assume the polite question is required for legal reasons. Otherwise gamers might sue Nintendo for updating their Wiis without having asked them for permission.

Regarding updates in general terms, I could either install Starfall to prevent them (which seems like a hassle, requires downgrade) or simply run originals from the Gecko OS to bypass update questions.
In my case, it will not do none of this, and will keep using the standard disc channel for my current games, as none of them require updates.

Thanks to all of you (SJ2K9, WiiPower and Leeuwtje) who kindly replied to my questions.
 

GexX2

Lurker
Member
Joined
Oct 23, 2006
Messages
517
Trophies
0
Age
32
Location
Tennesee, US
Website
Visit site
XP
292
Country
United States
Yablan said:
I however still use the standard disc channel for my originals. Are you saying that I should run my originals from the backup channel instead? Is it even possible? And if I do, won't the backup launcher read the originals at x3 speed, rather than x6 speed?
The backup launcher runs originals at 6x. It will also block any updates.
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: They are in shape and all that lol