Will NinjHax work on an old 3DS XL with a 3.* Firmware?

Discussion in '3DS - Flashcards & Custom Firmwares' started by FirstLady, May 30, 2015.

  1. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    I'm wondering if it'll work. It's possible to downgrade F/W via Gateway website but what about upgrading to at least 4.0.0-7 for Ninjhax, possible?

    Thanks

    Ninjhax Requirements

    > A 3DS, 3DS XL or 2DS console with a firmware version between 4.0.0-7 and 9.2.0-20.
     


  2. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    What is the last one digit on your console firmware? I hope it is other than 0. Like for eg. 4.0.0-7 where the last digit is 7. If it is 0 then it means that it doesn't have browser installed which Ninjhax needs to run exploit completely. You can use a cart that has update under 9.2.0 but that won't change the last digit, and as such it won't install browser and so Ninjhax won't work (and you'll get stuck in even more trouble).

    You at least want to go for cart that has update anywhere from 4.1 to 4.5 in order to at least run MSET exploit, after which you can use MSET method of PASTACFW to update using 3DSNUS (don't know exact procedure). Updating using 3DS updater CIA on sysNAND could allow for update for eg. 9.2.0-20 to have latest "exploitable" version with browser.
     
    FirstLady likes this.
  3. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    If you have a -0 browser then you need to cart update to 4.1-4.4 then install PBT. Once you have PBT you can install BBM and use that to install sysupdater. From here you can update to 4.5-9.2 with the browser exoloit. Now you have the browser you can run cubic ninja ninjahax and load pasta cfw on 4.x-9.2
     
    FirstLady likes this.
  4. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    Thanks, I'm not sure what the last digit is, but since it is possible, I'll buy it tomorrow. Your replies have been helpful, I appreciate it. ;)
     
  5. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Just remember currently you need a cn cart for pasta cfw to work on ofw 5.0-9.2, you will also need a retail game cart to do the initial update to 4.x and a ds flash cart to make everything work.
     
    FirstLady likes this.
  6. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    I have Cubic Ninja and a dstwo. I have quite a few games, I'm sure at least one has 4.x. What Do I need the ds flash cart for though?

    Edit: I just checked. I have New Super Mario Bros 2. It has 4.1.0. Also New Art Academy.
     
    Last edited by FirstLady, May 30, 2015
  7. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Yeah 4.1 will work to get you started. Just make sure you don't have an update nag and keep wifi off when doing a cart update. Once you get to 4.1.0-x let us know what the x is to see if you have the correct browser
     
    FirstLady likes this.
  8. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    Ok thanks, will do ;)
     
  9. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    760
    185
    Mar 28, 2011
    United States
    I think the simplest solution is to forget about pasta and sysupdater and instead
    1) Use a cart to upgrade to 4.x.
    2) Use the Gateway launcher to "downgrade" from the first 4.x to the specific 4.x that Gateway installs.
    3) The specific 4.x that Gateway "downgraded" to will have a browser suitable for ninjhax.

    This method is mostly useful with a Gateway, since you'll end up on 4.x and without a Gateway, you probably want to be on 9.2 so that you are able to play the most games while keeping ninjhax (or if you use Pasta, so that you can pirate the most games while keeping ninjhax).
     
    Last edited by Jiro2, May 31, 2015
  10. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    Great, is the 4.x that Gateway downgrades to lower than 4.1. Thanks )
     
  11. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    760
    185
    Mar 28, 2011
    United States
    For USA it downgrades to 4.2.0-9. This is suitable for ninjhax.

    The point is that although it's called "downgrading", I don't think Gateway actually requires that your firmware version be going down in order to do a "downgrade", so you should be able to "downgrade" 4.1 without browser to 4.2 with browser.
     
    FirstLady likes this.
  12. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    Hi, bought and updated to 4.1 with NSMB2. My firmware is now 4.1.0-6E.

    What would be the best thing to do now? I have Cubic Ninja and a DSTWO Cart. Basically I need Ninjhax, Pasta, FBI and eventually upgrade to 9.2 for full compatibility with some of the games I'm interested in.

    Since the last digit of my fw is 6. Can I safely install Ninjhax and Pasta via official instructions?

    Thanks
     
  13. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    Hi, i checked the youtube video for downgrading and someone in the comments said it's not possible to downgrade to 4.5 from a lower fw like 4.1 via the Gateway website, so I'm uncertain what to do. Is it safe to try.? My last digit is 6, unsupported by ninjhax, the 4.1 at NH starts at 7.
     
  14. gamesquest1

    gamesquest1 Nabnut

    Member
    14,119
    9,454
    Sep 23, 2013
    easiest route would be to update to something higher, i think GW needs you to be on a minimum of 5.x to be able to use the downgrader....or if you happy to mess with sysupdater again use PBT-CFW to run that and update to a more specific FW, if you plan to go to 9.2 at some point you might as well head directly to 9.2.0-20 or whatever
     
    Last edited by gamesquest1, May 31, 2015
  15. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    Yes, I just tried gateway and it said downgrading is not supported on my console.

    So I I'll try what you suggest. Thanks )
     
  16. MattKimura

    MattKimura 3DS & WiiU Enthusiast

    Member
    1,776
    923
    Jun 30, 2014
    United States
    FirstLady likes this.
  17. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France

    I hope I'm not too late but don't do that, many people got the fatal error while trying to downgrade because they updated their console with a game. Just set up the pbt-cfw first then use sysupdater to update your console to 9.2.0-20.
     
    FirstLady likes this.
  18. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    The problem with updating to 5.x+ is you won't have a browser so no ninjahax and no gw menu.

    As I mentioned before it's best to cart update to 4.1 in OP case, use mset to get pasta, sysupdate to 4.5-9.2 and profit.

    Depending if op has a copy of cubic ninja I would suggest two different scenarios. If they do have it then update to 9.2 if not stay on 4.5
     
    FirstLady likes this.
  19. FirstLady
    OP

    FirstLady GBAtemp Regular

    Member
    166
    35
    May 25, 2015
    United States
    I'm so confused as to what to do now. I have Cubic Ninja so how do I use it if the last digit 6. Tried to get the qr code for ninjhax, but last digit starts on 7 for qr code on ninjhax website? Cheers
     
  20. 75mak

    75mak GBAtemp Fan

    Member
    389
    111
    Nov 10, 2011
    I'm on firmware 4.3.0-4e

    can't run ninjahax as get stuck on 70% - assuming I used wrong QR code

    So my question is - how can I install 4.3.0-7e - so that I can use that QR code?