Will a DStwo work on the latest update on a DSI?

Discussion in 'Supercard' started by KoopaHax35000vr, Feb 5, 2013.

  1. KoopaHax35000vr
    OP

    KoopaHax35000vr Idk

    Member
    146
    7
    Jan 24, 2013
    United States
    California
    Hi, I am thinking of getting a supercard DStwo and I was wondering will it work on the latest update on the DSI?
     
  2. GamerzHell9137

    GamerzHell9137 GBAtemp Psycho!

    Member
    3,824
    1,645
    Nov 1, 2011
    Bosnia and Herzegovina
    No.....
    The strongest and the best flashcard ever made won't run on the latest firmware of DSi.
     
  3. Nebuleon

    Nebuleon MAH BOI/GURL

    Member
    900
    465
    Dec 22, 2012
    Canada
    Sarcasm aside, yes, it will work flawlessly. I can boot Supercards on my DSi.

    Many threads warn otherwise for 3DSes however.
     
  4. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    GamerzHell9137 is being sarcastic, yes it will work.
     
  5. KoopaHax35000vr
    OP

    KoopaHax35000vr Idk

    Member
    146
    7
    Jan 24, 2013
    United States
    California
    Thx