Will 3DS Gateway work on making their flashcart support newer 3DS system firmwares?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Endrit49, Oct 24, 2014.

  1. Endrit49
    OP

    Endrit49 Advanced Member

    Newcomer
    78
    0
    Sep 16, 2010
    I don't exactly have the money to dish out for a 4.x 3DS and I've already bought some games on the eShop.

    Does 3DS Gateway plan on doing anything to support newer system firmwares?
     


  2. t-master

    t-master Member

    Newcomer
    28
    9
    Dec 22, 2013
    They said they are looking at it, however there has been no progress (at least usable for loading roms) at all for any firmware higher than 4.5 for years.
    So while there might be a slim chance that we are able to update in the next few years I wouldn't count on it.
     
  3. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    No they said they only want to support 4.x consoles.......jkn ofc if the *could* support higher FW version they would, but just because they want something doesn't mean it's technically possible, wait a indefinite about of time or buy a compatible console
     
  4. Pox

    Pox GBAtemp Regular

    Member
    146
    19
    Sep 12, 2014
    Its all just a speculation, no one can give you precise information.

    The thing is there is a lot more to be done with current FW support (4.1-4-5), save games, homebrew etc., so I DONT think they ll bother with higher FW support of sysNAND. Dont forget that even newest emuNAND gave problems in the beginning so they need to fix those "launchers" from time to time.

    In short, I dont think there will be support for newer FWs, and Nintendo wont allow it either, they are not sitting empty handed while Gateway team is working you know :) ?
     
  5. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,919
    1,211
    Aug 20, 2013
    straya m8
    Gateway team has been saying since the beginning that they are working on higher firmwares but it's been well over a year, closer to a year and a half since they burst out into the scene.

    With their resources, and I'm speculating here, teams of reverse engineers and coders, hardware such as RAM dumping rigs etc. and they haven't figured out how to get into control of the kernel yet, well I've got bad news for you, it probably won't happen for a long time. Sorry.

    Best buy yourself a 4.5 3DS and join in on the current developments!
     
  6. cearp

    cearp the ticket master

    Member
    7,484
    4,714
    May 26, 2008
    Tuvalu
    hmm, i'm surprised we have never had a thread about this.
    good question!



    ...


    ...


    :tpi:
     
  7. Searinox

    Searinox <3

    Member
    1,736
    161
    Dec 16, 2007
    Romania
    Gateway has a lot to gain by making their flashcart available on a wider range of consoles. But the 3DS is such a bitch to hack...
     
  8. dekuleon

    dekuleon GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    dekuleon is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    507
    157
    Oct 1, 2010
    Brazil
    where the wind makes the curve
    Maybe just maybe SSSpwn will help achieve this. Remember when Geohot said his ps3 jailbreak would not help piracy?
     
  9. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,919
    1,211
    Aug 20, 2013
    straya m8
    SSSpwn is user land, it can't and never will enable ROM loading by itself. There needs to be found another vulnerability to enable control of 3DS kernel mode.
     
  10. needcash

    needcash Newbie

    Newcomer
    8
    9
    Oct 20, 2014
    Bangladesh
    Yes.
     
  11. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    damn you needcash you gonna turn this into one of "those" threads......oh never mind it already was pretty much ;)

    good to hear you survived the exchange :lol:

    (obligatory "assuming its not BS" :P)
     
  12. shamzie

    shamzie Oh David de Gea <3

    Member
    782
    412
    Mar 19, 2014
    Manchester
    lol atleast you're keeping up appearances
     
  13. SSG Vegeta

    SSG Vegeta GBAtemp Fan

    Member
    436
    90
    Jul 25, 2013
    United States
    I hope Gateway supports newer firmwares cause i'm getting a NN3DS soon & won't update it till someone here finds out how to mod the new console
     
  14. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    probably be a way to get it hard modded so you can upgrade/downgrade if anything ever does happen but not be restricted to never updating in the meantime

    that's assuming the old SD reader method works and they haven't done anything else to prevent downgrades
     
  15. SSG Vegeta

    SSG Vegeta GBAtemp Fan

    Member
    436
    90
    Jul 25, 2013
    United States

    I hope it does because its been confirmed that the NN3DS uses micro sd cards & not the regular sd cards
     
  16. Steena

    Steena GBAtemp Advanced Fan

    Member
    559
    272
    Sep 13, 2009
    Italy
    You think they're making more profit by updating features for existing customers/a limited quantity systems rather than opening up the exploit to the vast majority, which is on newer firmwares?
    If they could, getting more FW compatibility would be the absolute #1 priority no matter what, there's no question about that.
     
  17. SSG Vegeta

    SSG Vegeta GBAtemp Fan

    Member
    436
    90
    Jul 25, 2013
    United States
    Not to mention more profit for them since their cart would be the only cart to support higher firmwares
     
  18. lamentofking

    lamentofking Advanced Member

    Newcomer
    59
    1
    May 14, 2009
    United States
    You all are saying that they would make more by supporting higher firmwares but is the time spent worth it though? Nintendo is releasing new firmwares that don't even affect the GW working as long as we don't update SysNand to above 4.5. For every update Nintendo releases GW would have to keep making sure their device still works. The amount of work to be done may not justify the amount of money they would make.
     
  19. shamzie

    shamzie Oh David de Gea <3

    Member
    782
    412
    Mar 19, 2014
    Manchester
    Not really, If a kernel exploit is found people just need to not be stupid enough to update past the workable firmware like they did with 4.5 (myself included, so I bought a new one).
     
    gamesquest1 likes this.
  20. adragon123

    adragon123 GBAtemp Regular

    Member
    130
    20
    Jun 29, 2014
    United States
    If they are, then they should work on the New 3ds instead of any other old firmware. that way we could just buy brand new New 3ds's while they're still on 9.xx