WiiWare games - meek required games go to black, others exit to HBC

Discussion in 'Wii - Backup Loaders' started by XC-3730C, Jul 27, 2017.

  1. XC-3730C
    OP

    XC-3730C GBAtemp Fan

    Member
    487
    53
    May 10, 2014
    United States
    I am setting up another softmodded Wii for a friend of mine.

    I cannot get ANY WiiWare games to work. I am using USB Loader GX, and I have already set up emunand on my USB drive (the directories are set to USB:/nand folder).

    I set up d2x cIOS per this guide:

    https://sites.google.com/site/completesg/backup-launchers/installation

    I even tried a pre-made emunand from this site:

    https://ccabz.wordpress.com/2013/01/16/neek2o-emunand-setup-for-noobs/

    Games that require neek, like Konami Rebirth titles just boot to a black screen. All other games exit to HBC.

    Please help. I have been at this for hours...
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,007
    775
    Mar 2, 2015
    United States
    Make sure your NAND folder is in one in the root of the drive called /nands/. neek2o r96 doesn't like it just being in /nand/. It generally ends up trying to use the root and writing a bunch of unusable folders to it. (shared1, shared2, sys, etc.)

    (e.g.: "sd:/nands/nandname")

    Also, if you installed d2x v10-beta53 as that guide suggest that could be part of the problem. It doesn't work well with emuNAND. v8 or v10-beta52 works.

    When setting up NEEK always make sure it boots before adding a bunch of titles to it. After about 100 it may not boot to the menu at all so there is no way to troubleshoot it.
     
  3. XC-3730C
    OP

    XC-3730C GBAtemp Fan

    Member
    487
    53
    May 10, 2014
    United States
    What do you mean by this?

    If you mean launching neek (I can launch it from within the WiiWare tab in Usb loader GX) itself, here is what I see when I launch it:

    [​IMG]

    For starters, I ended up dumping my own NAND, because the pre-made NAND had nothing but issues when installing WADS to it.

    I installed dx2 v10-beta52 for both IOS249/base 56, and IOS250/base57

    Both NAND Emu Path and NAND Emu Channel path are set to usb1:/nands/xxxx (xxxx in my case is named wiinand).

    Neek required games still boot to a black screen. I did get Adventure Island to work, but
    Alien Crush booted to black.

    Another strange issue is most emunand titles display a 4-digit code rather than the actual name of the title. (HACA for the Mii Channel, WD9E for Castlevania Rebirth, etc).
     
    Last edited by XC-3730C, Jul 27, 2017
  4. XC-3730C
    OP

    XC-3730C GBAtemp Fan

    Member
    487
    53
    May 10, 2014
    United States
    Anyone?
     
  5. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,007
    775
    Mar 2, 2015
    United States
    NEEK and emuNAND are not the same thing. NEEK does not use any IOSes. If you cannot launch a cleanly dumped copy of your console's NAND using NEEK before you add any extra titles to it then something is wrong with your setup. It's possible your drive configuration is wrong. It needs to be MBR/FAT32 with the main (or preferably only) partition as the first one. It's also possible it may not work on a flash drive. NEEK should work fine from SD or a real USB HDD.
     
    Last edited by GreyWolf, Jul 29, 2017
  6. XC-3730C
    OP

    XC-3730C GBAtemp Fan

    Member
    487
    53
    May 10, 2014
    United States
    My 500gb USB HDD is FAT32 formatted, and is the only partition. Wii games work well on it.
     
    Last edited by XC-3730C, Jul 29, 2017
  7. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,007
    775
    Mar 2, 2015
    United States
    That's running under cIOS still. NEEK is not the same environment. It doesn't have the same requirements.
     
  8. XC-3730C
    OP

    XC-3730C GBAtemp Fan

    Member
    487
    53
    May 10, 2014
    United States
    Well I am out of answers, as I followed the NEEK installation instruction step by step

    Sent from my SM-G955U using Tapatalk