Hacking Feedback Hardware WiiU freezes at logo screen - attempted UDPIH recovery force shuts it down

NAV1gate

New Member
OP
Newbie
Joined
Mar 29, 2023
Messages
3
Trophies
0
Age
22
XP
54
Country
Australia
Hello!

This is a long story, but it’s probably best to get into everything that’s happened with my console. Would absolutely love some input! TDLR will be at the end.

Anyway, just at the beginning of the pandemic, I was really into Splatoon 2 and it made me want to play the original, so after many years of playing my Switch (I stopped playing my WiiU after it launched) I took it out of storage. It booted fine, however I kept encountering multiple error codes (the ones I recorded include 108-0035, 160-1710, 150-2031) and my console just kept freezing; although the more I’d shut it down and try again, the longer it’d go without freezing. At the time, I was thinking if I tried a system update, surely it’d fix the freezing, and I’m sure you could guess what happened.

At this point, I had called Nintendo customer support and they advised me to turn off my wifi and see if it would respond to it - it did not. Everything was frozen. I had no choice but to pull the plug and it was then on I would be trapped at the logo screen. They gave me the details to send in my console for repairs, but I did not have the money so I did not end up going through with it. About a year and a bit later, I tried again and I took it into a local EB games (yoo any aussies?!) to see what they could do before going to Nintendo. I got it back and they listed it as unrepairable; they listed the fault being system memory corruption caused by freezing mid-update, which was from motherboard failure (assuming from leaving it unpowered for so long).

Recent discussions of WiiU failure and unbricking has inspired me once more to get it fixed; I had seen Voultar’s video and, while I did not have those error codes, the core issue was ultimately the same - corrupted system memory. Worth a try, ya know. I don’t wanna throw my WiiU away. So I had bought a pico, which just arrived today, and I have been going through the steps. What happens though is once I insert the pico to the screen, my WiiU just instantly shuts down. I think saw a flash of the recovery boot screen before it’d do that, but otherwise I cannot progress. It still boots to the frozen WiiU screen if I don’t insert it, so the pico didn’t like kill it.

I’m really just thinking I screwed up in going to do a system update back then (honestly I really don’t know why I thought to do that), but I wanna rule out all options first.

Any thoughts from this?

TDLR; WiiU kept freezing after taking out of storage w/ codes 108-0035, 160-1710, 150-2031, froze mid system update, begun only booting to the logo screen; have been trying to go into recovery using UDIPH however inserting pico forces console to shut down.
 

SDIO

Well-Known Member
Member
Joined
Feb 13, 2023
Messages
2,632
Trophies
1
Age
28
XP
1,838
Country
Germany
Do you know which firmware you were on before the Update?
If the Wii u shuts down from udpih it usually means the SDcard isn't prepared correctly. Is it formatted FAT32 (not exFAT) and does it have the recovery_menu file in the root?

If you get the menu to work, the first thing you should do is dumping otp. After that you should dump the logs and send them to me with a PM for analysis.
Third thing would be to go to system information and note the manufacturer and CID of the MLC/eMMC.

What voultar showed won't help you, because it only applies to CBHC bricks.
If you go to the Coldboot menu it will show you in the top left the current coldboot title, which should already be the same as you would set it to. You can try it, it won't break anything,but I am certain it won't fix your problem.
 

NAV1gate

New Member
OP
Newbie
Joined
Mar 29, 2023
Messages
3
Trophies
0
Age
22
XP
54
Country
Australia
Do you know which firmware you were on before the Update?
If the Wii u shuts down from udpih it usually means the SDcard isn't prepared correctly. Is it formatted FAT32 (not exFAT) and does it have the recovery_menu file in the root?

If you get the menu to work, the first thing you should do is dumping otp. After that you should dump the logs and send them to me with a PM for analysis.
Third thing would be to go to system information and note the manufacturer and CID of the MLC/eMMC.

What voultar showed won't help you, because it only applies to CBHC bricks.
If you go to the Coldboot menu it will show you in the top left the current coldboot title, which should already be the same as you would set it to. You can try it, it won't break anything,but I am certain it won't fix your problem.
No I don’t, sadly. I would want to take a guess as to what it would be - I did stop playing it about when the switch launched, then again I couldn’t know for certain.

I think you may have been right about the sd card. I did format it to FAT32 but I don’t think I did it properly originally, so I think I fixed that. My WiiU still went to shut down when I did it again - further attempts it didn’t shut down but still with the logo there. I could have just been missing the timing but I had realised the light was purple. I think it was doing that anyway though, I just didn’t notice it from the usual blue light. That should mean it’s being recognised, right?

I thought to try using the recovery_menu_dc_init file + renaming it and this actually made my screen change; although, it’s just a white screen and a bunch of blue/purple lines going through the middle. I guess that’s something though. I went to assume I was in recovery and tried to navigate the menu blindly for the logs - didn’t get anything from doing that though :mellow:
 

SDIO

Well-Known Member
Member
Joined
Feb 13, 2023
Messages
2,632
Trophies
1
Age
28
XP
1,838
Country
Germany
If you used my menu it has the options ordered differently. Try to dump otp with the original recovery
 

NAV1gate

New Member
OP
Newbie
Joined
Mar 29, 2023
Messages
3
Trophies
0
Age
22
XP
54
Country
Australia
I didn’t realise you had your own repairs, but I looked and holy crap you’re INSANE!!! Thank you for your breakthroughs in the community - mad respect!!

I had been just following the steps provided by Gary for UDIPH and going from there, but with my lack of progress, I’m going to try and hardmod my WiiU - at least to a point where I can get some data to work from. Your methods and references I think could really help me. Only thing is I have no experience at all, so I’m going to start learning soldering while I try and get a better understanding of how all this works.

I’ll keep you updated on how everything goes! And thank you for all your help so far. I finally have a way forward for my console :D
 

SDIO

Well-Known Member
Member
Joined
Feb 13, 2023
Messages
2,632
Trophies
1
Age
28
XP
1,838
Country
Germany
It's still work in progress and the SLC dumper still has problems. it will be integrated in Garys menu once it is ready.
You should try to get OTP and SEEPROM first. without them we can't analyze a dump you did in hardware. Maybe try it blind in garys menu.

Here is a updated version of my dumper, which should give indication on the power led. After booting it just press power once. After half a minute or so the power LED should start flashing yellow.
 

Attachments

  • recovery_menu_dumper_blink.zip
    17.4 KB · Views: 72

Hipoli04

Member
Newcomer
Joined
Jun 28, 2023
Messages
9
Trophies
0
Age
19
XP
29
Country
Spain
I didn’t realise you had your own repairs, but I looked and holy crap you’re INSANE!!! Thank you for your breakthroughs in the community - mad respect!!

I had been just following the steps provided by Gary for UDIPH and going from there, but with my lack of progress, I’m going to try and hardmod my WiiU - at least to a point where I can get some data to work from. Your methods and references I think could really help me. Only thing is I have no experience at all, so I’m going to start learning soldering while I try and get a better understanding of how all this works.

I’ll keep you updated on how everything goes! And thank you for all your help so far. I finally have a way forward for my console :D
Did you get a solution? I hace the exactly same error
 

V10lator

Well-Known Member
Member
Joined
Apr 21, 2019
Messages
2,716
Trophies
1
Age
36
XP
5,781
Country
Germany
@Hipoli04 The exact same error is the LED turning purple but no or garbled screen output? If so you need to navigate blindly and do what SDIO said:
1) Dump OTP + SEEPROM.
2) Dump syslogs.
3) Show us the logs (DM to SDIO or me in case you're concerned about the serial number inside of that logs).
4) Dump MLC and SLC.
5) Wait for further instructions.
 

Hipoli04

Member
Newcomer
Joined
Jun 28, 2023
Messages
9
Trophies
0
Age
19
XP
29
Country
Spain
@Hipoli04 The exact same error is the LED turning purple but no or garbled screen output? If so you need to navigate blindly and do what SDIO said:
1) Dump OTP + SEEPROM.
2) Dump syslogs.
3) Show us the logs (DM to SDIO or me in case you're concerned about the serial number inside of that logs).
4) Dump MLC and SLC.
5) Wait for further instructions.
I'm sorry, I'm new to this and I don't understand any of the process you have told me, could you explain it to me?
 

V10lator

Well-Known Member
Member
Joined
Apr 21, 2019
Messages
2,716
Trophies
1
Age
36
XP
5,781
Country
Germany
@Hipoli04 sended me the logs. This is indeed a dying eMMC:
Code:
00:00:04:442: mmc_core card err: idx=3, lba=55282688, blks=1024, xfer=0x1, ret=0x00200b40
00:00:04:442: mdblk: err=-131099, mid=0x90, prv=0x5c, pnm=[HYNIX ]
00:00:04:781: FSA: ### MEDIA ERROR ###, dev:mlc01, err:-2228230, cmd:11, path:(null)
00:00:04:781: failed to read file /vol/storage_mlc01/sys/title/0005001b/10042400/content/CafeCn.ttf, err -196673
00;00;04;662: ***LoadShared - WaitLoadComplete(0,8388608) failed with error -196673 on file "CafeCn.ttf".
00:00:05:154: mmc_core card err: idx=3, lba=55313408, blks=1024, xfer=0x1, ret=0x00200b40
(this is just one of many such log entries)

So Hipoli04: I'm going to bed now. Would be great if you could figure out how to do OTP, SEEPROM, MLC and SLC dumps from (SDIOs fork of) the recovery menu. In case you can't either @SDIO or me will tell you ASAP.

Tomorrow either SDIO or me will tell you what to do next but make sure to turn the console off with a 4 button power press after the MLC + SLC dump and to not turn it back on until we tell you to do so. Also maybe start reading into NAND-AID as you will need this. Next steps are roughly:
- Inspect the MLC dump to see what files are corrupted.
- Replace the eMMC (MLC) with a SD card (NAND-AID) containing that dump.
- Fix the curruptions by hand (with the recovery menu). This is the hardest step but we'll try to spoon feed you on it.

BTW: What country are you from? There might be some users near you able to give away NAND-AID PCBs for cheap. ;)
 

SDIO

Well-Known Member
Member
Joined
Feb 13, 2023
Messages
2,632
Trophies
1
Age
28
XP
1,838
Country
Germany
I wouldn't turn it off with the 4 second press, as that might start something from the menu. I would just remove the power.

EDIT: I have a single NAND-AID set left, that nobody claimed so far.
 

SDIO

Well-Known Member
Member
Joined
Feb 13, 2023
Messages
2,632
Trophies
1
Age
28
XP
1,838
Country
Germany
but before it tells the power ic to shut down, it tells the recovery menu to do whatever is selected.
 

CMDreamer

Well-Known Member
Member
Joined
Oct 29, 2014
Messages
1,741
Trophies
1
Age
39
XP
3,641
Country
Mexico
I wouldn't turn it off with the 4 second press, as that might start something from the menu. I would just remove the power.

EDIT: I have a single NAND-AID set left, that nobody claimed so far.
Would love to claim it if still available. Thank you!
 

Hipoli04

Member
Newcomer
Joined
Jun 28, 2023
Messages
9
Trophies
0
Age
19
XP
29
Country
Spain
I wouldn't turn it off with the 4 second press, as that might start something from the menu. I would just remove the power.

EDIT: I have a single NAND-AID set left, that nobody claimed so far.
if i need it, i would like to claim it
 

Hipoli04

Member
Newcomer
Joined
Jun 28, 2023
Messages
9
Trophies
0
Age
19
XP
29
Country
Spain
@Hipoli04 sended me the logs. This is indeed a dying eMMC:
Code:
00:00:04:442: mmc_core card err: idx=3, lba=55282688, blks=1024, xfer=0x1, ret=0x00200b40
00:00:04:442: mdblk: err=-131099, mid=0x90, prv=0x5c, pnm=[HYNIX ]
00:00:04:781: FSA: ### MEDIA ERROR ###, dev:mlc01, err:-2228230, cmd:11, path:(null)
00:00:04:781: failed to read file /vol/storage_mlc01/sys/title/0005001b/10042400/content/CafeCn.ttf, err -196673
00;00;04;662: ***LoadShared - WaitLoadComplete(0,8388608) failed with error -196673 on file "CafeCn.ttf".
00:00:05:154: mmc_core card err: idx=3, lba=55313408, blks=1024, xfer=0x1, ret=0x00200b40
(this is just one of many such log entries)

So Hipoli04: I'm going to bed now. Would be great if you could figure out how to do OTP, SEEPROM, MLC and SLC dumps from (SDIOs fork of) the recovery menu. In case you can't either @SDIO or me will tell you ASAP.

Tomorrow either SDIO or me will tell you what to do next but make sure to turn the console off with a 4 button power press after the MLC + SLC dump and to not turn it back on until we tell you to do so. Also maybe start reading into NAND-AID as you will need this. Next steps are roughly:
- Inspect the MLC dump to see what files are corrupted.
- Replace the eMMC (MLC) with a SD card (NAND-AID) containing that dump.
- Fix the curruptions by hand (with the recovery menu). This is the hardest step but we'll try to spoon feed you on it.

BTW: What country are you from? There might be some users near you able to give away NAND-AID PCBs for cheap. ;)
thank you for the help! I'm from Spain. I'm going to bed now, but i hope we can fix this wii u together! I have already dump the OTP and the SEEPROM, but i don't know how to do the MLC & SLC Dumps. Tomorrow will see :)
Post automatically merged:

Do you have a broken eMMC?
I guess so, according to what @V10lator has told me.
Post automatically merged:

@Hipoli04 sended me the logs. This is indeed a dying eMMC:
Code:
00:00:04:442: mmc_core card err: idx=3, lba=55282688, blks=1024, xfer=0x1, ret=0x00200b40
00:00:04:442: mdblk: err=-131099, mid=0x90, prv=0x5c, pnm=[HYNIX ]
00:00:04:781: FSA: ### MEDIA ERROR ###, dev:mlc01, err:-2228230, cmd:11, path:(null)
00:00:04:781: failed to read file /vol/storage_mlc01/sys/title/0005001b/10042400/content/CafeCn.ttf, err -196673
00;00;04;662: ***LoadShared - WaitLoadComplete(0,8388608) failed with error -196673 on file "CafeCn.ttf".
00:00:05:154: mmc_core card err: idx=3, lba=55313408, blks=1024, xfer=0x1, ret=0x00200b40
(this is just one of many such log entries)

So Hipoli04: I'm going to bed now. Would be great if you could figure out how to do OTP, SEEPROM, MLC and SLC dumps from (SDIOs fork of) the recovery menu. In case you can't either @SDIO or me will tell you ASAP.

Tomorrow either SDIO or me will tell you what to do next but make sure to turn the console off with a 4 button power press after the MLC + SLC dump and to not turn it back on until we tell you to do so. Also maybe start reading into NAND-AID as you will need this. Next steps are roughly:
- Inspect the MLC dump to see what files are corrupted.
- Replace the eMMC (MLC) with a SD card (NAND-AID) containing that dump.
- Fix the curruptions by hand (with the recovery menu). This is the hardest step but we'll try to spoon feed you on it.

BTW: What country are you from? There might be some users near you able to give away NAND-AID PCBs for cheap. ;)
So... should we start?
 
Last edited by Hipoli04,

SDIO

Well-Known Member
Member
Joined
Feb 13, 2023
Messages
2,632
Trophies
1
Age
28
XP
1,838
Country
Germany
The quuestion was directed at @CMDreamer, because he asked for a NAND AID without showing a problem.
Your eMMC @Hipoli04 is clearly bad, there iis no question. I would give the last NAND-AID set to you, because you clearly need it and claimed it.

The next step would be to dump the slc + mlc with the custom recovery. Maybe you can look at another thread, where it was uploaded and explained. I am to tired now, maybe I will explain it tomorrow, if you still have questions.
 

Hipoli04

Member
Newcomer
Joined
Jun 28, 2023
Messages
9
Trophies
0
Age
19
XP
29
Country
Spain
The quuestion was directed at @CMDreamer, because he asked for a NAND AID without showing a problem.
Your eMMC @Hipoli04 is clearly bad, there iis no question. I would give the last NAND-AID set to you, because you clearly need it and claimed it.

The next step would be to dump the slc + mlc with the custom recovery. Maybe you can look at another thread, where it was uploaded and explained. I am to tired now, maybe I will explain it tomorrow, if you still have questions.
Sounds good to me, I Will explore how to dump the slc and mlc and then I tell you :)
Post automatically merged:

The quuestion was directed at @CMDreamer, because he asked for a NAND AID without showing a problem.
Your eMMC @Hipoli04 is clearly bad, there iis no question. I would give the last NAND-AID set to you, because you clearly need it and claimed it.

The next step would be to dump the slc + mlc with the custom recovery. Maybe you can look at another thread, where it was uploaded and explained. I am to tired now, maybe I will explain it tomorrow, if you still have questions.
What do you mean by "custom recovery"?
 
Last edited by Hipoli04,

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Veho @ Veho: