Hacking WiiFlow Lite

kaisersozeh

Well-Known Member
Member
Joined
Mar 21, 2018
Messages
260
Trophies
0
Location
Phobos
XP
993
Country
Antarctica
i have another proposal for everyone. something i've wanted to do for some time now.

i want to make wiiflow totally use plugins. with the wii, gc, nand, emunand, and homebrew plugins i made up, i could make wiiflow work in plugin mode all the time. enabling and disabling wii, gc, nand channels, and homebrew would be as simple as adding or not adding the plugin to wiiflow/plugins folder.

what do you think?
If you do this you could distribute a version, without the 'illegal' cios plugins, on wiibrew - as an emulator coverflow loader (in addition to a mediaplayer and homebrew front-end). People just don't see wiiflow as an emu game loader, which is where wiiflow is most immediately useful and where it differs from anything else available. After hacking your wii, wiibrew is the first point of call - a wiiflow presence there will mean more people downloading and enjoying the software.
Wiiflow can also function as a front end for homebrew that can handle arguments, so a presence on wiibrew might encourage more plugins. WiiFlow can handle menus and art and just feed an argument to the homebrew. Easy RPG and Flash game specific urls spring to mind. Podcasts? Newsreader?
This is something that could sit alongside a USBLoaderGX install, users have that for what it does and wiiflow for everything else.
Edit: Personally, this being wiiflow's greatest strength, i think if you @fledge68 did release a plugin version, do it with a new name, in gbatemp/wii/Emulators and Homebrew. - i doing think that will expose far more potential users to wiiflow.
 
Last edited by kaisersozeh,

fledge68

Well-Known Member
OP
Member
Joined
Jan 30, 2012
Messages
2,221
Trophies
1
XP
3,777
Country
United States
@Wiimpathy or anyone else that can help.

my cps2 roms are not working with retroarch wii 1.7.6 via a wiiflow plugin or even the app itself. the most i get is the screen resolution message.
any idea why? do i need to update my roms? do they work for everyone else?

cps1, neogeo, and fba roms all work fine.
 

Wiimpathy

Well-Known Member
Member
Joined
Mar 3, 2010
Messages
948
Trophies
1
XP
2,376
Country
France
@Wiimpathy or anyone else that can help.

my cps2 roms are not working with retroarch wii 1.7.6 via a wiiflow plugin or even the app itself. the most i get is the screen resolution message.
any idea why? do i need to update my roms? do they work for everyone else?

cps1, neogeo, and fba roms all work fine.

Generally, if the roms are bad, it goes back to the retroarch's menu or just crashes. I've tried with Retroarch 1.7.7 and it's ok even as a plugin.

Maybe you're using a build that had a bug or it's a config conflict between old and new version. There are all sort of problems when using old retroarch config with new build. Wii controllers not responding for example.

To avoid this kind of mess, one way is to have a custom cfg per core. By hex editing the dol, and replacing retroarch.cfg by retrocps2.cfg. Or compile the cores yourself and change the config names.
Or just use about the same version for everything and be sure to start fresh by deleting retroarch folder (back up first!?).

EDIT:
There's a bug in 1.7.7 when switching video resolutions. It has been fixed since then. You need a nightly build: http://buildbot.libretro.com/nightly/nintendo/wii/
 
Last edited by Wiimpathy,

Wiimpathy

Well-Known Member
Member
Joined
Mar 3, 2010
Messages
948
Trophies
1
XP
2,376
Country
France
How do I add the emulator arguments in emGBA (https://github.com/Extrems/mGBA) in WiiFlow?

<arguments>
<arg>--filter=scale2xex</arg>
<arg>--matrix=gbi</arg>
<arg>--scaler=oversample</arg>
<arg>--cursor=sd:/mGBA/point-srgb.tpl.gz</arg>
<arg>--overlay=sd:/mGBA/frame-srgb.tpl.gz</arg>
</arguments>
I haven't tried this but I'd just seperate each arg with the pipe symbol :

arguments={device}:/{path}/{name}|--filter=scale2xex|--matrix=gbi|--scaler=oversample etc...

Not sure if the games path needs to be first, at the end or whatever.
 

rogerioronin

Well-Known Member
Newcomer
Joined
Nov 19, 2013
Messages
52
Trophies
0
Age
35
Location
Jandira, Sao Paulo, Brazil
XP
1,402
Country
Brazil
I haven't tried this but I'd just seperate each arg with the pipe symbol :

arguments={device}:/{path}/{name}|--filter=scale2xex|--matrix=gbi|--scaler=oversample etc...

Not sure if the games path needs to be first, at the end or whatever.



I tried "arguments = {device}: / {path} / {name} | --filter = scale2xex |matrix = gbi | --scaler = oversample" and it did not work
 

Tetsuo Shima

Well-Known Member
Member
Joined
Oct 29, 2008
Messages
1,686
Trophies
1
Age
43
XP
3,546
Country
Italy
What is the best retroarch version to use as a plugin on WFL?
I'm on RA 1.0.0.2, modded to have separate per-core cfgs. But maybe it's too old and could be updated for performance or compatibility, or added dols.

Maybe we could create a complete list of the best plugins to use with Wiiflow, including stand alone emulators for systems not covered by RA. If we share our setups maybe it will not be too difficult.
It could be the base for a new Masterpiece pack:creep:
And this could also help Fledge to update platform.ini (if he wants to do it)
 
  • Like
Reactions: Neoma

Wiimpathy

Well-Known Member
Member
Joined
Mar 3, 2010
Messages
948
Trophies
1
XP
2,376
Country
France
I tried "arguments = {device}: / {path} / {name} | --filter = scale2xex |matrix = gbi | --scaler = oversample" and it did not work

- Download the latest emGBA and extract it to USB drive.

- In /WiiFlow/plugins create a file called emgba.ini with this content :
Code:
[PLUGIN]
magic=45474241
covercolor=01a300
coverfolder=gba
filetypes=.gba|.zip
romdir=roms/GBA
dolfile=usb1:/apps/emGBA/boot.dol
bannersound=sounds/GBA.ogg
displayname=emGBA-gba
consolecoverid=nintendo
arguments={device}:/{path}/{name}|--filter=scale2xex|--matrix=gbi|--scaler=oversample|--cursor={device}:/mGBA/point-srgb.tpl.gz|--overlay={device}:/mGBA/frame-srgb.tpl.gz

- In source_menu.ini add the button :
Code:
[BUTTON_54]
image=Game_Boy_Advance.png
image_s=Game_Boy_Advanceb.png
source=plugin
magic=45474241
emuflow=5

The dolfile path assumes it's the first partition for usb. It should work in most cases but you can also copy the dol in WiiFlow/plugins too. You'd have to rename it to emgba.dol for example and modify the ini to dolfile=emgba.dol
Off course change BUTTON_54 to which number you want.

What is the best retroarch version to use as a plugin on WFL?
I'm on RA 1.0.0.2, modded to have separate per-core cfgs. But maybe it's too old and could be updated for performance or compatibility, or added dols.

Maybe we could create a complete list of the best plugins to use with Wiiflow, including stand alone emulators for systems not covered by RA. If we share our setups maybe it will not be too difficult.
It could be the base for a new Masterpiece pack:creep:
And this could also help Fledge to update platform.ini (if he wants to do it)
It's hard to say which one is the best. There have been fixes since then for sure. In retroarch and the cores too. Not really a lot of real new features for the Wii port though.

There are some new cores indeed. A list would be great with updated emulators as we already discussed.
We'd have to download a retroarch nightly and test each core. There are 50 currently. Then update and add entries to Source_menu + Default Rompaths.rtf from the Masterpiece pack.

I've already gave a list of new standalone emulators back in april: https://gbatemp.net/threads/wiiflow-lite.422685/page-76#post-8580238
mGBA and emGBA weren't in the pack either.

I may sound pessimistic but I don't think anyone will update the pack.
 
  • Like
Reactions: rogerioronin

fledge68

Well-Known Member
OP
Member
Joined
Jan 30, 2012
Messages
2,221
Trophies
1
XP
3,777
Country
United States
as for making a new WFL master pack, i was working on it and got about half way through but the last 2 months and all of summer i've been or will be very busy with other things. not much spare time to work on it or WFL.

If anyone else has the time and wants to they are more than welcome to update Abz's wiiflow pack and upload it somewhere.

in the mean time i will try to put out a WFL 5.3.0 release soon. but i'm very disappointed because currently it can't launch roms using the retroarch 1.7.6 cps2 core. i tried 1.7.7 and i tried WFL 5.2.0, neither worked. I'm guessing the cps2 core is too big in bytes and conflicting with the apploader. Haikaisha says it works for her but she's using SuperSonics version of it.

It would be nice to know which retroarch version works the best.
 

Wiimpathy

Well-Known Member
Member
Joined
Mar 3, 2010
Messages
948
Trophies
1
XP
2,376
Country
France
Last edited by Wiimpathy,
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: https://youtu.be/g3U7tCipvdQ