WiiFlow crashed; can no longer alter most files in HDD. Need help!

Discussion in 'Wii - Backup Loaders' started by Alacres, Mar 5, 2015.

  1. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    I'm so bummed right now. After spending all night finally getting the Wiiflow masterpack installed, doing all the steps, copying over a ton of wii games and such, I finally get it all working (including the emunand) and then as I'm looking at the Wii games, I hit the back button on my wiimote and everything goes crazy. Flashing green lines, crazy noises, and it crashes hard requiring me to manually restart. Well, much to my horror, now wiiflow won't load from my USB (it just sits there for a second and then loads back to the system menu. Then I hook the drive up to my computer to check it out and it's not letting me copy or delete certain files. Instead it gives me a "corrupted" message.

    Does anyone know what might have happened, and what can I do to fix it? This is a brand new WD external drive that I got yesterday, and it didn't seem to have any problems prior. I had planned to take my wii over to a friend's tonight for some gaming, and this really screwed me plans.

    I'm running chkdsk right now, but I'm not all that hopeful about it. If any of you can give me some advice, I'd be really grateful.
     


  2. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    Many HDD, Flash Drives, SD are fake give wrong sizes and corrupt stuff written on them. This might be the case. If not then it's an unlucky crash.
    If your scandisk fails and your files are lost I would check the drive using special tool.
    There are many tools like rmprep which checks real size/speed and what not but they format the drive to do so.
    so save whatever you can, check it out and if fake get another one
     
    Alacres likes this.
  3. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Thanks very much for the response. Chkdsk still isn't finished unfortunately so I probably won't know what I'm dealing with for a few days (as I won't be home again until then.) I don't want to disturb it so I'm just going to let it finish while I'm gone; I'll be using my old external drive until then.

    I had another question though -- when you say the HDD/flash drives are sometimes fake, what do you mean exactly? That the drive itself is literally a fraudulent piece of hardware? It's a Western Digital Elements drive that I ordered directly from Amazon (it was actually one of the drives listed on the compatibility page) so I would think it would be a legit drive. I was wondering if it might have happened because I wasn't sure about a few of the steps in your masterpack guide. On the wad section, I didn't install any of the IOS/cIOS wads because I wasn't sure it was necessary. I had already followed the "Complete Softmod Guide" and did the cIOS installation using their instructions when I first got my Wii. Could that be why my Wiiflow crashed? Do I need to install all those wads to make it work correctly?

    Thanks again for the help; I really appreciate it!
     
  4. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    if the wii is properly modded then those wads are not needed
     
    Alacres likes this.
  5. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Ah okay, good to know. I did actually install the BC-NUS-v6.wad and RVL-mios-v10.wad though -- was I supposed to do that?

    By the way, I just wanted to take a minute to say thanks for all the hard work you've done on all this stuff. I also really love your Carbonik Abz theme; it beats the heck out of the default, imo :). That's one of the reasons I was so bummed when my drive got screwed up. The external I'm using now only has the default one and I decided to keep it that way for now so I don't risk screwing anything up with it too, heh. Assuming my new drive isn't faulty or something, I'm hoping I'll finally be able to get your masterpack set up properly. I'll probably start over clean and try to be extra careful while following the instructions. I'm still a total noob to wii hacking but little by little it's starting to make more sense.

    And again, thanks for the help!
     
    AbdallahTerro likes this.
  6. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Well damn, this is getting ridiculous. I finally got back home yesterday, and decided to reinstall everything (since the chkdsk went through and "fixed" the issues.) After getting the masterpack installed again and putting all my games back on it, I tested it out for awhile, played a few games (both wii and GC) and it seemed to work fine. Then it started getting more and more glitchy and sluggish as I navigated through the menu, and also it was taking forever to load game covers and such. Then it would freeze for a second or two between switching to different sections and stuff like that. And finally, it crashed again (this time it gave me an "exception message" and restarted itself) and naturally, the whole drive is screwed again. It won't even let me access it on my PC without formatting it first.

    So since this is the second time this has happened -- both times which have caused my drive to become inoperable -- do you think it's my new drive that's messed up? Is there anything else that could cause this kind of behavior? I never had a crash or anything with my old drive, but I was just using the basic version of wiiflow on it and not much else. If you think it's likely the drive, I'll probably just send it back while I can. I was going to try it with my old drive, but I'm a little worried I might screw it up too.

    Edit: Now that I think about it, I was running wiiflow from the SD card when using my old drive. I'm not sure that makes any difference but I figured it was worth mentioning.
     
  7. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    your drive is faulty, get a new one, having wiiflow on sd won't make a difference, using old wiiflow too
     
    Alacres likes this.
  8. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Yeah, I figured that's what it was. I don't think anything else could cause such fatal crashes. I'm sending it back for a replacement; hopefully I'll get lucky this time. It has great ratings on Amazon, but I guess it's never a sure thing with hard drives.

    Thanks for the confirmation.
     
  9. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Well, I installed everything on my old drive finally (masterpack, all my games, etc) and it seems to work better than the other. I'm still having issues with crashing though, but luckily, wiiflow always loads right back up (versus my other drive which became unusable afterwards.) I've isolated a few things that always cause a crash and I was wondering if you knew why it might be happening. It crashed probably about 3 times while I was trying to download a few missing covers for games that seemed to have covers missing or only partially there. Funny thing is, after the crash, when I went back, the covers were all showing up like they were supposed to.

    Another crash happens every time I try to click on a particular GC game (The Sims.) It doesn't even let me attempt to load it. I just click on the cover and I get the "exception" crash screen. It happens every time. I thought it might have been an issue with the game itself, but it happens before I even get to where I can load it.

    Do you know what might be causing this behavior? I know it's not the drive as I've never had problems with it, and it never crashed with the vanilla version of wiiflow installed. Can the covers sometimes cause crashing?

    On a positive note, it hasn't crashed on me while in game yet, so at least there's that.

    Thanks again for the help!
     
  10. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    crash when selecting a game is due to either wrong/corrupted cache file or cover/Png file, so delete both png and wfc files from covers/boxcovers and cache folders and rebuild the cache
    oh and also a corrupted banner file can do that too so make sure you download both the custom banner and game cover for the game
     
    Alacres likes this.
  11. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    I'm just having the worst luck with all of this. I deleted all the png and wfc files in the folders you mentioned, then I tried to download them again (this time picking the original/custom order, in cae any originals were missing.) Well, I guess that messed something up with the wii covers because once I went to the games to see if the covers were working, I clicked on Bully to check it and I got stuck in some infinite crash loop. I deleted all the files again and redownloaded them going with only the original covers and it worked that time. Then I switched over the my GC games and, just out of curiosity, I clicked on "The Sims" again since it didn't have a cover yet. I'm not sure what the problem is but even without the cover, it crashed wiiflow with an exception just like before. I just can't figure out what could possibly cause that to happen.

    Then I went to download all the covers again, and this time the download just stopped about midway and wouldn't go any further. When I go to cancel it, it just sits there "Cancelling..." and doesn't do anything and I'm forced to hard restart the system. Ugh, I'm getting stressed. The Wii has to be the most finicky console I've ever softmodded.

    In any case, thanks for the help. I'll try downloading everything again later and hope it works out.
     
  12. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    looks like a bad "sims" iso (most probably wiiflow crashed when trying to load the banner from the iso) so in this case you need to redump or download another one
     
  13. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Yeah, I'll have to look around and see if I can find another. I'm not really a big Sims player anyway, but I was interested in seeing what the GC version was like.

    I did have another question about GC games if you don't mind. Do you know what might cause some of them to not start up at all? So far, I've noticed a handful that just give me a black screen after the Nintendont loader and I'm forced to restart the system. I also have one (1080 Avalanche I think) that actually causes the system to turn off when I try to load it. Are they just faulty isos or could it be a setting I need to change?

    Also, kind of unrelated, but is there any way to turn memory card emulation on for all games at once, or do you need to set it specifically for each game.

    Thanks again :)
     
  14. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    black screen can be bad iso, force video modes or reloading IOS, so check the settings
    to change default memory card you need to edit the wiiflow ini. however it's on by default if you are using my latest mod
     
  15. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Okay, I'll check the settings in Nintendont but I think most of the stuff is turned off.

    When you say latest mod, are you talking about your masterpack or is there something else that I should download? I'd try changing the ini myself, but I can't find it anywhere in my folder.
     
  16. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    http://copy.com/vRN3HgFVyk9u7YuB/Public/Edit_ini.txt
     
    woodflower and Alacres like this.
  17. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
  18. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    Just a little update -- I got my new WD replacement drive today and, lo and behold, it's crashing practically non-stop. The drive didn't become inoperable like the last one, but something about these WD elements drives just don't seem to play nice with the Wii at all. I couldn't even browse through my GC gamelist (in the "wall paper" mode) without it crashing. It's crazy. So yeah, I'm done with this drive and possibly all WD external drives from here on. I'm just going to continue to use my old Seagate drive as long as I can. It seems to be a hell of a lot more stable.

    By the way, I had a quick question about an issue with Nintendont if you don't mind. I just put my Seagate drive back with my Wii (I didn't change anything, except for swapping out the "saves" folder from the one on my SD card because I stupidly thought I'd be able to use my old virtual console saves that way -- that's another question I could use help with) and I noticed that the R+Z+B + D-pad down function for exiting a GC game isn't working anymore. I'm forced to do a hard restart of my Wii in order to pick a different GC game. Do you have any idea what could cause that to stop working? It worked just fine the last time I used this drive. I did change a few things in the wiiflow.ini as we discussed above, but I don't see how that would mess this up.

    Anyway, just thought I'd ask. Thanks in advance.
     
  19. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,519
    Jan 14, 2012
    Ideas factory :)
    you might have changed the "return to" option while editing wiiflow ini, so just make sure you have "wiiflow" as selection there, it's in general settings. also make sure you have the wiiflow loader wad v2 installed
     
    Alacres likes this.
  20. Alacres
    OP

    Alacres Advanced Member

    Newcomer
    78
    3
    Dec 11, 2009
    United States
    That's actually one of the things I always change in the settings while I'm in wiiflow, but I noticed it wasn't set to "wiiflow" in the ini itself. That wasn't what was causing the problem though. It was the "native controls=yes" option that was prohibiting the function from working. It's also what was causing my wiimote to stay on whenever I played a GC game (I noticed it staying on, with all 4 lights on, before I disabled the native controls thing.) I'm not sure if there are benefits to using the native controls option, but considering this issues it causes, I'm going to leave it off for now.

    A bit off-topic, but I was wondering if you might know anything about where to find the save files for VC games? I was playing an injected rom (Earthbound) on my emunand, but before I installed your masterpack, I took all my old files off the drive first (wiiflow, nand folder, etc) so there wouldn't be any conflicts. Because of that, my saves went with it. Since I still have all those old files saved on my PC, is it possible for me to transfer my VC saves to my current USB drive? If so, how do I go about doing that? To put it simply, I just want to transfer my VC saves from one drive to another, essentially. If that's possible.

    As always, thanks again for all the help :).