Wii Won't Initialize HD (that works on other Wiis)

Discussion in 'Wii - Hacking' started by asd63, Jan 19, 2013.

Jan 19, 2013
  1. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    Hey everyone,

    I've modded 3 different Wiis before this one, and I've never had this problem before. For some reason, when I plug in a hard drive (that works on two other Wiis), USB loader gx does not recognize it and it fails to initialize. I put this in Wii Hacking instead of Backup Loaders because all 3 Wiis have the same USB loader and same version.

    This is the only one that was 4.3U, and I had to use the Letterbomb exploit to get the HBC this time around. I used Mod-Mii and installed all the cIOS and IOS that Mod-Mii generated.

    At first I figured the cIOS may not have installed cleanly, so I reinstalled them. I used Port 0 (on the right when looking at the back of the wii, right?) for all three Wiis, although I did try Port 1. I saw that Cyan mentioned that some Wiis might require an IOS249 with base 58 if the USB test app returned 0x3002 in the log file, but this is the log I got (0x3000):
    Warning: Spoilers inside!

    Here's a system check (I attached a zip of the syschecks in case you can't make it out below):
    Warning: Spoilers inside!

    Also, an IOS syscheck (included in zip file):
    Warning: Spoilers inside!

    The hard drive has multiple partitions, but both Wii and Gamecube backups are on the first, primary, active partition in FAT32 (and yes 32 kb cluster size).

    As far as I know, the Wii is the same as the others I've modded (edit: except that one of them may have an older IOS249), but for some reason this one does not work.

    Any help is greatly appreciated! Let me know if any other info could help.

    Thanks!
     

    Attached Files:

  2. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    See if you are using v8 on the two Wii's that do work.
     
  3. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    well, one of them I believe is IOS249 base 38, rev 17. but the other (mine) I'm 99.9% sure is also d2x v8 final. I remember deciding to update my cIOS using Mod-Mii and noticed a couple cIOS's had "d2x...final". I can't recall for sure if it was v8, but I assume it would be..

    EDIT*
    I was in fact using d2x v8 final. I updated to d2x v10-alt. Both versions support the USB drive on my Wii.
     
  4. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands
    Is the problem HDD usb powered or adaptor powered?
    Do you have usbl gx on sd card or hdd only?
    If so, reinstall D2x cios 249/ 250
     
  5. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    The HDD is usb powered (eGo Iomega Ruby, 320GB), and I have usbl gx on sd card only. How are they related to the d2x install? is there something I should do before installing it that I'm forgetting or not seeing? I'll try a reinstall tonight.
     
  6. Coto

    Member Coto GBAtemp Addict

    Joined:
    Jun 4, 2010
    Messages:
    2,278
    Country:
    Chile
    hmm.. for some reason the usb controller throws out not-connected device. if possible you'd have to disable all hdd-controller/disk software bullcrap onboard both the hdd/controller firmware does upon booting up the disk.

    it is that, or the usb controller you have plugged in, it's 3.0 USB compliant only
     
  7. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    hmm, well the HDD does have USB 2.0 (it works on two other Wii's). Not sure what you mean by disable hdd-controller/disk software or how to do that, but here's a syscheck of my Wii (where the HDD works).

    Warning: Spoilers inside!

    and the IOS syscheck:

    Warning: Spoilers inside!


    One thing I noticed is on the Wii that doesn't work, the Homebrew channel says that it's 1.0.0 running on IOS0, where mine says it's 1.1.0 running IOS58. Maybe I should re-install the HBC? But I don't see how that would fix things, because the forwarder channel for USB loader gx still can't find the HDD (and it can on my Wii). Also, the IOS check reports IOS247 and 248 on mine, but the not-yet-working wii doesn't (and it reports IOS236, where mine doesn't). I think I know why the 247 and 248 show up on mine though. I wanted to install IOS249 with different bases, but wanted the newest ones in 249 and 250, so I installed it to slots 247 and 248.

    Hopefully this info helps.

    edit: the IOS's differ for the following (that I've noticed):
    IOS16
    IOS90 (I have it, he doesn't)
    IOS248, IOS249 (I have them, he doesn't, but no big deal since I chose to install them, and they're not required. Right?)
     
  8. Yepi69

    Member Yepi69 Vivid and busy gamer

    Joined:
    Nov 29, 2010
    Messages:
    1,679
    Location:
    Behind you
    Country:
    Portugal
    Have you tried on another USB port?
     
  9. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    Yea I tried the other USB port, but it still wouldn't find it. I think I might need d2x v10-alt to use the other port, wouldn't I? Also, DIOS MIOS needs port 0, correct? Forcing it to the other port is kinda a last resort (if it would work) because of DIOS MIOS.

    edit* I just updated mine (the one that was already working) to d2x v10-alt, same bases, in IOS249 and 250.
    Using multiple ports works for Wii games, but doesn't for Gamecube as I figured.

    For the one that doesn't work, I'm going to try to see if apps show up on the HDD in HBC and I'll test d2x v10-alt as well.
     
  10. stev418

    Member stev418 GBAtemp Fan

    Joined:
    Sep 25, 2007
    Messages:
    492
    Country:
    Australia
    for what its worth i have 2 wiis with the exact same software and hack setup, but i have a USB thumb drive that only registers on the older of the two wii's
     
  11. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    Hmm strange.. heres some more info:

    I put the "apps" folder that was on the SD card onto the HDD, and loaded up the HBC. The apps did show up, so it's not a faulty port or anything. This just means there's something wrong with the way I hacked it.. but I can't see what... Anyone have any ideas?

    If I need to, I'll just re-mod it with Mod-Mii. I think it's very strange that HBC is 1.0.0 using IOS0 according to syscheck. Any explanation for that?
     
  12. asd63
    OP

    Newcomer asd63 Newbie

    Joined:
    Jan 19, 2013
    Messages:
    7
    Country:
    United States
    Hey everyone,

    I'm still working on this and haven't figured out a solution, but rather than create a new topic, I'd figure I'd post my progress up to this point to see if any of this new info could help figure this out.

    Basic info:
    - USB loaders can't find my external harddrive on 1 Wii, but the USB loaders on 2 other Wii's do find it.
    - I've tried a different external hard drive on the Wii that doesn't work, but that didn't work either (but it does work on the other two).
    - On the Wii that doesn't work, I CAN see and load apps stored on the hard drive in the Homebrew channel.
    - I can see the FAT32 partition in WiiMC app, but not the NTFS or WBFS (which I expected) partitions. The WBFS partition is the primary, active partition right now, but I just changed that to test this. The FAT32 partition was the primary, active partition but that didn't work either.

    Here's the newest syscheck. I've installed d2x v8 final with base 56 and 57 in ios slots 249 and 250 respectively.
    Code:
    sysCheck v2.1.0b19 by Double_A and R2-D2199, Nano
    ...runs on IOS58 (rev 6175).
     
    Region: NTSC-U
    System Menu 4.3U (v513)
    Priiloader installed
    Drive date: Unknown
    Homebrew Channel 1.1.2 running on IOS58
    HomebrewFilter ist nicht installiert
    Console ID: 49015267
    Boot2 v4
    Found 101 titles.
    Found 51 IOS on this console. 3 of them are stub.
     
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 16174): Trucha Bug, NAND Access
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 54321): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 1032): No Patches
    IOS20 (rev 16174): Trucha Bug, NAND Access
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 16174): Trucha Bug, NAND Access
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): Trucha Bug, ES Identify, NAND Access
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 16174): Trucha Bug, NAND Access
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 16174): Trucha Bug, NAND Access
    IOS51 (rev 4864): Stub
    IOS52 (rev 16174): Trucha Bug, NAND Access
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6175): USB 2.0
    IOS60 (rev 16174): Trucha Bug, NAND Access
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 16174): Trucha Bug, NAND Access
    IOS80 (rev 16174): Trucha Bug, NAND Access
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS247[58] (rev 21, Info: rev 21): Trucha Bug, NAND Access, USB 2.0
    IOS248[56] (rev 21, Info: rev 21): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    BC v6
    MIOS v10 (DIOS MIOS 2.6.1+)
     
    Report generated on 2013/12/07.
    I've rehacked using Modmii several times and even tried pulling some IOSs from the other wii and installing them to this wii (with BlueDump Alpha 3 Fakesign), but nothing has worked.

    Any help is very greatly appreciated :]


    Update* I got it to find the hard drive when I used Hermes cios 222 in Port 1. I would rather use d2x though, so I'm still trying to find a solution. Hermes cios in port 1 wouldn't allow Gamecube games to run off the HD right? since Dios Mios needs to be in port 0..

    Update2* I got it to run off of d2x-v10-beta53alt in Port 1. Still doesn't work in Port 0. (I set the ios and usbport settings in the meta data for usbloader gx). Ran a Wii game in Port 1 and it works fine, but GC games don't show up since it's not the right port..

    So I basically found that Port 0 doesn't work, Port 1 does. Any ideas why?

    Update3* Well I just found out that DIOS MIOS does actually work in Port 1... so I suppose there's no reason to keep trying to force Port 0. I'm fine with using Port 1 now, so mystery solved.
     

Share This Page