Wii updated to 3.2U, how do IOS files work, what do I need?

Discussion in 'Wii - Hacking' started by protomind, Mar 13, 2009.

  1. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    I have a first gen Wii with Wiikey and HomeBrewChannel, my system is updated to 3.2U update. From what I understand I need to update my Wii with some IOS files in order to play the latest games. My question lies in the amount of updates needed. For example in order to play madworld, on my favorite private gaming tracker there is a torrent with the following files "IOS38-64-v3609.wad, IOS53-64-v4113.wad, IOS55-64-v4633.wad", it is said that I need to install the aforementioned files to play madworld. Since I have not installed ANY other IOS files, will installing these cover all previous IOS updates? Meaning: Is this a sort of cumulative patch? Or do I need to do a series of IOS file patches leading me up the the latest ones so that I can play all of the latest games?

    Hopefully I have made myself clear and easy to understand.

    Thank you for taking the time to read all of this.

    Any help is greatly appreciated.
     
  2. kikoolol

    Newcomer kikoolol Advanced Member

    Joined:
    Mar 15, 2008
    Messages:
    64
    Country:
    United States
    The more IOS your wii have, more things will be able to run.

    IOS are operating system, files that are needed by apps to run. For example if you have apps A,B,C. A use IOS30, B use IOS40, C use IOS50. In the end, you'll need IOS 30/40/50 to run each apps, if you only have IOS 50, only apps using IOS 50(so app C here) will run.

    Sorry if it's not clear.
     
  3. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    Well, what should install to be able to run them all, assuming I did every official update, what list of IOS files would I need to play them all? Or are some games having custom IOS files?
     
  4. kikoolol

    Newcomer kikoolol Advanced Member

    Joined:
    Mar 15, 2008
    Messages:
    64
    Country:
    United States
    Custom IOS are unofficial IOS so you can't find them in games.

    You need some cIOS tu runs some unofficial apps, look for cIOScorp to be up to date.
     
  5. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    What IOS files should I install to keep me up to date with all official games?
     
  6. kikoolol

    Newcomer kikoolol Advanced Member

    Joined:
    Mar 15, 2008
    Messages:
    64
    Country:
    United States
  7. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    Thanks for the link, I am still at a loss, but closer to understanding. The link you gave gives me no clear timeline as far as what IOS is included with what system update. So do I need the last three?
     
  8. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    Does anybody know what IOS WADS I need to play some of the latest games? Or at could someone help me figure it out. The link above that was given may hold the answer, but I am not sure how to decipher it.
     
  9. Azariel_z

    Member Azariel_z GBAtemp Regular

    Joined:
    Mar 13, 2009
    Messages:
    190
    Country:
    Turkey
    Hey, good thread, i am on teh sam wagon, thinkign to "update" my Wii ( 3.1 U ) but I dont want to crash into official wants that blocks my HB aplications, or isntall/uninstall WADs..
    If you find any info, could you share? i am still wodnerign from where to start, my Wii has a Wasabi v3 from long time ago, and I am still using , and happy, with my firmware, but newer games are forcing updates upon us.. what are you using to install the Ios, what are you running? Any tips?
     
  10. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    go to wum.televas.com and download wii update manager, use that to inject any wii game ISO with whichever update you would like. I would recommend you download 3.2, however make sure you get your region setting correct with WUM before you download (you download the update with WUM) and then use WUM to update your ISO, burn to disc and enjoy!

    I still need to figure out the IOS WADS though, watch this thread, I am sure there will be some solution here soon.
     
  11. jinxvorheeze

    Member jinxvorheeze GBAtemp Advanced Fan

    Joined:
    May 13, 2008
    Messages:
    572
    Country:
    United States
    Just install those 3 IOS files you originally posted using Wad Manager and you'll be all set and up to date on the extra IOS files which are required to play some games. Having a WiiKey you don't need cioscorp, and re-updating to 3.2 wont do you any good either. Rip the IOS files from the MadWorld game disk using WiiScrubber if you need to and install them like any other WAD file.
     
  12. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    In regards to the link below, how far down that list does 3.2U take me?
    http://wiibrew.org/wiki/IOS_History

    Lets say I put in animal crossing (from what I understand it has IOS38), will it automatically update the IOS file? Or will it want to update my system menu along with the IOS update? Would I have to manually install the IOS38 WAD in order to play animal crossing without updating the system menu?

    Is there a hack/program which would block the system update but allow the IOS to be updated from the disc? Or do I always need to updatethe IOS WADS manually?

    Is there not a proper IOS FAQ on the net that would answer all of these questions?


    Edit: Just saw post after making this one jinxvorheeze, thanks for the info. FYI I never re-updated to 3.2U, I updated to 3.2U from 3.1U, I only did this cause I wanted the Wii menu performance and cd performance tweaks offered by 3.2 update.

    So I would install them via HBC? I never actually installed any wads yet.


    @Azariel_z, I would advise to not update past system menu 3.2
     
  13. protomind
    OP

    Newcomer protomind Member

    Joined:
    May 3, 2007
    Messages:
    16
    Country:
    United States
    Lets say I put in animal crossing (from what I understand it has IOS38), will it automatically update the IOS file? Or will it want to update my system menu along with the IOS update? Would I have to manually install the IOS38 WAD in order to play animal crossing without updating the system menu?
     
  14. joinx

    Newcomer joinx Advanced Member

    Joined:
    Apr 4, 2009
    Messages:
    58
    Country:
    Mauritius
    i'm having some prob for running new games..i have modchip firmware 3.2u..will these 3 ios be enough to play those games or i need also to install cios rev13?
     
  15. rambi

    Newcomer rambi Newbie

    Joined:
    Jul 3, 2009
    Messages:
    3
    Country:
    United States
    Currently, i'm on 3.2U and just installed Ciso rev13b. I tried to launch the newer game on neogamma R6 but i got the error saying
    "The Game disc could not be read. Refer to the wii operations manual for details"

    Any kind soul out there could tell me what went wrong and what are the steps to remedy it.
    Thanks in advance
     
  16. joinx

    Newcomer joinx Advanced Member

    Joined:
    Apr 4, 2009
    Messages:
    58
    Country:
    Mauritius
    try to install cios rev 13a..heard it doesn't play with cios rev13b...and installed also these 3 ios...38,53,55
     
  17. rambi

    Newcomer rambi Newbie

    Joined:
    Jul 3, 2009
    Messages:
    3
    Country:
    United States

    i'm new to it...so does it mean that i can install cios rev 13a and it will overwrite the ciosr ev 13b? or do i have to uninstall cios rev13b before installing cios rev13a?
    and how do i install the 3 ios 38, 53, 55? i thought it comes together with the cios rev 13a or 13b files? pardon me for asking such questions because i'm getting abit confused now...
     

Share This Page