Wii U N64 Injection Framebuffer Issues

the_randomizer

The Temp's official fox whisperer
OP
Member
Joined
Apr 29, 2011
Messages
30,979
Trophies
2
Age
36
Location
Dr. Wahwee's castle
XP
18,430
Country
United States
So, I'm trying to inject Zelda OOT Redux into the base OOT game (this ROM hack fixes a lot of issues the OG version had, adds hover/iron boots to the d-pad, faster text speed, many QOL stuff that makes it superior to the vanilla version).
However, the framebuffer effects are completely jacked up in the subscreen menus, like, neon colors and of course the delay. There is no info that I can find on here or with Google, and I've been out of the loop for some time, didn't have my Wii U for a while as I lent it to a family member until today.
@ploggy Do you have any insight or maybe bring me up to speed to see what I can do to fix it? Maybe I'm using the wrong base game,

This is what the ROM hack does to the vanilla game:

https://www.romhacking.net/hacks/5138/

Maybe it's too much for Vessel to handle and it just screws up how the RSP is being emulated? I'm baffled because it otherwise works perfectly fine and at full speed. I also forgot how to adjust it back to 4:3 aspect ratio with the canvas settings in the ROM ini files, so yeah. I'm so out of the loop :P

This what the INI file looks like

Code:
;Ocarina US
[Cheat]
;pause menu
Cheat0 = 2
Cheat0_Addr = 0x801DAE8B
Cheat0_Value = 0x02
Cheat0_Bytes = 1
;Health
Cheat1 = 1
Cheat1_Addr = 0x8011ACAE
Cheat1_Value = 0x01400140
Cheat1_Bytes = 4

[RomOption]
RetraceByVsync = 0
Rumble = 1
PDFURL = "http://m1.nintendo.net/docvc/NUS/USA/CZLE/CZLE_E.pdf"
UseTimer = 1
RSPMultiCore = 0

[RomHack]
;Fix NOA BTS No.115
Count=2
Address0 = 0x175c39b
Type0 = 1
Value0 = 0x3e
Address1 = 0x9443d8
Type1 = 1
Value1 = 0xAE

[Render]
CopyDepthBuffer = 1
NeedTileSizeCheck = 1
ZClip = 0

[FilterHack]
Count = 3

TextureAddress0 = 0x37A630
SumPixel0 = 0xBD076095
Data2_0 = 0x801247
Data3_0 = 0x200000
AlphaTest0 = 250

TextureAddress1 = 0x374830
SumPixel1 = 0x294329A9
Data2_1 = 0x801135
Data3_1 = 0x80000
AlphaTest1 = 250

TextureAddress2 = 0x376530
SumPixel2 = 0x18DDD160
Data2_2 = 0x800055
Data3_2 = 0x80000
AlphaTest2 = 250

[VertexHack]
Count = 6

;Fix NOA BTS No.58
VertexCount0 = 10
VertexAddress0 = 0x22fdd8
TextureAddress0 = 0x37af28
FirstVertex0 = a6:  0b 96 fe fc 27 cd
Value0 = a18:00 02 
00 06 15 95 00 58 22 03
00 07 15 95 00 58 22 03

;Fix NOA BTS No.107
VertexCount1 = 24
VertexAddress1 = 0x241d20
TextureAddress1 = 0x380030
FirstVertex1 = a6:  ff 59 03 e3 15 11
Value1 = a18:00 02 
00 00 ff 59 03 e3 15 21
00 02 fe 76 03 ea 15 27

;Fix NOA BTS No.61 - a
VertexCount2 = 32
VertexAddress2 = 0x241b20
TextureAddress2 = 0x380030
FirstVertex2 = a6: 04 4e 04 54 0c 1b
Value2 = a34:00 04
00 00 04 4e 04 54 0c 20
00 03 04 4e 04 54 0c 20
00 04 04 4e 04 54 0a 9c
00 09 04 4e 04 54 0a 9c

;Fix NOA BTS No.61 - b
VertexCount3 = 13
VertexAddress3 = 0x243fe8
TextureAddress3 = 0x37c830
FirstVertex3 = a6: fd dd 05 b2 0c 84
Value3 = a10:00 01 
00 07 fe 6d 05 aa 05 72

;Fix NOA BTS No.61 - c
VertexCount4 = 32
VertexAddress4 = 0x245808
TextureAddress4 = 0x383830
FirstVertex4 = a6:  04 4e 04 54 0a ef
Value4 = a10:00 01 
00 07 05 16 04 54 0a a0

;Fix NOA BTS No.61 - d
VertexCount5 = 29
VertexAddress5 = 0x2436a8
TextureAddress5 = 0x37c830
FirstVertex5 = a6:  04 17 07 0a 12 30
Value5 = a18:00 02 
00 05 05 0a 05 95 0d 22
00 1b 05 13 05 97 0c e8
 
  • Angry
Reactions: D34DL1N3R

ploggy

WAKA! WAKA!
Member
Joined
Aug 29, 2007
Messages
4,255
Trophies
1
XP
5,937
Country
United Kingdom
So, I'm trying to inject Zelda OOT Redux into the base OOT game (this ROM hack fixes a lot of issues the OG version had, adds hover/iron boots to the d-pad, faster text speed, many QOL stuff that makes it superior to the vanilla version).
However, the framebuffer effects are completely jacked up in the subscreen menus, like, neon colors and of course the delay. There is no info that I can find on here or with Google, and I've been out of the loop for some time, didn't have my Wii U for a while as I lent it to a family member until today.
@ploggy Do you have any insight or maybe bring me up to speed to see what I can do to fix it? Maybe I'm using the wrong base game,

This is what the ROM hack does to the vanilla game:

https://www.romhacking.net/hacks/5138/

Maybe it's too much for Vessel to handle and it just screws up how the RSP is being emulated? I'm baffled because it otherwise works perfectly fine and at full speed. I also forgot how to adjust it back to 4:3 aspect ratio with the canvas settings in the ROM ini files, so yeah. I'm so out of the loop :P

This what the INI file looks like

Code:
;Ocarina US
[Cheat]
;pause menu
Cheat0 = 2
Cheat0_Addr = 0x801DAE8B
Cheat0_Value = 0x02
Cheat0_Bytes = 1
;Health
Cheat1 = 1
Cheat1_Addr = 0x8011ACAE
Cheat1_Value = 0x01400140
Cheat1_Bytes = 4

[RomOption]
RetraceByVsync = 0
Rumble = 1
PDFURL = "http://m1.nintendo.net/docvc/NUS/USA/CZLE/CZLE_E.pdf"
UseTimer = 1
RSPMultiCore = 0

[RomHack]
;Fix NOA BTS No.115
Count=2
Address0 = 0x175c39b
Type0 = 1
Value0 = 0x3e
Address1 = 0x9443d8
Type1 = 1
Value1 = 0xAE

[Render]
CopyDepthBuffer = 1
NeedTileSizeCheck = 1
ZClip = 0

[FilterHack]
Count = 3

TextureAddress0 = 0x37A630
SumPixel0 = 0xBD076095
Data2_0 = 0x801247
Data3_0 = 0x200000
AlphaTest0 = 250

TextureAddress1 = 0x374830
SumPixel1 = 0x294329A9
Data2_1 = 0x801135
Data3_1 = 0x80000
AlphaTest1 = 250

TextureAddress2 = 0x376530
SumPixel2 = 0x18DDD160
Data2_2 = 0x800055
Data3_2 = 0x80000
AlphaTest2 = 250

[VertexHack]
Count = 6

;Fix NOA BTS No.58
VertexCount0 = 10
VertexAddress0 = 0x22fdd8
TextureAddress0 = 0x37af28
FirstVertex0 = a6:  0b 96 fe fc 27 cd
Value0 = a18:00 02
00 06 15 95 00 58 22 03
00 07 15 95 00 58 22 03

;Fix NOA BTS No.107
VertexCount1 = 24
VertexAddress1 = 0x241d20
TextureAddress1 = 0x380030
FirstVertex1 = a6:  ff 59 03 e3 15 11
Value1 = a18:00 02
00 00 ff 59 03 e3 15 21
00 02 fe 76 03 ea 15 27

;Fix NOA BTS No.61 - a
VertexCount2 = 32
VertexAddress2 = 0x241b20
TextureAddress2 = 0x380030
FirstVertex2 = a6: 04 4e 04 54 0c 1b
Value2 = a34:00 04
00 00 04 4e 04 54 0c 20
00 03 04 4e 04 54 0c 20
00 04 04 4e 04 54 0a 9c
00 09 04 4e 04 54 0a 9c

;Fix NOA BTS No.61 - b
VertexCount3 = 13
VertexAddress3 = 0x243fe8
TextureAddress3 = 0x37c830
FirstVertex3 = a6: fd dd 05 b2 0c 84
Value3 = a10:00 01
00 07 fe 6d 05 aa 05 72

;Fix NOA BTS No.61 - c
VertexCount4 = 32
VertexAddress4 = 0x245808
TextureAddress4 = 0x383830
FirstVertex4 = a6:  04 4e 04 54 0a ef
Value4 = a10:00 01
00 07 05 16 04 54 0a a0

;Fix NOA BTS No.61 - d
VertexCount5 = 29
VertexAddress5 = 0x2436a8
TextureAddress5 = 0x37c830
FirstVertex5 = a6:  04 17 07 0a 12 30
Value5 = a18:00 02
00 05 05 0a 05 95 0d 22
00 1b 05 13 05 97 0c e8
Sorry mate It's been so long since I messed with WiiU N64 injects, I've pretty much forgotten everything :P
Try using a newer base game I guess? I don't even know what the newest N64 base is?
 
  • Like
Reactions: the_randomizer

the_randomizer

The Temp's official fox whisperer
OP
Member
Joined
Apr 29, 2011
Messages
30,979
Trophies
2
Age
36
Location
Dr. Wahwee's castle
XP
18,430
Country
United States
Sorry mate It's been so long since I messed with WiiU N64 injects, I've pretty much forgotten everything :P
Try using a newer base game I guess? I don't even know what the newest N64 base is?

It's fine, I'm just trying to find out and reestablish my familiarity with the whole Wii U homebrew stuff. If not, it's no biggie, I have other ways of playing the game :P
 

zerofalcon

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
746
Trophies
0
Location
Somewhere close to my NES
XP
1,982
Country
I need to try with latest patcher64+ tool if repatching the redux mod to ROM can solve that issue, but if not, just change:

[Render]
CopyDepthBuffer = 1

to

[Render]
CopyDepthBuffer = 0

pause menu will be totally black (just the background) instead, better than those glitches.

For the delay after pressing start just change this:

;Ocarina US
[Cheat]
;pause menu
Cheat0 = 2
Cheat0_Addr = 0x801DAE8B

to this

;Ocarina US
[Cheat]
;pause menu
Cheat0 = 2
Cheat0_Addr = 0x801DA5CB
 
  • Like
Reactions: the_randomizer

the_randomizer

The Temp's official fox whisperer
OP
Member
Joined
Apr 29, 2011
Messages
30,979
Trophies
2
Age
36
Location
Dr. Wahwee's castle
XP
18,430
Country
United States
I need to try with latest patcher64+ tool if repatching the redux mod to ROM can solve that issue, but if not, just change:

[Render]
CopyDepthBuffer = 1

to

[Render]
CopyDepthBuffer = 0

pause menu will be totally black (just the background) instead, better than those glitches.

For the delay after pressing start just change this:

;Ocarina US
[Cheat]
;pause menu
Cheat0 = 2
Cheat0_Addr = 0x801DAE8B

to this

;Ocarina US
[Cheat]
;pause menu
Cheat0 = 2
Cheat0_Addr = 0x801DA5CB
I'll give that a shot, thanks ^^

BTW, what exactly is the patcher64 tool?

Edit: If you can find out what's going on and get the background to emulate properly with framebuffer, that'd be awesome, keep me posted
 
  • Angry
Reactions: D34DL1N3R

pedro702

Well-Known Member
Member
Joined
Mar 3, 2014
Messages
11,357
Trophies
1
Age
31
XP
6,312
Country
Portugal
what im guessing is the new mod doesnt have the same adresses that the original has therefore it fails to patch them.
 

the_randomizer

The Temp's official fox whisperer
OP
Member
Joined
Apr 29, 2011
Messages
30,979
Trophies
2
Age
36
Location
Dr. Wahwee's castle
XP
18,430
Country
United States
what im guessing is the new mod doesnt have the same adresses that the original has therefore it fails to patch them.
Ah crap. Figured as much >.> Jusy trying to get back into the Wii U scene. I still have other ways to play the ROM hack but wanted to check anyway, you know? If it can be resolved great, but if not, oh well. Sorry to bother with such a trivial issue 😑
 
  • Angry
Reactions: D34DL1N3R

pedro702

Well-Known Member
Member
Joined
Mar 3, 2014
Messages
11,357
Trophies
1
Age
31
XP
6,312
Country
Portugal
Ah crap. Figured as much >.> Jusy trying to get back into the Wii U scene. I still have other ways to play the ROM hack but wanted to check anyway, you know? If it can be resolved great, but if not, oh well. Sorry to bother with such a trivial issue 😑
you can probably played it just fine on not64/wii64 no?
 

the_randomizer

The Temp's official fox whisperer
OP
Member
Joined
Apr 29, 2011
Messages
30,979
Trophies
2
Age
36
Location
Dr. Wahwee's castle
XP
18,430
Country
United States
you can probably played it just fine on not64/wii64 no?
Admittedly not a fan of the emulator screen tearing and depth buffer issues where there's culling glitches. No vsync and FB causes issues. I'll stick to other emulators. Damn I'm sorry for wasting your time :sad:
 
  • Angry
Reactions: D34DL1N3R
General chit-chat
Help Users
  • No one is chatting at the moment.
    Veho @ Veho: https://i.imgur.com/8Bj96q1.mp4